View Issue Details

IDProjectCategoryView StatusLast Update
0001039bareos-core[All Projects] webuipublic2019-02-15 10:35
Reporteralex-dvvAssigned To 
Status newResolutionopen 
PlatformLinuxOSDebianOS Version9
Product Version18.2.4rc2 
Target VersionFixed in Version 
Summary0001039: Cant login in webui
DescriptionHi!Cant login in webui
Error: Sorry, can not authenticate. Wrong username and/or password.
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action




2019-01-31 15:44

reporter   ~0003228


The same problem on my SLES 12.3, Version 18.2.5-136.1 (SUSE Repository).

I tracked the problem down to the following log messages (debug mode 100 and gdb running with breakpoint at lib/

""" (100): lib/ Construct BareosSocket
[New Thread 0x7fffe3fff700 (LWP 19998)] (100): include/jcr.h:320-0 Construct JobControlRecord (200): lib/ Identified from Bareos handshake: admin-R_CONSOLE recognized version: 18.2
[Switching to Thread 0x7fffe3fff700 (LWP 19998)]

Thread 16 "bareos-dir" hit Breakpoint 1, GetHandshakeMode (config=0x6f4530, bs=0x7fffec001fe8, bs@entry=0x6d63a0 <std::string::_Rep::_S_empty_rep_storage>)
    at /usr/src/debug/bareos-18.2.5/src/lib/
69 Dmsg1(200, "Connection to %s will be denied due to configuration mismatch\n", client_name.c_str());
(gdb) c
Continuing. (200): lib/ Connection to admin will be denied due to configuration mismatch (100): lib/ Destruct BareosSocket (100): include/jcr.h:324-0 Destruct JobControlRecord
[Thread 0x7fffe3fff700 (LWP 19998) exited]

the relevant part of the code is giving for Bareos >=18.2 only a "ConnectionHandshakeMode::PerformCleartextHandshake" if "tls_policy == kBnetTlsNone".


2019-01-31 16:03

reporter   ~0003230

I could resolve the problem by following the suggestion in "/etc/bareos/bareos-dir.d/console/admin.conf.example" to disable TLS or use Certificates. (It should only be disabled if the director is only listening on localhost, because otherwise passwords might be transferred nonencrypted over the network.)

So for me it looks like a configuration problem resulting from non adapted old configurations.


2019-02-01 07:20

reporter   ~0003232

Same Problem here after updating from 17.4 to 18.2.5, solved it with adding "TLS Enable = No" in the console config

But now I can't access to webui, gui is reporting:

Sorry, it seems you are not authorized to run this module. If you think this is an error, please contact your local administrator.
Please read the Bareos documentation for any additional information on how to configure the Command ACL directive of your Console/Profile resources. Following is a list of required commands which need to be in your Command ACL to run this module properly:


I checked up my webui-admin profile, it containes the lines from 18.2.5 documentation....

Unbenannt.png (122,585 bytes)
Unbenannt.png (122,585 bytes)


2019-02-01 07:25

reporter   ~0003233

Doesn't come anyway, here's the config:
onsole {
  Name = admin
  Password = ******
  Profile = webui-admin
  TLS Enable = No


2019-02-01 07:31

reporter   ~0003234

I went in !!! But the error is the same:Sorry, it seems you are not authorized to run this module. If you think this is an error, please contact your local administrator.


2019-02-01 12:44

reporter   ~0003238

It worked!I do not really like!


2019-02-01 23:05

reporter   ~0003240

alex, it is working on your server? what did you change?


2019-02-01 23:59

reporter   ~0003241

uhh, just looked at my system, and webui is now working without any changes! nice self-healing!!


2019-02-04 18:27

reporter   ~0003244

I have the blank page after login like teka74 did. It did self heal eventually, but then closing the webui window and trying to log back in returned the issue.

httpd error log shows:
[Mon Feb 04 11:20:53.319812 2019] [:error] [pid 3414] [client x.x.x.x:52713] PHP Notice: Undefined variable: form in /usr/share/bareos-webui/module/Auth/view/auth/auth/login.phtml on line 45, referer: http://x.x.x.x/bareos-webui/auth/login
[Mon Feb 04 11:20:53.319849 2019] [:error] [pid 3414] [client x.x.x.x:52713] PHP Fatal error: Call to a member function prepare() on a non-object in /usr/share/bareos-webui/module/Auth/view/auth/auth/login.phtml on line 45, referer: http://x.x.x.x/bareos-webui/auth/login

When it works correctly, those errors do not show up.


2019-02-04 23:24

reporter   ~0003245

agree with murrdyn, partially I can login in webui, sometimes blank window appears...


2019-02-07 16:07

reporter   ~0003254

Hi, same problem in Centos 7.6.1810 fresh install bareos-dir version 18.2.5:

[Thu Feb 07 15:27:29.244019 2019] [:error] [pid 25046] [client] admin, referer: http://bareosdir00.mgmt/bareos-webui/
[Thu Feb 07 15:27:29.244068 2019] [:error] [pid 25046] [client] console_name: admin, referer: http://bareosdir00.mgmt/bareos-webui/
[Thu Feb 07 15:27:29.245627 2019] [:error] [pid 25046] [client] PHP Notice: fwrite(): send of 26 bytes failed with errno=104 Connection reset by peer in /usr/share/bareos-webui/vendor/Bareos/library/Bareos/BSock/BareosBSock.php on line 219, referer: http://bareosdir00.mgmt/bareos-webui/


2019-02-12 14:02


webuiproblem.png (95,893 bytes)
webuiproblem.png (95,893 bytes)


2019-02-12 14:02

reporter   ~0003257

I have similar problem, if I try to login, I get next message:


2019-02-13 10:57




2019-02-13 10:57

reporter   ~0003258

This issue It seems to be the same to issue number 0001033 ( that's it's close and resolve in version 18.2.4rc2-76.1.

In my Centos 7.6 installations with php verison 7.2.15 with bareos 18.2.5 the error persist ...

[Wed Feb 13 10:35:08.142474 2019] [php7:notice] [pid 9012] [client] PHP Notice: fwrite(): send of 26 bytes failed with errno=104 Connection reset by peer
in /usr/share/bareos-webui/vendor/Bareos/library/Bareos/BSock/BareosBSock.php on line 219

I'm sure that the credential are correct.


2019-02-13 19:00

reporter   ~0003259

A possibly helpful observation I have made concerning this bug:

Typically, if you remain logged in and your session expires by the time you try to perform an action, you have to log back in. This is when you encounter this bug.

Following a long idle period, if you avoid performing any action, so as to avoid being notified that your session has expired, and instead click your username and properly logout from the drop-down, you can log back in successfully without triggering this bug.

In fact, I have found that if I always deliberately logout, such that I avoid triggering the session expiry notice, I can always successfully login on the next attempt.

I have not tested a scenario of closing all browser windows then trying to login. But so far it seems that deliberately logging out -- even after session expiry (but without doing anything to trigger a session expiry notification) -- avoids triggering this bug.

Hope that helps with figuring out where the bug resides.


2019-02-14 09:46

reporter   ~0003261

In my case the errot occurs in a fresh install and I have no previous sessions ..., otherwise I have test in a Debian 9 fresh install and I have the same problem!!


2019-02-15 10:32

reporter   ~0003263

From a similar issue that previously happen in the docker version of bareos jukito show me that putting the options TLS Enable = No in /etc/bareos/bareos-dir.d/console/admin.conf file:

Console {
  Name = admin
  Password = *****
  Profile = webui-admin
  TLS Enable = No

correct the problem.


2019-02-15 10:35

reporter   ~0003264

Sorry, I've forgotten to include the link for bareos docker same issue:

Issue History

Date Modified Username Field Change
2019-01-30 07:40 alex-dvv New Issue
2019-01-31 15:44 noone Note Added: 0003228
2019-01-31 16:03 noone Note Added: 0003230
2019-02-01 07:20 teka74 File Added: Unbenannt.png
2019-02-01 07:20 teka74 Note Added: 0003232
2019-02-01 07:25 alex-dvv Note Added: 0003233
2019-02-01 07:31 alex-dvv Note Added: 0003234
2019-02-01 12:44 alex-dvv Note Added: 0003238
2019-02-01 23:05 teka74 Note Added: 0003240
2019-02-01 23:59 teka74 Note Added: 0003241
2019-02-04 18:27 murrdyn Note Added: 0003244
2019-02-04 23:24 teka74 Note Added: 0003245
2019-02-07 16:08 c0r3dump3d Note Added: 0003254
2019-02-12 14:02 IvanBayan File Added: webuiproblem.png
2019-02-12 14:02 IvanBayan Note Added: 0003257
2019-02-13 10:57 c0r3dump3d File Added: Captura de pantalla de 2019-02-13 10-56-37.png
2019-02-13 10:57 c0r3dump3d Note Added: 0003258
2019-02-13 19:00 xyros Note Added: 0003259
2019-02-14 09:46 c0r3dump3d Note Added: 0003261
2019-02-15 10:32 c0r3dump3d Note Added: 0003263
2019-02-15 10:35 c0r3dump3d Note Added: 0003264