View Issue Details

IDProjectCategoryView StatusLast Update
0001033bareos-core[All Projects] webuipublic2019-01-16 17:08
ReportervladAssigned Toarogge 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSDebianOS Version9
Product Version18.2.4-rc1 
Target VersionFixed in Version 
Summary0001033: Cant login in webui
DescriptionHallo!
My Issue: Cant login in webui
Error: Sorry, can not authenticate. Wrong username and/or password.

/etc/bareos/bareos-dir.d/console/admin.conf
#
# Restricted console used by bareos-webui
#
Console {
  Name = administrator
  Password = "*************"
  Profile = "webui-admin"
}
Additional InformationApache log:

[Fri Jan 11 11:19:35.303427 2019] [:error] [pid 24528] [client 192.168.25.3:58241] administrator, referer: http://192.168.29.250/bareos-webui/
[Fri Jan 11 11:19:35.303483 2019] [:error] [pid 24528] [client 192.168.25.3:58241] console_name: administrator, referer: http://192.168.29.250/bareos-webui/
[Fri Jan 11 11:19:35.304124 2019] [:error] [pid 24528] [client 192.168.25.3:58241] PHP Notice: fwrite(): send of 26 bytes failed with errno=104 Connection reset by peer in /usr/share/bareos-webui/vendor/Bareos/library/Bareos/BSock/BareosBSock.php on line 211, referer: http://bareos/bareos-webui/
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

vlad

vlad

2019-01-11 09:28

reporter  

error_bareos_webui.JPG (62,634 bytes)
error_bareos_webui.JPG (62,634 bytes)
arogge

arogge

2019-01-11 13:42

developer   ~0003171

Did you follow the upgrade documentation?
Take a look at:
https://docs.bareos.org/developers/releasenotes.html#backward-compatibility
vlad

vlad

2019-01-11 15:22

reporter   ~0003172

Yes, i followed this documentation. Tls Enable = no or false everywhere.
End all daemons work, end run. (dir, sd, fd)

/etc/bareos/bareos-dir.d/director/bareos-dir.conf
Director { # define myself
  Name = bareos-dir
  QueryFile = "/usr/lib/bareos/scripts/query.sql"
  Maximum Concurrent Jobs = 10
  Password = "**********" # Console password
  Messages = Daemon
  Tls Enable = false
# TLS Enable = no
# Auditing = no
}
/etc/bareos/bareos-dir.d/client/bareos-fd.conf
Client {
  Name = bareos-fd
  Description = "Client resource of the Director itself."
  Address = localhost
  Password = "***********" # password for FileDaemon
  TLS Enable = no
}

/etc/bareos/bareos-fd.d/director/bareos-dir.conf
Director {
  Name = bareos-dir
  Password = "***********"
  Description = "Allow the configured Director to access this file daemon."
  TLS Enable = no
}
gallan

gallan

2019-01-11 18:39

reporter   ~0003173

Last edited: 2019-01-11 18:42

View 2 revisions

Hello,
I had exactly the same error after a bareos upgrade on Ubuntu 18.04 (from a 18.2.4rc-2-XX version to the last one 18.2.4rc2-86.1)
Bareos works well from bconsole, but bareos-webui refuse connection with the same error :
PHP Notice: fwrite(): send of 26 bytes failed with errno=104 Connection reset by peer in /usr/share/bareos-webui/vendor/Bareos/library/Bareos/BSock/BareosBSock.php on line 211, referer: http://51.38.55.74/bareos-webui/

Webui veriosn is 18.2.4rc2-76.1. It worked perfectly just before bareos upgrade

gallan

gallan

2019-01-12 09:14

reporter   ~0003174

Hi,

I've just passed the next patch on Webui files, and my Webui is now available :
https://github.com/bareos/bareos/commit/d620c4a6b02a4889b40498a3e407421e4eb151ae?diff=unified
arogge

arogge

2019-01-16 09:40

developer   ~0003180

do you need any further feedback on this or does it work as expected now?
gallan

gallan

2019-01-16 09:44

reporter   ~0003181

it works for me after applying the patch https://github.com/bareos/bareos/commit/d620c4a6b02a4889b40498a3e407421e4eb151ae?diff=unified on source file for webui.
I think it will work with the distribution (Ubuntu 18.04 on my side) when you will apply this patch on it. The webui installed directly with my distribution doesn't work.
arogge

arogge

2019-01-16 17:07

developer   ~0003198

The problem happens in the 18.2 release candidate. As it is already fixed in the dev-branch the final release will contain the fix.

Related Changesets

bareos: dev d620c4a6

2019-01-11 11:09:12

pstorz

Ported: N/A

Details Diff
webui: adapt BareosBSock.php to current console protocol

- regress-config-webui: removed unneeded cmake settings
- webui/CMakeLists.txt accept FULLVERSION as parameter,
try to extract from version.h if not given.

- removed version.txt, instead added version.php which is included
and contains full and short version
Affected Issues
0001033
mod - regress/scripts/regress-config-webui Diff File
mod - webui/CMakeLists.txt Diff File
add - webui/cmake/BareosExtractVersionInfo.cmake Diff File
mod - webui/debian/rules Diff File
mod - webui/module/Application/view/layout/login.phtml Diff File
mod - webui/packaging/obs/bareos-webui.spec Diff File
mod - webui/vendor/Bareos/library/Bareos/BSock/BareosBSock.php Diff File
add - webui/version.php.in Diff File
rm - webui/version.txt Diff File

Issue History

Date Modified Username Field Change
2019-01-11 09:28 vlad New Issue
2019-01-11 09:28 vlad File Added: error_bareos_webui.JPG
2019-01-11 13:41 arogge Assigned To => arogge
2019-01-11 13:41 arogge Status new => assigned
2019-01-11 13:42 arogge Note Added: 0003171
2019-01-11 13:42 arogge Status assigned => feedback
2019-01-11 15:22 vlad Note Added: 0003172
2019-01-11 15:22 vlad Status feedback => assigned
2019-01-11 18:39 gallan Note Added: 0003173
2019-01-11 18:42 gallan Note Edited: 0003173 View Revisions
2019-01-12 09:14 gallan Note Added: 0003174
2019-01-16 09:40 arogge Note Added: 0003180
2019-01-16 09:40 arogge Status assigned => feedback
2019-01-16 09:44 gallan Note Added: 0003181
2019-01-16 17:07 arogge Note Added: 0003198
2019-01-16 17:07 arogge Status feedback => resolved
2019-01-16 17:07 arogge Resolution open => fixed
2019-01-16 17:08 arogge Changeset attached => bareos dev d620c4a6