View Issue Details

IDProjectCategoryView StatusLast Update
0000004bareos-core[All Projects] installer / packagespublic2013-02-12 14:17
ReportermaikAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformOSWindowsOS Version7 Professional
Product Version 
Target VersionFixed in Version 
Summary0000004: Winbareos installer does not write config
DescriptionWinbareos installer does not seem to write config files - at least not in the expected directory. Expected them to be in the same directory as they used to be with B*cula.

They are not linked in the task-menu, neither.

Really not there or moved elsewhere and not documented?
Additional Informationwinbareos-12.4.0-64-bit-r7.1.exe
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

maik

maik

2012-12-01 14:19

administrator  

maik

maik

2012-12-01 14:46

administrator   ~0000001

Found out:
Configs now at c:\ProgramData\Bareos.

If there are existing configs while installer runs, new configs are stored as *.new (e.g. bareos-fd.conf.new). Hence software doesn't work,
if again installed after an uninstall with wrong configuration.

This makes user thing there is a bug despite having entered all config data correctly during installation.

Solution should be:
- rename old config to *old and install new config properly
OR
- ask user to confirm to overwrite existing config
pstorz

pstorz

2012-12-03 16:39

administrator   ~0000004

The new installer (-8.1) now creates shortcuts in the startmenu for each config file.

Also, if config files exist, they are moved to *.old and the new ones are installed in the right path so that they are used.
When doing this, the user is informed that the file was moved to *.old.
pstorz

pstorz

2012-12-03 16:54

administrator   ~0000008

Please give feedback
maik

maik

2012-12-03 21:23

administrator   ~0000013

with 8.1 even worse: there are no config files at all written to c:\ProgramData\Bareos - directory is empty. Links in task menu are present.
maik

maik

2012-12-10 16:55

administrator   ~0000016

Problem seems to be related to old bacula installation on that system. This does not seem to work.

Make sure to first uninstall bacula before actually installing bareos.

Issue History

Date Modified Username Field Change
2012-12-01 14:19 maik New Issue
2012-12-01 14:19 maik File Added: winbareos_without_config.PNG
2012-12-01 14:46 maik Note Added: 0000001
2012-12-03 16:39 pstorz Note Added: 0000004
2012-12-03 16:54 pstorz Note Added: 0000008
2012-12-03 16:54 pstorz Assigned To => pstorz
2012-12-03 16:54 pstorz Status new => confirmed
2012-12-03 21:23 maik Note Added: 0000013
2012-12-10 13:57 maik Category General => installer / packages
2012-12-10 16:55 maik Note Added: 0000016
2013-02-12 14:17 pstorz Assigned To pstorz =>
2013-02-12 14:17 pstorz Status confirmed => closed
2013-02-12 14:17 pstorz Resolution open => unable to reproduce