View Issue Details

IDProjectCategoryView StatusLast Update
0000003bareos-core[All Projects] installer / packagespublic2013-02-20 07:29
ReportermaikAssigned To 
PrioritylowSeverityminorReproducibilityhave not tried
Status closedResolutionsuspended 
PlatformOSWindowsOS Version7 Professional
Product Version 
Target VersionFixed in Version 
Summary0000003: winbareos uninstaller incomplete
DescriptionIf tray monitor is running, the uninstaller runs incomplete (tra-monitor is not stopped, bareos directory and some files remain undeleted).
Steps To Reproduceinstall winbareos with tray monitor, start traymonitor, uninstall winbareos
Additional Informationwinbareos-12.4.0-64-bit-r6.1.exe
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

pstorz

pstorz

2012-12-03 16:40

administrator   ~0000005

I switched form the KillProcDLL plugin to the KillProcWMI Plugin, because the old one was not able to kill 64Bit executables while being a 32Bit executable itself.

My first tests looked good, but a confirm that this works is needed.
pstorz

pstorz

2012-12-03 16:50

administrator   ~0000006

Ok
maik

maik

2012-12-12 21:56

administrator   ~0000025

I had a similiar problem again:

First i made a mistake: installed 64Bit Version on 32 bit windows. Installer went through without any warning.

Tray monitor didn't start but did not get uninstalled completely. There was a bareos directory with tra-monitor inside left.

After that the correct 32-bit installer hung. I had to remove any remains manually, before the installer succeeded.

After that it worked on a Windows 7 Home pro.

Used winbareos-12.4.0-32-bit-r11.2.exe.
pstorz

pstorz

2013-02-20 07:29

administrator   ~0000137

As we don't install the tray monitor, this problem will not show up until we do.

Issue History

Date Modified Username Field Change
2012-12-01 14:09 maik New Issue
2012-12-03 16:40 pstorz Note Added: 0000005
2012-12-03 16:50 pstorz Note Added: 0000006
2012-12-03 16:50 pstorz Assigned To => pstorz
2012-12-03 16:50 pstorz Status new => acknowledged
2012-12-03 16:51 pstorz Status acknowledged => assigned
2012-12-10 13:56 maik Category General => installer / packages
2012-12-12 21:56 maik Note Added: 0000025
2013-02-20 07:29 pstorz Note Added: 0000137
2013-02-20 07:29 pstorz Assigned To pstorz =>
2013-02-20 07:29 pstorz Status assigned => closed
2013-02-20 07:29 pstorz Resolution open => suspended