View Issue Details

IDProjectCategoryView StatusLast Update
0000354bareos-core[All Projects] directorpublic2015-03-31 14:43
ReportersseitzAssigned Topstorz 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformHardwareOSUbuntuOS Version14.04 / amd64
Product Version14.2.1 
Target VersionFixed in Version 
Summary0000354: bconsole restore / dir on (at least one) directory crashes bareos-dir
DescriptionWhen running bconsole entering the following commands, will reproducable crash bareos-dir. The given backup job is a Full Backup.

restore jobid=20 client=sseitz-fd
cd /home
cd s.seitz
dir

The complete output with some filenames redacted has been attached.

The notification email notices a debugger, I'ld reproduce it with a debugger attached but didn't find any documentation on how to do this.
Additional InformationMail Output:

Date: Wed, 29 Oct 2014 12:11:58 +0100 (CET)
From: root@localhost
To: root@localhost
Subject: Bareos NONE traceback of bareos-dir on backup01

No debugger available on this platform, please install one to get proper stack traces

TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Relationships

has duplicate 0000383 resolved dir command in bconsole crash bareos-dir 

Activities

sseitz

sseitz

2014-10-29 12:22

reporter  

bconsole-restore-dir-crash.txt (2,083 bytes)
root@backup01:~# bconsole
Connecting to Director backup01:9101
1000 OK: backup01-dir Version: 14.2.1 (12 September 2014)
Enter a period to cancel a command.
*restore jobid=20 client=sseitz-fd
Using Catalog "MyCatalog"
You have selected the following JobId: 20

Building directory tree for JobId(s) 20 ...  +++++++++++++++++++++++++++++++++++++++++++++
823,638 files inserted into the tree.

You are now entering file selection mode where you add (mark) and
remove (unmark) files to be restored. No files are initially added, unless
you used the "all" keyword on the command line.
Enter "done" to leave this mode.

cwd is: /
$ cd /home
cwd is: /home/
$ cd s.seitz
cwd is: /home/s.seitz/
$ dir
drwxr-xr-x  22 10020    users             4096  2014-08-12 18:18:10  /home/s.seitz/Öffentlich/
drwxr-xr-x   2 10020    users             4096  2014-04-25 17:53:39  /home/s.seitz/.DownloadManager/
-rw-------   1 10020    users            69524  2014-10-17 17:45:56  /home/s.seitz/.ICEauthority
drwxrwxr-x   2 10020    users             4096  2014-09-11 13:21:34  /home/s.seitz/.InstallAnywhere/
[... removed 151 lines of directory output ...]
-rw-rw-r--   1 10020    users             5258  2013-12-03 10:14:08  /home/s.seitz/Nagios_abfragen.xlsx
drwxr-xr-x   4 10020    users             4096  2014-06-13 15:21:48  /home/s.seitz/PROJEKTE/
-rw-r--r--   1 10020    users              315  2013-12-03 10:12:06  /home/s.seitz/RewriteBeispiel.txt
drwxr-xr-x   3 10020    users             4096  2014-08-12 18:22:07  /home/s.seitz/Seafile/
-rw-r--r--   1 10020    users           147871  2013-12-03 10:12:06  /home/s.seitz/Serverangebot-XXX-XXXXXXXX.pdf
��������������������������������������������������������������������������������������������������������������������������������
Sie haben neue Post in /var/mail/root.
root@backup01:~# 
sseitz

sseitz

2014-10-29 12:50

reporter  

bconsole-restore-dir-crash-gdb-backtrace.txt (665 bytes)
Created /var/lib/bareos/bareos-dir.core.24036 for doing postmortem debugging
[New LWP 24037]
[New LWP 24043]
[New LWP 24044]
[New LWP 24045]
[New LWP 24057]
[New LWP 24036]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Core was generated by `/usr/sbin/bareos-dir'.
#0  0x00007f4662033b9d in nanosleep () at ../sysdeps/unix/syscall-template.S:81
81      ../sysdeps/unix/syscall-template.S: Datei oder Verzeichnis nicht gefunden.
$1 = 1801675106
$2 = 37761112
$3 = 37761176
/usr/lib/bareos/scripts/btraceback.gdb:4: Error in sourced command file:
No symbol "catalog_db" in current context.


sseitz

sseitz

2014-11-03 10:13

reporter   ~0001027

backup01-dir: sql_get.c:136-0 Query=SELECT FileId, LStat, MD5 FROM File WHERE File.JobId=17 AND File.PathId=9900 AND File.FilenameId=1
backup01-dir: sql_get.c:140-0 get_file_record num_rows=1
backup01-dir: sql_get.c:62-0 db_get_file_attributes_record fname=/home/s.seitz/Serverangebot-ICO-a258387.pdf
backup01-dir: sql_get.c:136-0 Query=SELECT FileId, LStat, MD5 FROM File WHERE File.JobId=17 AND File.PathId=254 AND File.FilenameId=148747
backup01-dir: sql_get.c:140-0 get_file_record num_rows=1
backup01-dir: sql_get.c:62-0 db_get_file_attributes_record fname=/home/s.seitz/Serverdokumentation_mit_Racktables_und_SNMP.odp
backup01-dir: sql_get.c:136-0 Query=SELECT FileId, LStat, MD5 FROM File WHERE File.JobId=17 AND File.PathId=254 AND File.FilenameId=8238
backup01-dir: sql_get.c:140-0 get_file_record num_rows=1
backup01-dir: sql_get.c:62-0 db_get_file_attributes_record fname=/home/s.seitz/Ubuntu One/
backup01-dir: sql_get.c:136-0 Query=SELECT FileId, LStat, MD5 FROM File WHERE File.JobId=17 AND File.PathId=6887 AND File.FilenameId=1
backup01-dir: sql_get.c:140-0 get_file_record num_rows=1

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7ffff1c47700 (LWP 24417)]
0x00007ffff70c5a49 in sm_realloc_pool_memory (fname=fname@entry=0x7ffff70e190d "message.c", lineno=lineno@entry=1536, obuf=<optimized out>, size=size@entry=34) at mem_pool.c:203
203 mem_pool.c: Datei oder Verzeichnis nicht gefunden.
(gdb) bt
#0 0x00007ffff70c5a49 in sm_realloc_pool_memory (fname=fname@entry=0x7ffff70e190d "message.c", lineno=lineno@entry=1536, obuf=<optimized out>, size=size@entry=34)
    at mem_pool.c:203
0000001 0x00007ffff70c8441 in Mmsg (pool_buf=@0x7ffff1c463f8: 0x7fffe0004150 '\252' <repeats 40 times>, "a", fmt=fmt@entry=0x4851d8 "%s %2d %-8.8s %-8.8s %12.12s %s %c%s")
    at message.c:1536
0000002 0x00000000004640b2 in ls_output (dot_cmd=false, statp=0x7ffff1c46400, tag=<optimized out>, fname=0x7fffe000c700 "/home/s.seitz/Ubuntu One/",
    buf=0x7fffe0004150 '\252' <repeats 40 times>, "a", guid=0x7fffe0003498) at ua_tree.c:824
0000003 do_dircmd (ua=0x7fffe000c2e8, dot_cmd=false, tree=<optimized out>) at ua_tree.c:891
0000004 0x0000000000464b8c in user_select_files_from_tree (tree=tree@entry=0x7ffff1c46850) at ua_tree.c:158
0000005 0x0000000000455895 in build_directory_tree (rx=0x7ffff1c469a0, ua=0x7fffe0002c58) at ua_restore.c:1256
0000006 restore_cmd (ua=0x7fffe0002c58, cmd=<optimized out>) at ua_restore.c:194
0000007 0x000000000044304c in do_a_command (ua=0x7fffe0002c58) at ua_cmds.c:296
0000008 0x000000000045f562 in handle_UA_client_request (arg=0x7fffe40011a8) at ua_server.c:160
0000009 0x00007ffff70dbe05 in workq_server (arg=arg@entry=0x6991c0 <ua_workq>) at workq.c:335
0000010 0x00007ffff70c4625 in lmgr_thread_launcher (x=0x7fffe4002658) at lockmgr.c:932
0000011 0x00007ffff6a9f182 in start_thread (arg=0x7ffff1c47700) at pthread_create.c:312
0000012 0x00007ffff64c7fbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111
pstorz

pstorz

2014-11-03 10:56

administrator   ~0001028

Cannot be replayed in Testinstallation :(
pstorz

pstorz

2015-03-31 14:43

administrator   ~0001670

Is duplicate of 0000383

Issue History

Date Modified Username Field Change
2014-10-29 12:22 sseitz New Issue
2014-10-29 12:22 sseitz File Added: bconsole-restore-dir-crash.txt
2014-10-29 12:50 sseitz File Added: bconsole-restore-dir-crash-gdb-backtrace.txt
2014-11-03 10:13 sseitz Note Added: 0001027
2014-11-03 10:17 pstorz Assigned To => pstorz
2014-11-03 10:17 pstorz Status new => assigned
2014-11-03 10:56 pstorz Note Added: 0001028
2015-01-19 12:29 maik Relationship added has duplicate 0000383
2015-03-31 14:43 pstorz Note Added: 0001670
2015-03-31 14:43 pstorz Status assigned => closed
2015-03-31 14:43 pstorz Resolution open => fixed