View Issue Details

IDProjectCategoryView StatusLast Update
0000216bareos-core[All Projects] batpublic2015-03-25 19:18
ReporternicklasAssigned Tomvwieringen 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSArch LinuxOS Version3
Product Version13.2.0 
Target VersionFixed in Version 
Summary0000216: bat segfaults when Password is missing from configuration
DescriptionRunning bat without a Password field in the configuration would make it crash with a segfault. If password is required even with certificate logon, then an error message would be more user friendly.

Git version:
$ git describe --always
d21f758
Steps To ReproduceConfiguration file:

Director {
  Name = backup-dir
  DIRport = 9101
  address = backup.example.com
# Password = "secretpassword"
  
  TLS Enable = yes
  TLS Require = yes
# TLS Verify Peer = yes
  TLS CA Certificate File = /home/user/.pki/bareos/cacert.pem
  TLS Certificate = /home/userpki/bareos/clientcert.pem
  TLS Key = /home/user/.pki/bareos/clientkey.pem
}

$ bat -c ~/.bat
Additional Informationgdb traceback if of any use:


#0 0x00007ffff5e447f1 in __strlen_sse2_pminub () from /usr/lib/libc.so.6
0000001 0x00007ffff798ce66 in cram_md5_respond(BSOCK*, char const*, int*, int*) () from /home/user/abs/bareos-bat/src/bareos/src/lib/.libs/libbareos-12.4.4.so
0000002 0x000000000042aa88 in DirComm::authenticate_director(JCR*, DIRRES*, CONRES*, char*, int) ()
0000003 0x000000000042968e in DirComm::connect_dir() ()
0000004 0x000000000042b69c in Console::connect_dir() ()
0000005 0x000000000041d340 in MainWin::MainWin(QWidget*) ()
0000006 0x00000000004149f9 in main ()
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

mvwieringen

mvwieringen

2013-08-15 11:40

developer   ~0000633

Fix committed to bareos bareos-12.4 branch with changesetid 1073.
mvwieringen

mvwieringen

2013-08-15 11:40

developer   ~0000634

Fix committed to bareos master branch with changesetid 1074.
mvwieringen

mvwieringen

2013-08-15 11:40

developer   ~0000635

Fix committed to bareos bareos-13.2 branch with changesetid 1075.
mvwieringen

mvwieringen

2015-03-25 16:51

developer   ~0001364

Fix committed to bareos2015 bareos-14.2 branch with changesetid 5055.
joergs

joergs

2015-03-25 19:18

administrator   ~0001517

Due to the reimport of the Github repository to bugs.bareos.org, the status of some tickets have been changed. These tickets will be closed again.
Sorry for the noise.

Related Changesets

bareos: bareos-12.4 c77ca0c5

2013-08-15 09:36:42

mvwieringen

Ported: N/A

Details Diff
BAT segfaults when Password is missing from configuration

Fixes 0000216: bat segfaults when Password is missing from configuration
Affected Issues
0000216
mod - src/qt-console/bat_conf.cpp Diff File

bareos: master a7cf24b5

2013-08-15 09:36:42

mvwieringen

Ported: N/A

Details Diff
BAT segfaults when Password is missing from configuration

Fixes 0000216: bat segfaults when Password is missing from configuration
Affected Issues
0000216
mod - src/qt-console/bat_conf.cpp Diff File

bareos: bareos-13.2 8b737aab

2013-08-15 09:36:42

mvwieringen

Ported: N/A

Details Diff
BAT segfaults when Password is missing from configuration

Fixes 0000216: bat segfaults when Password is missing from configuration
Affected Issues
0000216
mod - src/qt-console/bat_conf.cpp Diff File

bareos2015: bareos-12.4 1ef3dec8

2013-08-15 11:36:42

mvwieringen

Ported: N/A

Details Diff
BAT segfaults when Password is missing from configuration

Fixes 0000216: bat segfaults when Password is missing from configuration
Affected Issues
0000216
mod - src/qt-console/bat_conf.cpp Diff File

bareos2015: bareos-13.2 7bc96b38

2013-08-15 11:36:42

mvwieringen

Ported: N/A

Details Diff
BAT segfaults when Password is missing from configuration

Fixes 0000216: bat segfaults when Password is missing from configuration
Affected Issues
0000216
mod - src/qt-console/bat_conf.cpp Diff File

bareos2015: bareos-14.2 83dffd81

2013-08-15 11:36:42

mvwieringen

Ported: N/A

Details Diff
BAT segfaults when Password is missing from configuration

Fixes 0000216: bat segfaults when Password is missing from configuration
Affected Issues
0000216
mod - src/qt-console/bat_conf.cpp Diff File

Issue History

Date Modified Username Field Change
2013-08-15 11:29 nicklas New Issue
2013-08-15 11:40 mvwieringen Changeset attached => bareos bareos-12.4 c77ca0c5
2013-08-15 11:40 mvwieringen Note Added: 0000633
2013-08-15 11:40 mvwieringen Assigned To => mvwieringen
2013-08-15 11:40 mvwieringen Status new => resolved
2013-08-15 11:40 mvwieringen Resolution open => fixed
2013-08-15 11:40 mvwieringen Changeset attached => bareos master a7cf24b5
2013-08-15 11:40 mvwieringen Note Added: 0000634
2013-08-15 11:40 mvwieringen Changeset attached => bareos bareos-13.2 8b737aab
2013-08-15 11:40 mvwieringen Note Added: 0000635
2013-09-05 17:17 mvwieringen Status resolved => closed
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-12.4 1ef3dec8
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-13.2 7bc96b38
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-14.2 83dffd81
2015-03-25 16:51 mvwieringen Note Added: 0001364
2015-03-25 16:51 mvwieringen Status closed => resolved
2015-03-25 19:18 joergs Note Added: 0001517
2015-03-25 19:18 joergs Status resolved => closed