View Issue Details

IDProjectCategoryView StatusLast Update
0001206bareos-core[All Projects] webuipublic2020-03-02 16:22
ReporterfrankAssigned Tofrank 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version19.2.6 
Fixed in Version 
Summary0001206: form field restore job is not populated after client selection
DescriptionThe form field "restore job" is not populated correctly after client selection and stays disabled if the configured restore job number is greater than 1 due to a wrong comparison-operator.
Steps To ReproduceHave more than one configured restore job and try to restore something via the webui restore module.
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Relationships

related to 0001187 confirmedarogge_adm Release Bareos 19.2.7 
related to 0001200 resolvedfrank fails to restore files 

Activities

frank

frank

2020-03-02 16:22

manager   ~0003882

Fix committed to bareos bareos-19.2 branch with changesetid 12931.

Related Changesets

bareos: master e7dbde2a

2020-02-28 12:02:27

frank

Ported: N/A

Details Diff
webui: fix restore job form element population

This commit fixes the issue that the form field "restore job" is not
populated correctly after client selection and stays disabled if the
configured restore job number is greater than 1 due to a wrong
comparison-operator.

Fixes 0001206: form field restore job is not populated after client selection
Affected Issues
0001206
mod - webui/module/Restore/src/Restore/Form/RestoreForm.php Diff File

bareos: bareos-19.2 db90caf3

2020-02-28 12:02:27

frank

Ported: N/A

Details Diff
webui: fix restore job form element population

This commit fixes the issue that the form field "restore job" is not
populated correctly after client selection and stays disabled if the
configured restore job number is greater than 1 due to a wrong
comparison-operator.

Fixes 0001206: form field restore job is not populated after client selection

(cherry picked from commit e7dbde2a3510673d6a1ff3ad543a4ba70cc365c5)
Affected Issues
0001206
mod - webui/module/Restore/src/Restore/Form/RestoreForm.php Diff File

Issue History

Date Modified Username Field Change
2020-02-28 11:55 frank New Issue
2020-02-28 11:55 frank Status new => assigned
2020-02-28 11:55 frank Assigned To => frank
2020-02-28 13:37 frank Relationship added related to 0001200
2020-03-02 12:08 frank Relationship added related to 0001187
2020-03-02 16:22 frank Changeset attached => bareos master e7dbde2a
2020-03-02 16:22 frank Changeset attached => bareos bareos-19.2 db90caf3
2020-03-02 16:22 frank Note Added: 0003882
2020-03-02 16:22 frank Status assigned => resolved
2020-03-02 16:22 frank Resolution open => fixed