View Issue Details

IDProjectCategoryView StatusLast Update
0000797bareos-core[All Projects] directorpublic2017-09-21 22:28
ReporterhopAssigned Tojoergs 
PrioritynormalSeverityminorReproducibilityalways
Status assignedResolutionreopened 
PlatformLinuxOSUbuntuOS Version14.04
Product Version16.2.5 
Fixed in Version 
Summary0000797: make_catalog_backup.pl not capable of new config structure
DescriptionThe default catalog-backup throws:
shell command: run BeforeJob "/usr/lib/bareos/scripts/make_catalog_backup.pl MyCatalog"
11-Mar 08:10 qdehd4-dir JobId 129379: BeforeJob: Can't find your catalog (MyCatalog) in director configuration 11-Mar 08:10 qdehd4-dir JobId 129379: Error: Runscript:

It seems, the script is not able to traverse the Configuration Dirs, but instead expects the catalog-Definition in the old director.conf file.
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Relationships

related to 0000783 closed Catalog Backup not working 

Activities

joergs

joergs

2017-03-20 12:52

administrator   ~0002614

There is no known problem with make_catalog_backup.pl.

make_catalog_backup.pl uses the command

bareos-dbcheck -B -c /etc/bareos/

to determine the catalog settings.

What is the output on your system?

Maybe your installation uses an old version of the make_catalog_backup.pl?
joergs

joergs

2017-06-08 12:53

administrator   ~0002647

closed, no feedback received.
hop

hop

2017-06-19 17:26

reporter   ~0002671

Hi,

sorry I didn't reply, but besides it seeming too obvious that my installation uses an "old" make_catalog_backup.pl, I was not able to reply your feedback for some time. Sorry for that. So:
The intention of my posting was to give a hint, that the update-mechanism maybe might not be complete with the mechanism not updating the mentioned script.
As I did not find a reason, why the update mechanism might have skiped the script in our case I wanted to give a hint to you folks to look, weather the skript might have been "forgotten" in the update...or not... :-)
So, if You are sure, the script is part of the update mechanism an will be installed on systems comeing from older versions, you can close this bug again, and I will take a look at the installation after the next updates...

Issue History

Date Modified Username Field Change
2017-03-13 13:21 hop New Issue
2017-03-20 12:52 joergs Note Added: 0002614
2017-03-20 12:52 joergs Status new => feedback
2017-03-20 13:07 joergs Relationship added related to 0000783
2017-06-08 12:53 joergs Note Added: 0002647
2017-06-08 12:53 joergs Status feedback => closed
2017-06-08 12:53 joergs Resolution open => unable to reproduce
2017-06-19 17:26 hop Note Added: 0002671
2017-06-19 17:26 hop Status closed => feedback
2017-06-19 17:26 hop Resolution unable to reproduce => reopened
2017-09-21 22:28 joergs Assigned To => joergs
2017-09-21 22:28 joergs Status feedback => assigned