View Issue Details

IDProjectCategoryView StatusLast Update
0000768bareos-core[All Projects] file daemonpublic2017-06-08 12:57
Reporterjoop.martensAssigned To 
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformX64OSMS WindowsOS Version2012R2 and 2016
Product Version16.2.4 
Fixed in Version16.2.5 
Summary0000768: Warning of failed VSS writer SqlServerWriter after 16.2 client upgrade.
DescriptionI have upgraded my Windows based clients from 15.2.2 to 16.2.4.
Backups of the (only) 2 servers that are hosting MSSQL always end in state "warning" with the following VSS error:

Warning: VSS Writer "SqlServerWriter" has invalid state. ERR=The writer vetoed the shadow copy creation process during the backup preparation state.

vssadmin list writers output:

Writer name: 'SqlServerWriter'
   Writer Id: {a65faa63-5ea8-4ebc-9dbd-a0c4db26912a}
   Writer Instance Id: {06b0a0eb-8092-4850-a0de-b6b591f6d082}
   State: [7] Failed
   Last error: Non-retryable error

One of the servers is running MSSQL 2012 and the other MSSQL 2014.
Reverting the Bareos client back to 15.2.2 resolves the issue for both.

Full joblog:

17-Jan 09:31 sclsnl01-008-dir JobId 360: Start Backup JobId 360, Job=D_scwsnl01-005_etc.2017-01-17_09.31.56_53
17-Jan 09:31 sclsnl01-008-dir JobId 360: Created new Volume "AI-Incr-0109" in catalog.
17-Jan 09:31 sclsnl01-008-dir JobId 360: Using Device "FileStorage1" to write.
17-Jan 09:31 sclsnl01-008-dir JobId 360: Sending Accurate information.
17-Jan 09:31 sclsnl01-008-sd JobId 360: Labeled new Volume "AI-Incr-0109" on device "FileStorage1" (/mnt/diskpool/bareos).
17-Jan 09:31 sclsnl01-008-sd JobId 360: Wrote label to prelabeled Volume "AI-Incr-0109" on device "FileStorage1" (/mnt/diskpool/bareos)
17-Jan 09:31 sclsnl01-008-dir JobId 360: Max Volume jobs=1 exceeded. Marking Volume "AI-Incr-0109" as Used.
17-Jan 09:31 scwsnl01-005-fd JobId 360: Created 20 wildcard excludes from FilesNotToBackup Registry key
17-Jan 09:32 scwsnl01-005-fd JobId 360: Generate VSS snapshots. Driver="Win64 VSS", Drive(s)="C"
17-Jan 09:32 scwsnl01-005-fd JobId 360: VolumeMountpoints are not processed as onefs = yes.
17-Jan 09:32 scwsnl01-005-fd JobId 360: Warning: VSS Writer "SqlServerWriter" has invalid state. ERR=The writer vetoed the shadow copy creation process during the backup preparation state.
17-Jan 09:32 scwsnl01-005-fd JobId 360: Warning: VSS Writer "SqlServerWriter" has invalid state. ERR=The writer vetoed the shadow copy creation process during the backup preparation state.
17-Jan 09:32 scwsnl01-005-fd JobId 360: VSS Writer (PrepareForBackup): "SqlServerWriter", State: 0x7 (VSS_WS_FAILED_AT_PREPARE_BACKUP)
17-Jan 09:32 scwsnl01-005-fd JobId 360: Warning: VSS Writer "SqlServerWriter" has invalid state. ERR=The writer vetoed the shadow copy creation process during the backup preparation state.
17-Jan 09:32 scwsnl01-005-fd JobId 360: VSS Writer (BackupComplete): "Task Scheduler Writer", State: 0x1 (VSS_WS_STABLE)
17-Jan 09:32 scwsnl01-005-fd JobId 360: VSS Writer (BackupComplete): "VSS Metadata Store Writer", State: 0x1 (VSS_WS_STABLE)
17-Jan 09:32 scwsnl01-005-fd JobId 360: VSS Writer (BackupComplete): "Performance Counters Writer", State: 0x1 (VSS_WS_STABLE)
17-Jan 09:32 scwsnl01-005-fd JobId 360: VSS Writer (BackupComplete): "System Writer", State: 0x1 (VSS_WS_STABLE)
17-Jan 09:32 scwsnl01-005-fd JobId 360: Warning: VSS Writer (BackupComplete): "SqlServerWriter", State: 0x7 (VSS_WS_FAILED_AT_PREPARE_BACKUP)
17-Jan 09:32 scwsnl01-005-fd JobId 360: VSS Writer (BackupComplete): "ASR Writer", State: 0x1 (VSS_WS_STABLE)
17-Jan 09:32 scwsnl01-005-fd JobId 360: VSS Writer (BackupComplete): "WMI Writer", State: 0x1 (VSS_WS_STABLE)
17-Jan 09:32 scwsnl01-005-fd JobId 360: VSS Writer (BackupComplete): "Registry Writer", State: 0x1 (VSS_WS_STABLE)
17-Jan 09:32 scwsnl01-005-fd JobId 360: VSS Writer (BackupComplete): "COM+ REGDB Writer", State: 0x1 (VSS_WS_STABLE)
17-Jan 09:32 scwsnl01-005-fd JobId 360: VSS Writer (BackupComplete): "Shadow Copy Optimization Writer", State: 0x1 (VSS_WS_STABLE)
17-Jan 09:32 scwsnl01-005-fd JobId 360: VSS Writer (BackupComplete): "IIS Config Writer", State: 0x1 (VSS_WS_STABLE)
17-Jan 09:32 scwsnl01-005-fd JobId 360: VSS Writer (BackupComplete): "MSMQ Writer (MSMQ)", State: 0x1 (VSS_WS_STABLE)
17-Jan 09:32 scwsnl01-005-fd JobId 360: VSS Writer (BackupComplete): "MSSearch Service Writer", State: 0x1 (VSS_WS_STABLE)
17-Jan 09:32 sclsnl01-008-sd JobId 360: Elapsed time=00:00:13, Transfer rate=39 Bytes/second
17-Jan 09:32 sclsnl01-008-dir JobId 360: Bareos sclsnl01-008-dir 16.2.4 (01Jul16):
  Build OS: x86_64-redhat-linux-gnu redhat CentOS Linux release 7.0.1406 (Core)
  JobId: 360
  Job: D_scwsnl01-005_etc.2017-01-17_09.31.56_53
  Backup Level: Incremental, since=2017-01-17 09:25:34
  Client: "scwsnl01-005-fd" 16.2.4 (01Jul16) Microsoft Windows Server 2012 Standard Edition (build 9200), 64-bit,Cross-compile,Win64
  FileSet: "Windows_etc" 2017-01-12 11:02:18
  Pool: "AI-Incremental" (From Job IncPool override)
  Catalog: "MyCatalog" (From Client resource)
  Storage: "File" (From Pool resource)
  Scheduled time: 17-Jan-2017 09:31:56
  Start time: 17-Jan-2017 09:31:59
  End time: 17-Jan-2017 09:32:12
  Elapsed time: 13 secs
  Priority: 10
  FD Files Written: 1
  SD Files Written: 1
  FD Bytes Written: 0 (0 B)
  SD Bytes Written: 508 (508 B)
  Rate: 0.0 KB/s
  Software Compression: None
  VSS: yes
  Encryption: no
  Accurate: yes
  Volume name(s): AI-Incr-0109
  Volume Session Id: 15
  Volume Session Time: 1484336204
  Last Volume Bytes: 1,202 (1.202 KB)
  Non-fatal FD errors: 1
  SD Errors: 0
  FD termination status: OK
  SD termination status: OK
  Termination: Backup OK -- with warnings
Steps To ReproduceInstall Bareos-fd 16.2.4 on Windows server 2012R2/2016 that is hosting an MSSQL 2012/2014 (Express) database instance.

Run a VSS enabled backup.
Additional InformationCurrently both servers are always running into this issue though one of the servers has ran a couple of successful backups after the Bareos client upgrade before this problem start occurring. The other server suffered from the issue since the Bareos client upgrade.

This situation probably does not make it always reproduce-able.





TagsNo tags attached.
bareos-master: impactyes
bareos-master: actionfixed
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impactyes
bareos-16.2: actionfixed
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Relationships

child of 0000734 closedstephand Release bareos-16.2.5 

Activities

daniel

daniel

2017-02-03 08:06

reporter   ~0002550

Reproduced it on windows 7 64bit with mssql express edtition 2014. only incremental backups seems to be affected. Each incremental backup ends with the status "Backup OK -- with warnings"
AndiH

AndiH

2017-02-08 16:36

reporter   ~0002552

This also affects Windows 2008 R2 and MS-SQL Server 2008 (same error)
djaekel

djaekel

2017-02-09 11:58

reporter   ~0002554

Same error Win 2012R2 Datacenter, MSSQL 2012 Standard.
decibel83

decibel83

2017-02-14 13:36

reporter   ~0002565

Same error with Windows 2012 R2 Standard and Microsoft SQL Server 2014 Standard.
pstorz

pstorz

2017-03-03 23:11

administrator   ~0002597

Fix committed to bareos bareos-16.2 branch with changesetid 6882.

Related Changesets

bareos: bareos-16.2 c32be44c

2017-02-21 17:58:21

pstorz

Ported: N/A

Details Diff
vss: call SetBackupState with bSelectComponents and bBackupBootableSystemState again

We call the SetBackupState again like it was before commit

8b1c713bdd2034a032d6a6cc1c401b1addd894f7 :
vss: Fix IVssBackupComponents::SetBackupState call

This commit changed the behaviour so that we experience problems when the
MS SqlServerWriter is installed on the system being backed up.

Fixes 0000768: Warning of failed VSS writer SqlServerWriter after 16.2 client upgrade.
Affected Issues
0000768
mod - src/win32/filed/vss_generic.c Diff File

Issue History

Date Modified Username Field Change
2017-01-17 10:21 joop.martens New Issue
2017-02-03 08:06 daniel Note Added: 0002550
2017-02-03 08:06 daniel Priority normal => high
2017-02-03 08:06 daniel Reproducibility sometimes => always
2017-02-03 08:06 daniel Status new => confirmed
2017-02-08 16:36 AndiH Note Added: 0002552
2017-02-09 11:58 djaekel Note Added: 0002554
2017-02-14 13:36 decibel83 Note Added: 0002565
2017-03-03 23:11 pstorz Changeset attached => bareos bareos-16.2 c32be44c
2017-03-03 23:11 pstorz Note Added: 0002597
2017-03-03 23:11 pstorz Status confirmed => resolved
2017-03-03 23:11 pstorz Resolution open => fixed
2017-03-06 12:22 maik Relationship added child of 0000734
2017-03-06 12:23 maik bareos-master: impact => yes
2017-03-06 12:23 maik bareos-master: action => fixed
2017-03-06 12:23 maik bareos-16.2: impact => yes
2017-03-06 12:23 maik bareos-16.2: action => fixed
2017-06-08 12:57 joergs Status resolved => closed
2017-06-08 12:57 joergs Fixed in Version => 16.2.5