View Issue Details

IDProjectCategoryView StatusLast Update
0001150bareos-core[All Projects] Generalpublic2019-12-18 15:24
ReporterfrankAssigned Topstorz 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformOSDebian/Ubuntu/UniventionOS Version
Product Version18.2.5 
Fixed in Version 
Summary0001150: dbconfig schema update scripts broken since 18.2
DescriptionThe required structure under /usr/share/dbconfig-common/data/... is wrong since the change to cmake.

Here is a DEB package comparison between 17.2.x and 18.2.x.

dpkg -c bareos-database-postgresql_17.2.4-9.1_amd64.deb

drwxr-xr-x root/root 0 2017-12-14 12:59 ./
drwxr-xr-x root/root 0 2017-12-14 12:59 ./usr/
drwxr-xr-x root/root 0 2017-12-14 12:59 ./usr/lib/
drwxr-xr-x root/root 0 2017-12-14 12:59 ./usr/lib/bareos/
drwxr-xr-x root/root 0 2017-12-14 12:59 ./usr/lib/bareos/backends/
-rw-r--r-- root/root 52456 2017-12-14 12:59 ./usr/lib/bareos/backends/libbareoscats-postgresql-17.2.4.so
drwxr-xr-x root/root 0 2017-12-14 12:59 ./usr/lib/bareos/scripts/
drwxr-xr-x root/root 0 2017-12-14 12:59 ./usr/lib/bareos/scripts/ddl/
drwxr-xr-x root/root 0 2017-12-14 12:59 ./usr/lib/bareos/scripts/ddl/creates/
-rw-r--r-- root/root 18166 2017-12-14 12:59 ./usr/lib/bareos/scripts/ddl/creates/postgresql.sql
drwxr-xr-x root/root 0 2017-12-14 12:59 ./usr/lib/bareos/scripts/ddl/drops/
-rw-r--r-- root/root 943 2017-12-14 12:59 ./usr/lib/bareos/scripts/ddl/drops/postgresql.sql
drwxr-xr-x root/root 0 2017-12-14 12:59 ./usr/lib/bareos/scripts/ddl/grants/
-rw-r--r-- root/root 350 2017-12-14 12:59 ./usr/lib/bareos/scripts/ddl/grants/postgresql-change_owner.dbconfig-template.sql
-rw-r--r-- root/root 1178 2017-12-14 12:59 ./usr/lib/bareos/scripts/ddl/grants/postgresql-readonly.sql
-rw-r--r-- root/root 2033 2017-12-14 12:59 ./usr/lib/bareos/scripts/ddl/grants/postgresql.sql
drwxr-xr-x root/root 0 2017-12-14 12:59 ./usr/lib/bareos/scripts/ddl/updates/
-rw-r--r-- root/root 681 2017-12-14 12:59 ./usr/lib/bareos/scripts/ddl/updates/postgresql.10_11.sql
-rw-r--r-- root/root 1961 2017-12-14 12:59 ./usr/lib/bareos/scripts/ddl/updates/postgresql.11_12.sql
-rw-r--r-- root/root 708 2017-12-14 12:59 ./usr/lib/bareos/scripts/ddl/updates/postgresql.12_14.sql
-rw-r--r-- root/root 1243 2017-12-14 12:59 ./usr/lib/bareos/scripts/ddl/updates/postgresql.14_2001.sql
-rw-r--r-- root/root 1490 2017-12-14 12:59 ./usr/lib/bareos/scripts/ddl/updates/postgresql.2001_2002.sql
-rw-r--r-- root/root 1428 2017-12-14 12:59 ./usr/lib/bareos/scripts/ddl/updates/postgresql.2002_2003.sql
-rw-r--r-- root/root 186 2017-12-14 12:59 ./usr/lib/bareos/scripts/ddl/updates/postgresql.2003_2004.sql
-rw-r--r-- root/root 2256 2017-12-14 12:59 ./usr/lib/bareos/scripts/ddl/updates/postgresql.2004_2171.sql
-rw-r--r-- root/root 3659 2017-12-14 12:59 ./usr/lib/bareos/scripts/ddl/updates/postgresql.bee.1017_2004.sql
drwxr-xr-x root/root 0 2017-12-14 12:59 ./usr/share/
drwxr-xr-x root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/
drwxr-xr-x root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/data/
drwxr-xr-x root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/data/bareos-database-common/
drwxr-xr-x root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/data/bareos-database-common/install/
drwxr-xr-x root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/data/bareos-database-common/upgrade/
drwxr-xr-x root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/data/bareos-database-common/upgrade/pgsql/
drwxr-xr-x root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/data/bareos-database-common/upgrade-dbadmin/
drwxr-xr-x root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/data/bareos-database-common/upgrade-dbadmin/pgsql/
drwxr-xr-x root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/scripts/
drwxr-xr-x root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/scripts/bareos-database-common/
drwxr-xr-x root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/scripts/bareos-database-common/upgrade/
drwxr-xr-x root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/scripts/bareos-database-common/upgrade/pgsql/
-rwxr-xr-x root/root 578 2017-12-14 12:59 ./usr/share/dbconfig-common/scripts/bareos-database-common/upgrade/pgsql/2170
drwxr-xr-x root/root 0 2017-12-14 12:59 ./usr/share/doc/
drwxr-xr-x root/root 0 2017-12-14 12:59 ./usr/share/doc/bareos-database-postgresql/
-rw-r--r-- root/root 728 2017-12-14 12:59 ./usr/share/doc/bareos-database-postgresql/changelog.Debian.gz
-rw-r--r-- root/root 72808 2017-12-14 11:57 ./usr/share/doc/bareos-database-postgresql/copyright
drwxr-xr-x root/root 0 2017-12-14 12:59 ./var/
drwxr-xr-x root/root 0 2017-12-14 12:59 ./var/lib/
drwxr-xr-x root/root 0 2017-12-14 12:59 ./var/lib/bareos/
drwxr-xr-x root/root 0 2017-12-14 12:59 ./var/lib/bareos/dbconfig-common/
drwxr-xr-x root/root 0 2017-12-14 12:59 ./var/lib/bareos/dbconfig-common/upgrade-dbadmin/
drwxr-xr-x root/root 0 2017-12-14 12:59 ./var/lib/bareos/dbconfig-common/upgrade-dbadmin/pgsql/
lrwxrwxrwx root/root 0 2017-12-14 12:59 ./usr/lib/bareos/backends/libbareoscats-postgresql.so -> libbareoscats-postgresql-17.2.4.so
lrwxrwxrwx root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/data/bareos-database-common/install/pgsql -> ../../../../../lib/bareos/scripts/ddl/creates/postgresql.sql
lrwxrwxrwx root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/data/bareos-database-common/upgrade/pgsql/11 -> ../../../../../../lib/bareos/scripts/ddl/updates/postgresql.10_11.sql
lrwxrwxrwx root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/data/bareos-database-common/upgrade/pgsql/12 -> ../../../../../../lib/bareos/scripts/ddl/updates/postgresql.11_12.sql
lrwxrwxrwx root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/data/bareos-database-common/upgrade/pgsql/14 -> ../../../../../../lib/bareos/scripts/ddl/updates/postgresql.12_14.sql
lrwxrwxrwx root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/data/bareos-database-common/upgrade/pgsql/2001 -> ../../../../../../lib/bareos/scripts/ddl/updates/postgresql.14_2001.sql
lrwxrwxrwx root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/data/bareos-database-common/upgrade/pgsql/2002 -> ../../../../../../lib/bareos/scripts/ddl/updates/postgresql.2001_2002.sql
lrwxrwxrwx root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/data/bareos-database-common/upgrade/pgsql/2003 -> ../../../../../../lib/bareos/scripts/ddl/updates/postgresql.2002_2003.sql
lrwxrwxrwx root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/data/bareos-database-common/upgrade/pgsql/2004 -> ../../../../../../lib/bareos/scripts/ddl/updates/postgresql.2003_2004.sql
lrwxrwxrwx root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/data/bareos-database-common/upgrade/pgsql/2171 -> ../../../../../../lib/bareos/scripts/ddl/updates/postgresql.2004_2171.sql
lrwxrwxrwx root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/data/bareos-database-common/upgrade-dbadmin/pgsql/2003 -> /var/lib/bareos/dbconfig-common/upgrade-dbadmin/pgsql/2003
lrwxrwxrwx root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/data/bareos-database-common/upgrade-dbadmin/pgsql/2004 -> /var/lib/bareos/dbconfig-common/upgrade-dbadmin/pgsql/2004
lrwxrwxrwx root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/data/bareos-database-common/upgrade-dbadmin/pgsql/2170 -> /var/lib/bareos/dbconfig-common/upgrade-dbadmin/pgsql/2170
lrwxrwxrwx root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/scripts/bareos-database-common/upgrade/pgsql/2003 -> 2170
lrwxrwxrwx root/root 0 2017-12-14 12:59 ./usr/share/dbconfig-common/scripts/bareos-database-common/upgrade/pgsql/2004 -> 2170

dpkg -c bareos-database-postgresql_18.2.5-144.1_amd64.deb

drwxr-xr-x root/root 0 2019-02-01 12:04 ./
drwxr-xr-x root/root 0 2019-02-01 12:04 ./usr/
drwxr-xr-x root/root 0 2019-02-01 12:04 ./usr/lib/
drwxr-xr-x root/root 0 2019-02-01 12:04 ./usr/lib/bareos/
drwxr-xr-x root/root 0 2019-02-01 12:04 ./usr/lib/bareos/backends/
-rw-r--r-- root/root 73504 2019-02-01 12:04 ./usr/lib/bareos/backends/libbareoscats-postgresql.so
drwxr-xr-x root/root 0 2019-02-01 12:04 ./usr/lib/bareos/scripts/
drwxr-xr-x root/root 0 2019-02-01 12:04 ./usr/lib/bareos/scripts/ddl/
drwxr-xr-x root/root 0 2019-02-01 12:04 ./usr/lib/bareos/scripts/ddl/creates/
-rw-r--r-- root/root 18166 2019-02-01 11:22 ./usr/lib/bareos/scripts/ddl/creates/postgresql.sql
drwxr-xr-x root/root 0 2019-02-01 12:04 ./usr/lib/bareos/scripts/ddl/drops/
-rw-r--r-- root/root 943 2019-02-01 11:22 ./usr/lib/bareos/scripts/ddl/drops/postgresql.sql
drwxr-xr-x root/root 0 2019-02-01 12:04 ./usr/lib/bareos/scripts/ddl/grants/
-rw-r--r-- root/root 350 2019-02-01 11:22 ./usr/lib/bareos/scripts/ddl/grants/postgresql-change_owner.dbconfig-template.sql
-rw-r--r-- root/root 1178 2019-02-01 11:22 ./usr/lib/bareos/scripts/ddl/grants/postgresql-readonly.sql
-rw-r--r-- root/root 2033 2019-02-01 11:22 ./usr/lib/bareos/scripts/ddl/grants/postgresql.sql
drwxr-xr-x root/root 0 2019-02-01 12:04 ./usr/lib/bareos/scripts/ddl/updates/
-rw-r--r-- root/root 681 2019-02-01 11:22 ./usr/lib/bareos/scripts/ddl/updates/postgresql.10_11.sql
-rw-r--r-- root/root 1961 2019-02-01 11:22 ./usr/lib/bareos/scripts/ddl/updates/postgresql.11_12.sql
-rw-r--r-- root/root 708 2019-02-01 11:22 ./usr/lib/bareos/scripts/ddl/updates/postgresql.12_14.sql
-rw-r--r-- root/root 1243 2019-02-01 11:22 ./usr/lib/bareos/scripts/ddl/updates/postgresql.14_2001.sql
-rw-r--r-- root/root 1490 2019-02-01 11:22 ./usr/lib/bareos/scripts/ddl/updates/postgresql.2001_2002.sql
-rw-r--r-- root/root 1428 2019-02-01 11:22 ./usr/lib/bareos/scripts/ddl/updates/postgresql.2002_2003.sql
-rw-r--r-- root/root 186 2019-02-01 11:22 ./usr/lib/bareos/scripts/ddl/updates/postgresql.2003_2004.sql
-rw-r--r-- root/root 2256 2019-02-01 11:22 ./usr/lib/bareos/scripts/ddl/updates/postgresql.2004_2171.sql
-rw-r--r-- root/root 3659 2019-02-01 11:22 ./usr/lib/bareos/scripts/ddl/updates/postgresql.bee.1017_2004.sql
drwxr-xr-x root/root 0 2019-02-01 12:04 ./usr/share/
drwxr-xr-x root/root 0 2019-02-01 12:04 ./usr/share/dbconfig-common/
drwxr-xr-x root/root 0 2019-02-01 12:04 ./usr/share/dbconfig-common/data/
drwxr-xr-x root/root 0 2019-02-01 12:04 ./usr/share/dbconfig-common/data/bareos-database-common/
drwxr-xr-x root/root 0 2019-02-01 12:04 ./usr/share/dbconfig-common/data/bareos-database-common/install/
-rw-r--r-- root/root 18166 2019-02-01 11:22 ./usr/share/dbconfig-common/data/bareos-database-common/install/pgsql
drwxr-xr-x root/root 0 2019-02-01 12:04 ./usr/share/dbconfig-common/data/bareos-database-common/upgrade/
drwxr-xr-x root/root 0 2019-02-01 12:04 ./usr/share/dbconfig-common/data/bareos-database-common/upgrade/pgsql/
-rw-r--r-- root/root 3896 2019-02-01 12:04 ./usr/share/dbconfig-common/data/bareos-database-common/upgrade/pgsql/18.2.5
drwxr-xr-x root/root 0 2019-02-01 12:04 ./usr/share/dbconfig-common/data/bareos-database-common/upgrade-dbadmin/
drwxr-xr-x root/root 0 2019-02-01 12:04 ./usr/share/dbconfig-common/data/bareos-database-common/upgrade-dbadmin/pgsql/
-rw-r--r-- root/root 15302 2019-02-01 12:04 ./usr/share/dbconfig-common/data/bareos-database-common/upgrade-dbadmin/pgsql/18.2.5
drwxr-xr-x root/root 0 2019-02-01 12:04 ./usr/share/doc/
drwxr-xr-x root/root 0 2019-02-01 12:04 ./usr/share/doc/bareos-database-postgresql/
-rw-r--r-- root/root 766 2019-02-01 12:04 ./usr/share/doc/bareos-database-postgresql/changelog.Debian.gz
-rw-r--r-- root/root 72808 2019-02-01 11:22 ./usr/share/doc/bareos-database-postgresql/copyright
drwxr-xr-x root/root 0 2019-02-01 12:04 ./var/
drwxr-xr-x root/root 0 2019-02-01 12:04 ./var/lib/
drwxr-xr-x root/root 0 2019-02-01 12:04 ./var/lib/bareos/
drwxr-xr-x root/root 0 2019-02-01 12:04 ./var/lib/bareos/dbconfig-common/
drwxr-xr-x root/root 0 2019-02-01 12:04 ./var/lib/bareos/dbconfig-common/upgrade-dbadmin/
drwxr-xr-x root/root 0 2019-02-01 12:04 ./var/lib/bareos/dbconfig-common/upgrade-dbadmin/pgsql/
Additional InformationIn versions >= 18.2, core/platforms/debian/CMakeLists.txt needs to be adjusted to fit what was given in 17.2 in platforms/debian/Makefile.in .
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Relationships

related to 0001152 closedarogge Release Bareos 18.2.7 

Activities

pstorz

pstorz

2019-12-12 12:22

administrator   ~0003662

Fix committed to bareos bareos-18.2 branch with changesetid 12376.

Related Changesets

bareos: master a2c0783e

2019-12-09 14:34:53

pstorz

Ported: N/A

Details Diff
debian: fix dbconfig file installation

Unfortunately in bareos 18.2 the dbconfig file installation was not complete, so
that schema updates were not applied correctly to the database when using
dbconfig on debian-based distributions.

Now upgrades including schema changes are possible again.

Fixes 0001150: dbconfig schema update scripts broken since 18.2
Affected Issues
0001150
mod - .cmake-format.py Diff File
mod - core/debian/bareos-database-postgresql.install.in Diff File
mod - core/platforms/debian/CMakeLists.txt Diff File
add - core/platforms/debian/share/dbconfig-common/data/bareos-database-common/upgrade-dbadmin/pgsql/2170 Diff File

bareos: bareos-18.2 45dcc081

2019-12-09 14:34:53

pstorz

Ported: N/A

Details Diff
debian: fix dbconfig file installation

Unfortunately in bareos 18.2 the dbconfig file installation was not complete, so
that schema updates were not applied correctly to the database when using
dbconfig on debian-based distributions.

Now upgrades including schema changes are possible again.

Fixes 0001150: dbconfig schema update scripts broken since 18.2
Affected Issues
0001150
mod - core/debian/bareos-database-postgresql.install.in Diff File
mod - core/platforms/debian/CMakeLists.txt Diff File
add - core/platforms/debian/share/dbconfig-common/data/bareos-database-common/upgrade-dbadmin/pgsql/2170 Diff File

Issue History

Date Modified Username Field Change
2019-12-10 13:04 frank New Issue
2019-12-12 12:22 pstorz Changeset attached => bareos master a2c0783e
2019-12-12 12:22 pstorz Changeset attached => bareos bareos-18.2 45dcc081
2019-12-12 12:22 pstorz Note Added: 0003662
2019-12-12 12:22 pstorz Assigned To => pstorz
2019-12-12 12:22 pstorz Status new => resolved
2019-12-12 12:22 pstorz Resolution open => fixed
2019-12-12 13:31 arogge Relationship added related to 0001152
2019-12-18 15:24 arogge Status resolved => closed