Bareos Bug Tracker
Bareos Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000942bareos-core[All Projects] storage daemonpublic2018-05-04 21:002018-08-14 15:33 
Assigned To 
PlatformLinuxOSCentOSOS Version6
Product Version18.1.2 
Target VersionFixed in Version 
Summary0000942: undefined symbol when launching SD in bareos- RPM
Description(So my server has the "experimental" yum repo enabled, yes I'm fully aware I've shot myself in the foot here, I don't remember why we did that in the first place.)

When the latest nightly RPM, bareos- installed, the storage director fails to start with:

   Unable to load any shared library for

Configuration files haven't changed in almost a year.
Steps To ReproduceInstall latest nightly RPM. Try to start SD. Boom.

I have confirmed the RPM packages are installed correctly, are not corrupt, and I've even tried reinstalling them.
Additional InformationThe failing symbol is _ZN19generic_tape_device7offlineEv, which suggests this might be a linking problem, not a code problem.

[root@backup1 bareos]# bareos-sd -vf -dt -d100
04-May-2018 13:48:31.423475 bareos-sd (100): lib/ config file = /etc/bareos/bareos-sd.conf
04-May-2018 13:48:31.423582 bareos-sd (100): lib/ glob /etc/bareos/bareos-sd.conf: 1 files
04-May-2018 13:48:31.423607 bareos-sd (100): lib/ open config file: /etc/bareos/bareos-sd.conf
04-May-2018 13:48:31.423831 bareos-sd (90): stored/ Inserting Director res: backup1-mon
04-May-2018 13:48:31.424026 bareos-sd (90): stored/ Inserting Device res: tapedrive-tl1000
04-May-2018 13:48:31.424125 bareos-sd (100): lib/ glob /etc/bareos/bareos-sd.conf: 1 files
04-May-2018 13:48:31.424144 bareos-sd (100): lib/ open config file: /etc/bareos/bareos-sd.conf
04-May-2018 13:48:31.428364 backup1-sd (100): lib/ read_last_jobs seek to 192
04-May-2018 13:48:31.428385 backup1-sd (100): lib/ Read num_items=0
04-May-2018 13:48:31.428421 backup1-sd (8): lib/ Could not open crypto cache file. /var/lib/bareos/bareos-sd.9103.cryptoc ERR=No such file or directory
04-May-2018 13:48:31.428502 backup1-sd (50): lib/ load_plugins
04-May-2018 13:48:31.429607 backup1-sd (10): stored/ stored: listening on port 9103
04-May-2018 13:48:31.429646 04-May-2018 13:48:31.429650 backup1-sd (100): include/jcr.h:291-0 Contruct JCR
backup1-sd (100): lib/ Addresses host[ipv4;;9103]
04-May-2018 13:48:31.429756 backup1-sd (90): stored/ calling init_dev /backups/bareos
04-May-2018 13:48:31.429800 backup1-sd (100): stored/ Addresses host[ipv4;;10000]
04-May-2018 13:48:31.429848 backup1-sd (100): stored/ init_dev: tape=0 dev_name=/backups/bareos
04-May-2018 13:48:31.429864 backup1-sd (100): stored/ dev=/backups/bareos dev_max_bs=0 max_bs=0
04-May-2018 13:48:31.429876 backup1-sd (10): stored/ SD init done /backups/bareos
04-May-2018 13:48:31.429897 backup1-sd (100): stored/ created new block of blocksize 64512 (dev->device->label_block_size) as dev->max_block_size is zero
04-May-2018 13:48:31.429969 backup1-sd (90): stored/ calling init_dev /dev/tape/by-id/scsi-350016977299e1010-nst
04-May-2018 13:48:31.429988 backup1-sd (100): stored/ init_backend_dev: testing backend /usr/lib64/bareos/backends/
04-May-2018 13:48:31.430132 backup1-sd (100): stored/ Unable to load shared library: /usr/lib64/bareos/backends/ ERR=/usr/lib64/bareos/backends/ undefined symbol: _ZN19generic_tape_device7offlineEv
Unable to load any shared library for

[root@backup1 bareos]# rpm -q bareos

I don't know when this broke, my colleague is out of the country right now, and I've just started looking at this server again. Presumably fairly recently, but unable to say exactly, sorry.
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action
Attached Files

- Relationships

-  Notes
joergs (administrator)
2018-05-05 10:24

Thank you for this report. We will look into this issue.
joergs (administrator)
2018-05-05 12:50

Please provide a list of installed bareos packages (rpm -qa | grep bareos).
(0002999) (reporter)
2018-05-07 16:32

My apologies, since this is our production backup server, I had to revert to the officially-supported 17.2 RPMs from the portal site, so I can't provide a direct answer.
I don't need this solved, I just wanted to point out that there's a potential problem with the CentOS6 rpms. I'll also be upgrading to CentOS 7 now, thanks to the WebUI-vs-PHP issue :-(.

I *can* tell you that I had attempted to resolve the problem by running "yum install bareos\*" which ran without error, and I expect that pulled in the entire set of RPMs.
kic68 (reporter)
2018-08-14 14:01


I am trying to install bareos on Ubuntu 18.04 so I currently have to use the nightly build(s) and I am fully aware of the meaning of nightly. Just FYI that something is not right yet.

This error comes from the July 23 nightly download.

The storage daemon is crashing with the same error message in (850): lib/ Enter Jmsg type=4 (850): lib/ Enter DispatchMessage type=4 JobId 0: Error: Unable to load shared library: /usr/lib/bareos/backends/ ERR=/usr/lib/bareos/backends/ undefined symbol: _ZN19generic_tape_device7offlineEv (850): lib/ DIRECTOR for following msg: JobId 0: Error: Unable to load shared library: /usr/lib/bareos/backends/ ERR=/usr/lib/bareos/backends/ undefined symbol: _ZN19generic_tape_device7offlineEv (800): lib/ no jcr for following msg: JobId 0: Error: Unable to load shared library: /usr/lib/bareos/backends/ ERR=/usr/lib/bareos/backends/ undefined symbol: _ZN19generic_tape_device7offlineEv (100): stored/ Unable to load shared library: /usr/lib/bareos/backends/ ERR=/usr/lib/bareos/backends/ undefined symbol: _ZN19generic_tape_device7offlineEv

Maybe the next build will be fixed already.

Thanks and best,

- Issue History
Date Modified Username Field Change
2018-05-04 21:00 New Issue
2018-05-05 10:24 joergs Note Added: 0002997
2018-05-05 10:24 joergs Status new => acknowledged
2018-05-05 12:50 joergs Note Added: 0002998
2018-05-05 12:50 joergs Status acknowledged => feedback
2018-05-07 16:32 Note Added: 0002999
2018-05-07 16:32 Status feedback => new
2018-08-14 14:01 kic68 Note Added: 0003101

Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker