Bareos Bug Tracker
Bareos Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000941bareos-core[All Projects] installer / packagespublic2018-05-03 08:222018-08-09 15:21
ReporterSchroeffu 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusacknowledgedResolutionopen 
PlatformLinuxOSUbuntuOS Version18.04
Product Version17.2.5 
Target VersionFixed in Version 
Summary0000941: Ubuntu 18.04 installation failes, because its not shipping depency libreadline6 anymore
DescriptionOn Ubuntu 18.04, the installation of Bareos Director and Client is not working Out-of-the-Box while using the Repository from 16.04 (18.04 repo is not existing yet)

Repo: http://download.bareos.org/bareos/release/17.2/xUbuntu_16.04 [^]
OS: Ubuntu 18.04 LTS

Failure:
 bareos : Depends: bareos-client (= 17.2.4-9.1) but it is not going to be installed
 bareos-client : Depends: bareos-bconsole (>= 17.2.4-9.1) but it is not going to be installed
 bareos-bconsole : Depends: libreadline6 (>= 6.0) but it is not installable
Steps To ReproduceTry install Bareos 17.2.latest from http://download.bareos.org/bareos/release/17.2/xUbuntu_16.04 [^] on 18.04
Additional InformationWorkaround: create & use libreadline6 fake-package with symlink inside /lib/x86_64-linux-gnu/libreadline.so.7 /lib/x86_64-linux-gnu/libreadline.so.6 , because Ubuntu 18.04 is shipping libreadline7

If it works completely that fake way? i dont know. but bconsole -t is now working again also ;)
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action
Attached Files

- Relationships

-  Notes
(0002996)
joergs (administrator)
2018-05-05 10:23

Well, we know, we do not provide Ubuntu 18.04 packages now. We are working on this. Ubuntu 16.04 packages are not intended to run on 18.04.
(0003099)
Schroeffu (reporter)
2018-08-09 15:21

Any update on this?

- Issue History
Date Modified Username Field Change
2018-05-03 08:22 Schroeffu New Issue
2018-05-05 10:23 joergs Note Added: 0002996
2018-05-05 10:23 joergs Status new => acknowledged
2018-08-09 15:21 Schroeffu Note Added: 0003099


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker