Bareos Bug Tracker
Bareos Bug Tracker

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000892bareos-core[All Projects] storage daemonpublic2018-01-22 14:072018-07-16 19:10
Reporterjoergs 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSRHELOS Version7
Product Version17.2.4 
Target VersionFixed in Version17.2.7 
Summary0000892: bareos-storage-droplet: if configured with unreachable S3 system, backup will terminate with OK
Descriptionbareos-17.2 introduces bareos-storage-droplet as technical preview.

Limitation:
  * libdroplet address buckets by DNS (%(bucket)s.YOUR_S3_HOSTNAME). Accessing S3 servers without prepended bucket name is not possible.

However, it is known, that it fails silently in same situations:

  * it does not work with all S3 backend.
    * fails with https://minio.io/ [^] (this does not provide bucket urls, see above)
    * succeeded with the rados-gw of Ceph
  * rados-gw:
    * if an non existing DNS name is provided (or system is not reachable) you get an error message in the joblog, claiming that bareos is not able to contact the S3. Even so, the backup ends with job status okay (T).
Steps To ReproduceInstall bareos with bareos-storage-droplet.

Have an rados-gw ready to use for testing.

Configure droplet profile to use an unreachable system.
TagsNo tags attached.
bareos-master: impactyes
bareos-master: actionwill care
bareos-17.2: impactyes
bareos-17.2: actionfixed
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impactno
bareos-15.2: action
bareos-14.2: impactno
bareos-14.2: action
bareos-13.2: impactno
bareos-13.2: action
bareos-12.4: impactno
bareos-12.4: action
Attached Files

- Relationships
related to 0000902closedjoergs bareos-storage-droplet: immediate restore fails, works after some seconds 
child of 0000966closedjoergs Release bareos-17.2.7 

-  Notes
(0003043)
joergs (administrator)
2018-06-14 13:27

Fix committed to bareos bareos-16.2-droplet branch with changesetid 8748.

- Related Changesets
bareos: bareos-16.2-droplet 5b6f33e3
Timestamp: 2018-04-10 18:54:24
Author: joergs
Ported: N/A
Details ] Diff ]
bareos-storage-droplet: improve error handling

Previos version did not always return an error, if data could not be written.
Especially the load_chunk ignored EIO errors, properly because of a typo.

As the droplet_device in iothread mode relies on asynchronious write-backs,
the new device method flush() has been introduced.
If a droplet_device is configured to use iothreads and unlimited retries,
this will do busy waiting until all data is written to the droplet backend.
In case of a connection problems to the droplet_device, this will be forever.

Note that a bconsole "status storage=..." command will inform about "Pending IO flush requests".

Fixes 0000892: bareos-storage-droplet: if configured with unreachable S3 system, backup will terminate with OK
mod - src/stored/acquire.c Diff ] File ]
mod - src/stored/backends/Makefile.in Diff ] File ]
mod - src/stored/backends/chunked_device.c Diff ] File ]
mod - src/stored/backends/chunked_device.h Diff ] File ]
mod - src/stored/backends/droplet_device.c Diff ] File ]
mod - src/stored/backends/droplet_device.h Diff ] File ]
mod - src/stored/dev.c Diff ] File ]
mod - src/stored/dev.h Diff ] File ]

- Issue History
Date Modified Username Field Change
2018-01-22 14:07 joergs New Issue
2018-01-22 14:08 joergs bareos-master: impact => yes
2018-01-22 14:08 joergs bareos-master: action => will care
2018-01-22 14:08 joergs bareos-17.2: impact => yes
2018-01-22 14:08 joergs bareos-17.2: action => will care
2018-01-22 14:08 joergs bareos-15.2: impact => no
2018-01-22 14:08 joergs bareos-14.2: impact => no
2018-01-22 14:08 joergs bareos-13.2: impact => no
2018-01-22 14:08 joergs bareos-12.4: impact => no
2018-01-31 18:15 joergs Relationship added related to 0000902
2018-04-19 19:23 joergs Assigned To => joergs
2018-04-19 19:23 joergs Status new => assigned
2018-06-14 13:27 joergs Changeset attached => bareos bareos-16.2-droplet 5b6f33e3
2018-06-14 13:27 joergs Note Added: 0003043
2018-06-14 13:27 joergs Status assigned => resolved
2018-06-14 13:27 joergs Resolution open => fixed
2018-06-19 18:41 joergs Relationship added child of 0000966
2018-07-16 19:10 joergs bareos-17.2: action will care => fixed
2018-07-16 19:10 joergs Status resolved => closed
2018-07-16 19:10 joergs Assigned To joergs =>
2018-07-16 19:10 joergs Fixed in Version => 17.2.7


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker