Bareos Bug Tracker
Bareos Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000799bareos-core[All Projects] directorpublic2017-03-21 21:102017-06-09 11:23
ReporterShodan 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusnewResolutionopen 
PlatformLinuxOSDebianOS Version8
Product Version16.2.4 
Target VersionFixed in Version 
Summary0000799: bareos-director crashes on backup job
DescriptionSegmentation fault during backup job

> bconsole
> run
Select Job resource (1-78): 77
Run Backup job
JobName: TL-ECN-MT
Level: Full
Client: tl-srv-str-01-fd
Format: Native
FileSet: ECN-MT
Pool: TL-TPL (From Job resource)
Storage: tl-bkp-tpl-01 (From Pool resource)
When: 2017-03-21 22:08:24
Priority: 10
OK to run? (yes/mod/no):

21-Mar 21:59 ld4-bar-dir JobId 134859: Start Backup JobId 134859, Job=TL-ECN-MT.2017-03-21_21.59.27_04
21-Mar 21:59 ld4-bar-dir JobId 134859: Using Device "ULT3580-HH7" to write.
21-Mar 21:59 ld4-bar-dir: ERROR in mem_pool.c:238 Failed ASSERT: obuf
Steps To Reproducerun backup job
Additional InformationDell tape loader is used for backup job
Traceback file attached
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action
Attached Filestxt file icon traceback.txt [^] (9,262 bytes) 2017-03-21 21:10 [Show Content]
txt file icon traceback2.txt [^] (9,274 bytes) 2017-03-22 10:12 [Show Content]

- Relationships

-  Notes
(0002616)
Shodan (reporter)
2017-03-21 21:14
edited on: 2017-03-22 10:14

bareos-dbcheck -f -c /etc/bareos/bareos-dir.conf does not fix the issue

Additional debug

gdb -q -ex 'file /usr/sbin/bareos-dir' -ex 'run -v -f'
Reading symbols from /usr/sbin/bareos-dir...Reading symbols from /usr/lib/debug//usr/sbin/bareos-dir...done.
done.
Starting program: /usr/sbin/bareos-dir -v -f
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7ffff45a1700 (LWP 47133)]
[New Thread 0x7ffff3655700 (LWP 47134)]
[Thread 0x7ffff3655700 (LWP 47134) exited]
[New Thread 0x7ffff3655700 (LWP 47135)]
[New Thread 0x7ffff2c48700 (LWP 47136)]
[New Thread 0x7ffff2447700 (LWP 47137)]
[New Thread 0x7ffff1c46700 (LWP 47138)]
[New Thread 0x7ffff1445700 (LWP 47192)]
[New Thread 0x7ffff0827700 (LWP 47214)]
ld4-bar-dir: mem_pool.c:238-134869 Failed ASSERT: obuf

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7ffff0827700 (LWP 47214)]
0x00007ffff6ebd6bb in sm_check_pool_memory_size (fname=<optimized out>, lineno=<optimized out>, obuf=0x0, size=<optimized out>) at mem_pool.c:238
238 mem_pool.c: No such file or directory.

(0002661)
joergs (administrator)
2017-06-08 16:18

Thank you for the stack traces. Unfortunately, this looks strange.
If, as stated in 0000005, jcr is really NULL, than a Segmentation Fault must have appeared earlier:

0000003 0x00007f041a4c36bb in sm_check_pool_memory_size (fname=<optimized out>, lineno=<optimized out>, obuf=0x0, size=<optimized out>) at mem_pool.c:238
0000004 0x0000000000416a8f in update_attribute (jcr=0x7f0404005568, msg=0x7f03f80016f0 "UpdCat Job=TLL1-ECN-MT.2017-03-21_21.59.27_04 FileAttributes ", msglen=206) at catreq.c:472
0000005 0x0000000000418088 in catalog_update (jcr=0x0, bs=0x0) at catreq.c:660
0000006 0x000000000042758b in bget_dirmsg (bs=0x7f03f8001598, allow_any_message=false) at getmsg.c:260

In what situation, this bug occurs? Have you got a small test configuration, were we could reproduce this error? If not, maybe we get some more insight, if you enable debug messages:
bareos-dir -f -d 900
(0002668)
Shodan (reporter)
2017-06-09 11:23

Sorry, unable to reproduce the issue anymore :(
The pool has been recreated and debian bareos package has been updated and recompiled to exclude unneeded modules (glusterfs, ceph). After this, the problem disappeared.

- Issue History
Date Modified Username Field Change
2017-03-21 21:10 Shodan New Issue
2017-03-21 21:10 Shodan File Added: traceback.txt
2017-03-21 21:14 Shodan Note Added: 0002616
2017-03-22 10:12 Shodan File Added: traceback2.txt
2017-03-22 10:14 Shodan Note Edited: 0002616 View Revisions
2017-06-08 13:29 joergs bareos-master: impact => yes
2017-06-08 13:29 joergs bareos-master: action => will care
2017-06-08 13:29 joergs bareos-16.2: impact => yes
2017-06-08 13:29 joergs bareos-16.2: action => will care
2017-06-08 13:29 joergs bareos-15.2: impact => no
2017-06-08 13:29 joergs bareos-14.2: impact => no
2017-06-08 13:29 joergs bareos-13.2: impact => no
2017-06-08 13:29 joergs bareos-12.4: impact => no
2017-06-08 13:29 joergs Status new => resolved
2017-06-08 13:29 joergs Fixed in Version => 16.2.6
2017-06-08 13:29 joergs Resolution open => fixed
2017-06-08 13:29 joergs Assigned To => joergs
2017-06-08 13:38 joergs bareos-master: impact yes =>
2017-06-08 13:38 joergs bareos-master: action will care =>
2017-06-08 13:38 joergs bareos-16.2: impact yes =>
2017-06-08 13:38 joergs bareos-16.2: action will care =>
2017-06-08 13:38 joergs bareos-15.2: impact no =>
2017-06-08 13:38 joergs bareos-14.2: impact no =>
2017-06-08 13:38 joergs bareos-13.2: impact no =>
2017-06-08 13:38 joergs bareos-12.4: impact no =>
2017-06-08 13:38 joergs Assigned To joergs =>
2017-06-08 13:38 joergs Status resolved => new
2017-06-08 13:38 joergs Resolution fixed => open
2017-06-08 13:38 joergs Fixed in Version 16.2.6 =>
2017-06-08 16:18 joergs Note Added: 0002661
2017-06-08 16:18 joergs Status new => feedback
2017-06-09 11:23 Shodan Note Added: 0002668
2017-06-09 11:23 Shodan Status feedback => new


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker