Bareos Bug Tracker
Bareos Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000441bareos-core[All Projects] configuration guipublic2015-03-19 21:062017-06-08 16:54
Reportergchongong 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionno change required 
PlatformLinuxOSCentOSOS Version7
Product Version14.2.2 
Target VersionFixed in Version 
Summary0000441: 0000429 - having this same issue
DescriptionI see issue 0000429 has been resolved, but I just tried installing the bareos gui and run into this.
The connection test is failing.

Cannot get to the web login page. What was the solution?


    /usr/share/php/Zend/ServiceManager/ServiceManager.php:529

Message:

    Zend\ServiceManager\ServiceManager::get was unable to fetch or create an instance for bareos



TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action
Attached Filespng file icon Screenshot from 2015-03-19 16:05:35.png [^] (105,734 bytes) 2015-03-19 21:06


png file icon Screenshot from 2015-03-19 16:05:25.png [^] (146,507 bytes) 2015-03-19 21:06

- Relationships

-  Notes
(0001327)
frank (manager)
2015-03-20 12:43

Looks like a misconfiguration, as far as I can see from the screenshots.

If you followed the install instruction (https://github.com/bareos/bareos-webui/blob/master/doc/INSTALL.md [^]) and you have just one director with the catalog db running on the same host, your directors.ini should look similar like following.


;
; Section bareos-dir
;
[bareos-dir]
enabled = "yes"
dbdriver = "postgresql"
dbaddress = "bareos"
dbport = 5432
dbuser = "bareos_webui"
dbpassword = "changeme"
dbname = "bareos"
diraddress = "bareos"
dirport = 9101
; Note: TLS has not been tested and documented, yet.
;tls_verify_peer = false
;server_can_do_tls = false
;server_requires_tls = false
;client_can_do_tls = false
;client_requires_tls = false
;ca_file = ""
;cert_file = ""
;cert_file_passphrase = ""
;allowed_cns = ""


Note: If you try to login even though the config test informs you about not being able to connect to the catalog db, you have to logout or close your browser to get rid of the session. Otherwise changes made to your directors.ini during session time are not applied. As there is no logout button if you run into the exception, you may call the needed action to logout via following url or simply close your browser to kill the session.

http://<replace-with-your-host>/bareos-webui/auth/logout [^]
(0001328)
gchongong (reporter)
2015-03-20 15:51

Thanks, you were right, this was just browser cache...

- Issue History
Date Modified Username Field Change
2015-03-19 21:06 gchongong New Issue
2015-03-19 21:06 gchongong File Added: Screenshot from 2015-03-19 16:05:35.png
2015-03-19 21:06 gchongong File Added: Screenshot from 2015-03-19 16:05:25.png
2015-03-20 10:40 joergs Assigned To => frank
2015-03-20 10:40 joergs Status new => assigned
2015-03-20 12:43 frank Note Added: 0001327
2015-03-20 15:51 gchongong Note Added: 0001328
2015-03-23 10:29 frank Status assigned => resolved
2015-03-23 10:29 frank Resolution open => no change required
2015-03-31 15:26 mvwieringen adm Assigned To frank =>
2017-06-08 16:54 frank Status resolved => closed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker