Bareos Bug Tracker
Bareos Bug Tracker

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000265bareos-core[All Projects] storage daemonpublic2014-01-06 09:522015-03-25 19:18
Reporterpstorz 
Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformLinuxOSanyOS Version3
Product Version13.2.1 
Target Version13.2.3Fixed in Version13.2.3 
Summary0000265: job hangs and cannot be terminated if spool file is not writable
DescriptionXXXXX JobId 63238: Fatal error: Open data spool file /bacula_spool/XXXXX.data.63238.ASTERISK.2014-01-03_23.00.01_03.LTO-Drive-IBM-0.spool failed: ERR=Permission denied

This leads to a job that hangs and even cannot be canceled by "cancel storage= jobid="


Correctly, the job should be canceled when the spool directory cannot be written.
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action
Attached Files

- Relationships

-  Notes
(0000780)
mvwieringen (developer)
2014-01-06 10:04

The return value of begin_data_spool() is ignored in src/stored/append.c,
src/stored/mac.c and src/stored/ndmp_tape.c

When fixing this also check the return value of begin_attribute_spool()
in those same files as it has the same problem.
(0000865)
mvwieringen (developer)
2014-05-16 17:14

Fix committed to bareos bareos-13.2 branch with changesetid 1772.
(0001409)
mvwieringen (developer)
2015-03-25 16:51

Fix committed to bareos2015 bareos-14.2 branch with changesetid 4945.
(0001562)
joergs (administrator)
2015-03-25 19:18

Due to the reimport of the Github repository to bugs.bareos.org, the status of some tickets have been changed. These tickets will be closed again.
Sorry for the noise.

- Related Changesets
bareos: master 9204714a
Timestamp: 2014-01-06 10:43:26
Author: pstorz
Ported: N/A
Details ] Diff ]
check return values of spool functions

We now check the return values of

* begin_data_spool()
* begin_attribute_spool()

as otherwise the job hangs until eternety if there is a problem with the
spool file.

Fixes: 0000265: job hangs and cannot be terminated if spool file is not writable
mod - src/stored/append.c Diff ] File ]
mod - src/stored/mac.c Diff ] File ]
mod - src/stored/ndmp_tape.c Diff ] File ]
bareos: bareos-13.2 88e4f457
Timestamp: 2014-01-06 10:43:26
Author: pstorz
Committer: mvwieringen
Ported: N/A
Details ] Diff ]
check return values of spool functions

We now check the return values of

* begin_data_spool()
* begin_attribute_spool()

as otherwise the job hangs until eternety if there is a problem with the
spool file.

Fixes: 0000265: job hangs and cannot be terminated if spool file is not writable
mod - src/stored/append.c Diff ] File ]
mod - src/stored/mac.c Diff ] File ]
mod - src/stored/ndmp_tape.c Diff ] File ]
bareos2015: bareos-13.2 49db247b
Timestamp: 2014-01-06 11:43:26
Author: pstorz
Committer: mvwieringen
Ported: N/A
Details ] Diff ]
check return values of spool functions

We now check the return values of

* begin_data_spool()
* begin_attribute_spool()

as otherwise the job hangs until eternety if there is a problem with the
spool file.

Fixes: 0000265: job hangs and cannot be terminated if spool file is not writable
mod - src/stored/append.c Diff ] File ]
mod - src/stored/mac.c Diff ] File ]
mod - src/stored/ndmp_tape.c Diff ] File ]
bareos2015: bareos-14.2 722a1ef4
Timestamp: 2014-01-06 11:43:26
Author: pstorz
Committer: mvwieringen
Ported: N/A
Details ] Diff ]
check return values of spool functions

We now check the return values of

* begin_data_spool()
* begin_attribute_spool()

as otherwise the job hangs until eternety if there is a problem with the
spool file.

Fixes: 0000265: job hangs and cannot be terminated if spool file is not writable
mod - src/stored/append.c Diff ] File ]
mod - src/stored/mac.c Diff ] File ]
mod - src/stored/ndmp_tape.c Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-01-06 09:52 pstorz New Issue
2014-01-06 10:04 mvwieringen Note Added: 0000780
2014-01-06 10:04 mvwieringen Assigned To => pstorz
2014-01-06 10:04 mvwieringen Status new => assigned
2014-01-06 14:42 pstorz Changeset attached => bareos master 9204714a
2014-01-06 14:44 pstorz Status assigned => resolved
2014-01-06 14:44 pstorz Fixed in Version => 13.2.3
2014-01-06 14:44 pstorz Resolution open => fixed
2014-05-16 17:14 mvwieringen Changeset attached => bareos bareos-13.2 88e4f457
2014-05-16 17:14 mvwieringen Note Added: 0000865
2014-05-16 17:15 mvwieringen adm Assigned To pstorz =>
2014-05-16 17:15 mvwieringen adm Status resolved => closed
2014-05-16 17:15 mvwieringen adm Target Version => 13.2.3
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-13.2 49db247b
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-14.2 722a1ef4
2015-03-25 16:51 mvwieringen Note Added: 0001409
2015-03-25 16:51 mvwieringen Status closed => resolved
2015-03-25 19:18 joergs Note Added: 0001562
2015-03-25 19:18 joergs Status resolved => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker