Bareos Bug Tracker
Bareos Bug Tracker

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000250bareos-core[All Projects] file daemonpublic2013-11-15 11:182015-03-25 19:18
Reporterpstorz 
Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformLinuxOSanyOS Version3
Product Version12.4.5 
Target Version12.4.6Fixed in Version12.4.6 
Summary0000250: bareos-fd asserts when reading a file from ntfs volume mounted on linux
Descriptionwhen backing up a filesystem mounted to a linux host via ntfs, we get an assertion error:

backup-sd-fd: bfile.c:1031-0 open file /bacula-mounts/INEZ/part2/Users/<username>/AppData/Local/Packages/WinStore_cw5n1h2txyewy/AC/Microsoft/Windows Store/Cache/0/0-Featured-https∺∯∯next-services.apps.microsoft.com∯browse∯6.2.9200-1∯667∯c∯DE∯Featured∯10895826.dat
backup-sd-fd: backup.c:983-0 Send data to SD len=6552
backup-sd-fd: find_one.c:756-0 Failed ASSERT: name_max+1 > (int)sizeof(struct dirent) + (int)NAMELEN(entry)
BAREOS interrupted by signal 11: Segmentation violation
Kaboom! bareos-fd, backup-sd-fd got signal 11 - Segmentation violation. Attempting traceback.
Kaboom! exepath=/usr/sbin/
Calling: /usr/sbin/btraceback /usr/sbin/bareos-fd 3528 /var/lib/bareos
/usr/sbin/btraceback: line 104: /usr/sbin/bsmtp: No such file or directory
cat: write error: Broken pipe
The btraceback call returned 127
Dumping: /var/lib/bareos/backup-sd-fd.3528.bactrace
Additional InformationThe initial problem seems to be an incompatibility of the ntfs driver with the ntfs version of the filesystem (Windows 2012 Server), because it is also not possible to copy the problematic files directly on the linux machine:

cp 0/ /root -r
cp: cannot stat `/root/0/0-FileAssociation-https∺∯∯next-services.apps.microsoft.com∯search∯6.2.9200-1∯667∯de-DE_de-DE∯m∯DE∯c∯DE∯il∯de-DE∯cp∯10005001∯FileAssociation∯cid∯0∯pf∯1∯pc∯0∯pt∯x64∯af∯0∯lf∯1∯s∯0∯2∯pn∯0∯pgc∯-1∿phrase=13.dat': File name too long

So obviously the stat information is damaged.

Anyway, we should be able to skip those files instead of asserting.
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action
Attached Files

- Relationships

-  Notes
(0000728)
mvwieringen (developer)
2013-11-16 15:30

Fix committed to bareos bareos-13.2 branch with changesetid 1341.
(0000729)
mvwieringen (developer)
2013-11-16 15:30

Fix committed to bareos bareos-12.4 branch with changesetid 1343.
(0001355)
mvwieringen (developer)
2015-03-25 16:51

Fix committed to bareos2015 bareos-13.2 branch with changesetid 4094.
(0001509)
joergs (administrator)
2015-03-25 19:18

Due to the reimport of the Github repository to bugs.bareos.org, the status of some tickets have been changed. These tickets will be closed again.
Sorry for the noise.

- Related Changesets
bareos: master ed6f7276
Timestamp: 2013-11-15 20:43:47
Author: mvwieringen
Ported: N/A
Details ] Diff ]
Some filesystems violate against the POSIX rules.

when backing up a filesystem mounted to a linux host via ntfs, we get an
assertion error:

backup-sd-fd: bfile.c:1031-0 open file
/bacula-mounts/INEZ/part2/Users/<username>/AppData/Local/Packages/WinStore_cw5n1h2txyewy/AC/Microsoft/Windows
Store/Cache/0/0-Featured-https∺∯∯next-services.apps.microsoft.com∯browse∯6.2.9200-1∯667∯c∯DE∯Featured∯10895826.dat
backup-sd-fd: backup.c:983-0 Send data to SD len=6552
backup-sd-fd: find_one.c:756-0 Failed ASSERT: name_max+1 >
(int)sizeof(struct dirent) + (int)NAMELEN(entry)

Fixes 250: bareos-fd asserts when reading a file from ntfs volume mounted on linux
mod - src/findlib/find_one.c Diff ] File ]
bareos: bareos-13.2 d330f872
Timestamp: 2013-11-15 20:43:47
Author: mvwieringen
Ported: N/A
Details ] Diff ]
Some filesystems violate against the POSIX rules.

when backing up a filesystem mounted to a linux host via ntfs, we get an
assertion error:

backup-sd-fd: bfile.c:1031-0 open file
/bacula-mounts/INEZ/part2/Users/<username>/AppData/Local/Packages/WinStore_cw5n1h2txyewy/AC/Microsoft/Windows
Store/Cache/0/0-Featured-https∺∯∯next-services.apps.microsoft.com∯browse∯6.2.9200-1∯667∯c∯DE∯Featured∯10895826.dat
backup-sd-fd: backup.c:983-0 Send data to SD len=6552
backup-sd-fd: find_one.c:756-0 Failed ASSERT: name_max+1 >
(int)sizeof(struct dirent) + (int)NAMELEN(entry)

Fixes 0000250: bareos-fd asserts when reading a file from ntfs volume mounted on linux
mod - src/findlib/find_one.c Diff ] File ]
bareos: bareos-12.4 3ac87d3a
Timestamp: 2013-11-15 20:43:47
Author: mvwieringen
Ported: N/A
Details ] Diff ]
Some filesystems violate against the POSIX rules.

when backing up a filesystem mounted to a linux host via ntfs, we get an
assertion error:

backup-sd-fd: bfile.c:1031-0 open file
/bacula-mounts/INEZ/part2/Users/<username>/AppData/Local/Packages/WinStore_cw5n1h2txyewy/AC/Microsoft/Windows
Store/Cache/0/0-Featured-https∺∯∯next-services.apps.microsoft.com∯browse∯6.2.9200-1∯667∯c∯DE∯Featured∯10895826.dat
backup-sd-fd: backup.c:983-0 Send data to SD len=6552
backup-sd-fd: find_one.c:756-0 Failed ASSERT: name_max+1 >
(int)sizeof(struct dirent) + (int)NAMELEN(entry)

Fixes 0000250: bareos-fd asserts when reading a file from ntfs volume mounted on linux
mod - src/findlib/find_one.c Diff ] File ]
bareos2015: bareos-12.4 cdebbb5c
Timestamp: 2013-11-15 21:43:47
Author: mvwieringen
Ported: N/A
Details ] Diff ]
Some filesystems violate against the POSIX rules.

when backing up a filesystem mounted to a linux host via ntfs, we get an
assertion error:

backup-sd-fd: bfile.c:1031-0 open file
/bacula-mounts/INEZ/part2/Users/<username>/AppData/Local/Packages/WinStore_cw5n1h2txyewy/AC/Microsoft/Windows
Store/Cache/0/0-Featured-https∺∯∯next-services.apps.microsoft.com∯browse∯6.2.9200-1∯667∯c∯DE∯Featured∯10895826.dat
backup-sd-fd: backup.c:983-0 Send data to SD len=6552
backup-sd-fd: find_one.c:756-0 Failed ASSERT: name_max+1 >
(int)sizeof(struct dirent) + (int)NAMELEN(entry)

Fixes 0000250: bareos-fd asserts when reading a file from ntfs volume mounted on linux
mod - src/findlib/find_one.c Diff ] File ]
bareos2015: bareos-13.2 a586203b
Timestamp: 2013-11-15 21:43:47
Author: mvwieringen
Ported: N/A
Details ] Diff ]
Some filesystems violate against the POSIX rules.

when backing up a filesystem mounted to a linux host via ntfs, we get an
assertion error:

backup-sd-fd: bfile.c:1031-0 open file
/bacula-mounts/INEZ/part2/Users/<username>/AppData/Local/Packages/WinStore_cw5n1h2txyewy/AC/Microsoft/Windows
Store/Cache/0/0-Featured-https∺∯∯next-services.apps.microsoft.com∯browse∯6.2.9200-1∯667∯c∯DE∯Featured∯10895826.dat
backup-sd-fd: backup.c:983-0 Send data to SD len=6552
backup-sd-fd: find_one.c:756-0 Failed ASSERT: name_max+1 >
(int)sizeof(struct dirent) + (int)NAMELEN(entry)

Fixes 0000250: bareos-fd asserts when reading a file from ntfs volume mounted on linux
mod - src/findlib/find_one.c Diff ] File ]

- Issue History
Date Modified Username Field Change
2013-11-15 11:18 pstorz New Issue
2013-11-15 11:21 mvwieringen Assigned To => mvwieringen
2013-11-15 11:21 mvwieringen Status new => assigned
2013-11-15 11:21 mvwieringen Summary bareos-fd asserts when reading a file form ntfs volume mounted on linux => bareos-fd asserts when reading a file from ntfs volume mounted on linux
2013-11-16 10:00 mvwieringen Changeset attached => bareos master ed6f7276
2013-11-16 15:30 mvwieringen Changeset attached => bareos bareos-13.2 d330f872
2013-11-16 15:30 mvwieringen Note Added: 0000728
2013-11-16 15:30 mvwieringen Status assigned => resolved
2013-11-16 15:30 mvwieringen Resolution open => fixed
2013-11-16 15:30 mvwieringen Changeset attached => bareos bareos-12.4 3ac87d3a
2013-11-16 15:30 mvwieringen Note Added: 0000729
2013-11-16 15:31 mvwieringen Status resolved => closed
2013-11-16 15:31 mvwieringen Assigned To mvwieringen =>
2013-11-16 15:36 mvwieringen adm Product Version 13.2.1 => 12.4.5
2013-11-16 15:36 mvwieringen adm Fixed in Version => 12.4.6
2013-11-16 15:36 mvwieringen adm Target Version => 12.4.6
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-12.4 cdebbb5c
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-13.2 a586203b
2015-03-25 16:51 mvwieringen Note Added: 0001355
2015-03-25 16:51 mvwieringen Status closed => resolved
2015-03-25 19:18 joergs Note Added: 0001509
2015-03-25 19:18 joergs Status resolved => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker