View Issue Details

IDProjectCategoryView StatusLast Update
0000965bareos-core[All Projects] directorpublic2019-01-16 17:01
ReporterwelrbragaAssigned Toarogge 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformLinuxOSDebianOS Version9
Product Version17.2.5 
Target VersionFixed in Version 
Summary0000965: "status job" command incomplete crashs director remotelly
DescriptionIf I run "status job=" in bconsole started as root in a remote machine, the director crashs.
Steps To Reproduce1 - Configure a console to be run in a remote machine (different of director machine).
2 - Starts bconsole as root (sudo bconsole);
3 - Type status job= [ENTER] (exactly this without inform the job)
4 - Your director will be crashed but no message will be informed and you can't connect to bareos-dir again, til you restart bareos-dir. You will return to shell prompt
5 - Your oppened volumes will be reported with diferent size in catalog

wbraga@jb015:~$ sudo bconsole
Connecting to Director localhost:9101
1000 OK: bareos-dir Version: 17.2.4 (21 Sep 2017)
Enter a period to cancel a command.
*
* status job=
wbraga@jb015:~$

The only different test I have done was run bconsole without sudo, with I did after change file permitions of /etc/bareos/bconsole.conf
Additional Information
The director crashs with this log message on /var/log/syslog. Note these occured twice (12:25 and 14:21).

=== /var/log/syslog ====
Jun 15 12:25:34 jb015 bareos-dir: BAREOS interrupted by signal 11: Segmentation violation
Jun 15 12:30:12 jb015 systemd[1]: Starting Bareos Director Daemon service...
Jun 15 12:30:12 jb015 systemd[1]: bareos-director.service: PID file /var/lib/bareos/bareos-dir.9101.pid not readable (yet?) after start: No such file or directory
Jun 15 12:30:12 jb015 systemd[1]: Started Bareos Director Daemon service.
[...]
[...]
[...]
Jun 15 14:21:26 jb015 bareos-dir: BAREOS interrupted by signal 11: Segmentation violation
Jun 15 14:22:55 jb015 systemd[1]: Starting Bareos Director Daemon service...
Jun 15 14:22:55 jb015 systemd[1]: bareos-director.service: PID file /var/lib/bareos/bareos-dir.9101.pid not readable (yet?) after start: No such file or directory
Jun 15 14:22:55 jb015 systemd[1]: Started Bareos Director Daemon service.


=== /var/log/bareos/bareos.log ====
15-jun 12:46 bareos-dir JobId 1151: No prior Full backup Job record found.
15-jun 12:46 bareos-dir JobId 1151: No prior or suitable Full backup found in catalog. Doing FULL backup.
15-jun 12:46 bareos-dir JobId 1151: Start Backup JobId 1151, Job=tucum-fotowaresemanal.2018-06-15_12.46.25_26
15-jun 12:46 bareos-dir JobId 1151: Using Device "RAFAELA2" to write.
15-jun 12:46 bareos-sd JobId 1151: Volume "MiniFull-0012" previously written, moving to end of data.
15-jun 12:46 bareos-sd JobId 1151: Warning: For Volume "MiniFull-0012":
The sizes do not match! Volume=4333684805 Catalog=3400067148
Correcting Catalog
[...]
[...]
15-jun 14:32 bareos-dir JobId 1152: No prior Full backup Job record found.
15-jun 14:32 bareos-dir JobId 1152: No prior or suitable Full backup found in catalog. Doing FULL backup.
15-jun 14:32 bareos-dir JobId 1152: Start Backup JobId 1152, Job=vm024-semanal.2018-06-15_14.32.50_50
15-jun 14:32 bareos-dir JobId 1152: Using Device "RAFAELA" to write.
15-jun 14:32 bareos-sd JobId 1152: Volume "MiniFull-0004" previously written, moving to end of data.
15-jun 14:32 bareos-sd JobId 1152: Warning: For Volume "MiniFull-0004":
The sizes do not match! Volume=2516484224 Catalog=2055997601
Correcting Catalog
15-jun 14:33 bareos-dir JobId 1153: No prior Full backup Job record found.
15-jun 14:33 bareos-dir JobId 1153: No prior or suitable Full backup found in catalog. Doing FULL backup.
15-jun 14:33 bareos-dir JobId 1153: Start Backup JobId 1153, Job=tucum-fotowaresemanal.2018-06-15_14.33.08_53
15-jun 14:33 bareos-dir JobId 1153: Using Device "RAFAELA2" to write.
15-jun 14:33 bareos-sd JobId 1153: Volume "MiniFull-0006" previously written, moving to end of data.
15-jun 14:33 bareos-sd JobId 1153: Warning: For Volume "MiniFull-0006":
The sizes do not match! Volume=963035318 Catalog=59931833
Correcting Catalog


=== /var/log/bareos/bareos-audit.log ===
15-jun 12:25 bareos-dir: Console [default] from [10.10.171.6] cmdline status job=
[...]
[...]
15-jun 14:21 bareos-dir: Console [default] from [10.10.171.6] cmdline status job=
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

joergs

joergs

2018-07-13 14:57

administrator   ~0003070

I've not been able to reproduce this.

Instead, it gives me the status of a storage (I've also tested it against 17.2.7):
*status job=
Connecting to Storage daemon File at ci-CentOS-7-64-aa38a569bc6ae306:9103

bareos-sd Version: 18.2.3 (01 Jun 2018) Linux-4.4.92-6.18-default redhat CentOS Linux release 7.5.1804 (Core)
Daemon started 13-Jul-18 14:21. Jobs: run=9, running=0.
 Heap: heap=45,056 smbytes=52,061 max_bytes=63,107,514 bufs=120 max_bufs=175
 Sizes: boffset_t=8 size_t=8 int32_t=4 int64_t=8 mode=0 bwlimit=0kB/s

Running Jobs:
No Jobs running.
====

Jobs waiting to reserve a drive:
====

Terminated Jobs:
 JobId Level Files Bytes Status Finished Name
===================================================================
     1 Full 495 45.53 M OK 13-Jul-18 14:21 backup-bareos-fd
     2 0 0 OK 13-Jul-18 14:21 RestoreFiles
     3 Full 2 22.20 M OK 13-Jul-18 14:21 BackupData
     4 0 0 OK 13-Jul-18 14:21 RestoreFiles
     5 Full 84 162.8 K OK 13-Jul-18 14:21 BackupCatalog
     6 Full 496 45.53 M OK 13-Jul-18 14:21 backup-s3-fd
     7 0 0 OK 13-Jul-18 14:22 RestoreFiles
     8 Full 496 45.53 M OK 13-Jul-18 14:24 backup-s3-fd
    11 Full 496 45.53 M OK 13-Jul-18 14:36 backup-s3-fd
====

Device status:

Device "FileStorage" (/var/lib/bareos/storage) is not open.
==
====

Used Volume status:
====

====

----

When there is more than one storage, it picks one, in our case the second of three.

You may test all your storage (from bconsole:.storages) with "status storage=..."

Maybe it crashes on one of them.
arogge

arogge

2019-01-16 17:01

developer   ~0003197

I'm closing this issue, as there has not been any new information for a long time and there is nothing we can do right now.
If you can provide additional information concerning this issue, please feel free to reopen the bug.

Issue History

Date Modified Username Field Change
2018-06-17 01:54 welrbraga New Issue
2018-07-13 14:57 joergs Note Added: 0003070
2018-07-13 14:57 joergs Status new => feedback
2019-01-16 17:01 arogge Note Added: 0003197
2019-01-16 17:01 arogge Status feedback => resolved
2019-01-16 17:01 arogge Resolution open => unable to reproduce
2019-01-16 17:01 arogge Assigned To => arogge