View Issue Details

IDProjectCategoryView StatusLast Update
0000900bareos-core[All Projects] file daemonpublic2019-10-10 12:59
ReporterjoergsAssigned To 
PrioritylowSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSMacOS XOS Version10
Product Version17.2.4 
Fixed in Version 
Summary0000900: platforms/osx/Makefile conflicts when building for homebrew
Descriptionmake -f platforms/osx/Makefile install
creates "$(DESTDIR)/Library/LaunchDaemons/org.bareos.bareos-fd.plist"

However, this disturbs building bareos in https://github.com/Homebrew/homebrew-core/

Please adapt the Makefile, that it can be used for locally creating a pkg file and be used in homebrew.
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

joergs

joergs

2019-09-27 16:38

administrator   ~0003587

Is this still an issue?
arogge

arogge

2019-09-30 09:31

developer   ~0003589

Maybe. We're packaging for mac using cpack now, so the Makefile there is probably unmaintained right now.
We'll need to discuss whether or not we want to support this in the future.
joergs

joergs

2019-10-10 12:59

administrator   ~0003594

The platforms/osx path has been removed since branch 18.2.

Issue History

Date Modified Username Field Change
2018-01-27 21:46 joergs New Issue
2018-01-27 21:46 joergs Status new => assigned
2018-01-27 21:46 joergs Assigned To => joergs
2019-09-27 16:38 joergs Assigned To joergs => arogge
2019-09-27 16:38 joergs Note Added: 0003587
2019-09-30 09:31 arogge Note Added: 0003589
2019-10-10 11:37 arogge Assigned To arogge => joergs
2019-10-10 12:59 joergs Assigned To joergs =>
2019-10-10 12:59 joergs Status assigned => resolved
2019-10-10 12:59 joergs Resolution open => fixed
2019-10-10 12:59 joergs Note Added: 0003594