View Issue Details

IDProjectCategoryView StatusLast Update
0000871bareos-core[All Projects] webuipublic2021-07-06 17:22
ReportertuxmasterAssigned Tofrank 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSCentOSOS Version7
Product Version17.4.2 
Fixed in Version 
Summary0000871: UI will not load complete
DescriptionAfter the login, the website will not load complete.
Only the spinner are shown. (See picture)

The php error log will flooded with:
PHP Notice: Undefined index: meta in /usr/share/bareos-webui/module/Job/src/Job/Model/JobModel.php on line 120

The bareos director will run with version 16.2.7.
Additional InformationPHP 7.1 via fpm
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

tuxmaster

tuxmaster

2017-11-04 16:10

reporter  

frank

frank

2017-11-09 15:35

manager   ~0002812

DIRD and WebUI need to have the same version currently.

WebUI 17.2.4 is not compatible to a 16.2.7 director yet, which may change in future.
tuxmaster

tuxmaster

2017-11-09 17:36

reporter   ~0002813

Thanks for the information.
But this shout be noted in the release notes, or better result in an error message about an unsupported version.
frank

frank

2021-06-30 11:49

manager   ~0004169

There is a note in the installation chapter, see https://docs.bareos.org/master/IntroductionAndTutorial/InstallingBareosWebui.html#system-requirements .
Nevertheless, I'm going to have a look if we can somehow improve the error handling reagarding version compatibility.
frank

frank

2021-07-06 17:22

manager   ~0004176

Fix committed to bareos master branch with changesetid 15057.

Related Changesets

bareos: master a30180d8

2021-06-30 13:17:18

frank

Ported: N/A

Details Diff
webui: check major version compatibility between webui and DIR

To ensure the installed WEBUI and DIR have the same version
because of compatibility reasons, this commit introduces a version
check at login time which provides an error message if versions
do not match.

Fixes 0000871: UI will not load complete
Affected Issues
0000871
mod - webui/module/Auth/src/Auth/Controller/AuthController.php Diff File

Issue History

Date Modified Username Field Change
2017-11-04 16:10 tuxmaster New Issue
2017-11-04 16:10 tuxmaster File Added: Bildschirmfoto von »2017-11-04 16-06-19«.png
2017-11-08 10:49 frank Assigned To => frank
2017-11-08 10:49 frank Status new => assigned
2017-11-09 15:35 frank Note Added: 0002812
2017-11-09 15:37 frank Status assigned => feedback
2017-11-09 17:36 tuxmaster Note Added: 0002813
2017-11-09 17:36 tuxmaster Status feedback => assigned
2021-06-30 11:49 frank Note Added: 0004169
2021-07-06 17:22 frank Changeset attached => bareos master a30180d8
2021-07-06 17:22 frank Note Added: 0004176
2021-07-06 17:22 frank Status assigned => resolved
2021-07-06 17:22 frank Resolution open => fixed