View Issue Details

IDProjectCategoryView StatusLast Update
0000804bareos-core[All Projects] installer / packagespublic2019-01-16 15:51
ReporterwintesterAssigned Toarogge 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Platformx86OSwindowsOS Version7 prof
Product Version16.2.4 
Target VersionFixed in Version 
Summary0000804: Full install problem on windows
Descriptionwhen selected full install pop-up window appear:
"Visual C++ Redistributable for Visual Studio 2012 x86 was not found ..."

vcredist_x86 2012 is installed
Steps To Reproducerun install select "Full SQLite" or "Full PostgreSQL" next next next install pop-up window appear, can't close this window

TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

joergs

joergs

2017-09-21 22:45

administrator   ~0002752

I've not seen this message before.
However, it will be generated by the Windows installer:
https://github.com/bareos/bareos/blob/master/platforms/win32/winbareos.nsi


   ReadRegDword $R1 HKLM "SOFTWARE\Wow6432Node\Microsoft\VisualStudio\11.0\VC\Runtimes\x86" "Installed"
check_for_vc_redist:
   ${If} $R1 == ""
      ExecShell "open" "https://www.microsoft.com/en-us/download/details.aspx?id=30679"
      MessageBox MB_OK|MB_ICONSTOP "Visual C++ Redistributable for Visual Studio 2012 x86 was not found$\r$\n\
                                 It is needed by the bareos-webui service.$\r$\n\
                                 Please install vcredist_x86.exe from $\r$\n\
                                 https://www.microsoft.com/en-us/download/details.aspx?id=30679$\r$\n\
                                 and click OK when done." /SD IDOK
   ${EndIf}

You can not close it, or it reappears again and again?

It tries to detect if vcredist_x86.exe is installed by testing, if the registry contains the key "SOFTWARE\Wow6432Node\Microsoft\VisualStudio\11.0\VC\Runtimes\x86" "Installed"

You say, vcredist_x86 is installed on your system. Does this registry key exists? Do it exist in some other place?
arogge

arogge

2019-01-16 15:51

developer   ~0003193

I'm closing this issue, as there has not been any new information for a long time and there is nothing we can do right now.
If you can provide additional information concerning this issue, please feel free to reopen the bug.

Issue History

Date Modified Username Field Change
2017-04-01 20:03 wintester New Issue
2017-09-21 22:45 joergs Note Added: 0002752
2017-09-21 22:45 joergs Status new => feedback
2019-01-16 15:51 arogge Note Added: 0003193
2019-01-16 15:51 arogge Status feedback => resolved
2019-01-16 15:51 arogge Resolution open => unable to reproduce
2019-01-16 15:51 arogge Assigned To => arogge