View Issue Details

IDProjectCategoryView StatusLast Update
0000803bareos-core[All Projects] webuipublic2021-08-30 12:47
ReporterchipAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformLinuxOSDebianOS Version7
Product Version17.1.3 
Fixed in Version 
Summary0000803: Does not list files in bareos-webui when restoring
DescriptionWhen open Restore menu and select any backup jobs, no files shown in "Select files to be restored" window. Restore job via bconsole menu shows files correctly.
Steps To ReproduceNo errors in nginx logs, no php errors on a web page.
Bareos-webui has access to bareos-dir via restricted console.
Restore job works fine via bconsole.
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Relationships

related to 0000851 closed Webui does not give any output when requested to restore, or to file list the files within a backup already done. 

Activities

chip

chip

2017-03-26 11:57

reporter  

bareos-web.png (55,724 bytes)
bareos-web.png (55,724 bytes)
RangerDB

RangerDB

2018-02-04 05:02

reporter   ~0002898

I am running version 17.2.4 and have the same issue. In fact it's been an issue for the last two versions I've installed. The bconsole list of files shows files exist but the WebUI simply shows the wheel land Loading ... for a long, long time until it shows the Oops must be two many files. The set is not that big.
hostedpower

hostedpower

2018-04-06 11:02

reporter   ~0002972

Hi,

We have the same issue with some (not all) backup jobs. Wehn we disable the "merge files", it does show files.

I don't think this is a minor bug since it's very cumbersome to restore now without the webui. Our support team is not up to this :/
frank

frank

2021-07-22 11:14

manager   ~0004186

There were numerous fixes since this report has been opened, please let us know if the problem still persists after updating to one of our latest maintained versions 20.x, 19.x or 18.x.

Also please read https://docs.bareos.org/bareos-20/IntroductionAndTutorial/InstallingBareosWebui.html#configure-updating-the-bvfs-cache-frequently .
hostedpower

hostedpower

2021-07-22 11:30

reporter   ~0004187

I don't think I've seen this recently to be honest :)
frank

frank

2021-08-30 12:47

manager   ~0004233

Please reopen or create a new report if you still encounter this issue.

Thank you!

Issue History

Date Modified Username Field Change
2017-03-26 11:57 chip New Issue
2017-03-26 11:57 chip File Added: bareos-web.png
2017-03-27 12:25 frank Assigned To => frank
2017-03-27 12:25 frank Status new => assigned
2018-02-04 05:02 RangerDB Note Added: 0002898
2018-04-06 11:02 hostedpower Note Added: 0002972
2021-07-22 10:58 frank Relationship added related to 0000851
2021-07-22 11:14 frank Note Added: 0004186
2021-07-22 11:14 frank Status assigned => feedback
2021-07-22 11:30 hostedpower Note Added: 0004187
2021-08-30 12:47 frank Assigned To frank =>
2021-08-30 12:47 frank Status feedback => closed
2021-08-30 12:47 frank Resolution open => unable to reproduce
2021-08-30 12:47 frank Note Added: 0004233