View Issue Details

IDProjectCategoryView StatusLast Update
0000738bareos-core[All Projects] file daemonpublic2016-12-13 11:11
ReporterthorstenAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
PlatformLinuxOSUbuntuOS Version14.04
Product Version16.2.4 
Fixed in Version 
Summary0000738: Filedaemon does not start after upgrading
DescriptionBareos filedaemon does not start after upgrading from 15.2 to 16.2. The cause seems to be the configuration directives in directory bareos-fd.d which are active although there is already an active configuration (bareos-fd.conf)
Steps To ReproduceUpdate existing client from 15.2 to 16.2
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

joergs

joergs

2016-12-12 17:51

administrator   ~0002465

Hi,

the normal update process is tested, manual as well as automatically.
If a /etc/bareos/bareos-fd.conf exists, it will be used.

You can verify this by:
bareos-fd -xc (prints the currently used config)
or starting bareos-fd is debug mode:
bareos-fd -f -d 100

Please provide additional information about why this is a general bug.
thorsten

thorsten

2016-12-13 10:59

reporter   ~0002469

I'm not able to reproduce the issue at the moment. Please close the issue. Thanks.

Issue History

Date Modified Username Field Change
2016-12-12 17:25 thorsten New Issue
2016-12-12 17:51 joergs Note Added: 0002465
2016-12-12 17:51 joergs Status new => feedback
2016-12-13 10:59 thorsten Note Added: 0002469
2016-12-13 10:59 thorsten Status feedback => new
2016-12-13 11:11 joergs Status new => closed
2016-12-13 11:11 joergs Resolution open => no change required