View Issue Details

IDProjectCategoryView StatusLast Update
0000709bareos-core[All Projects] storage daemonpublic2019-04-10 17:44
Reporterf.huberAssigned Toarogge 
PrioritylowSeveritycrashReproducibilityrandom
Status closedResolutionunable to reproduce 
PlatformLinuxOSCentOSOS Version7
Product Version15.2.2 
Target VersionFixed in Version 
Summary0000709: Storage Daemon crashes
DescriptionFrom time to time the storage daemon crashes with this error:

bareos.log:14-Oct 14:52 mng-backup-bacula-sd: ABORTING due to ERROR in smartall.c:208
bareos.log-20160901:03-Aug 23:27 mng-backup-bacula-sd: ABORTING due to ERROR in smartall.c:208
bareos.log-20160901:19-Aug 23:55 mng-backup-bacula-sd: ABORTING due to ERROR in smartall.c:229
bareos.log-20161001:07-Sep 19:30 mng-backup-bacula-sd: ABORTING due to ERROR in smartall.c:229
bareos.log-20161001:17-Sep 19:30 mng-backup-bacula-sd: ABORTING due to ERROR in smartall.c:229

After a daemon restart the backups usually continue.
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impactyes
bareos-15.2: action
bareos-14.2: impactno
bareos-14.2: action
bareos-13.2: impactno
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

joergs

joergs

2016-10-14 16:03

administrator   ~0002401

There have been quite q few bugfixes against sd crashes since the release of 15.2.2.
You might try with bareos-16.2.4 (currently release candidate).
arogge

arogge

2019-03-18 12:59

developer   ~0003295

Can you check wether or not this is reproducible with the latest 18.2 release?
If so: can you please provide a backtrace of that happens so we can look into this?

Thank you!
arogge

arogge

2019-04-10 16:40

developer   ~0003319

Sorry, I'm closing the bug as there has not been any feedback.

Issue History

Date Modified Username Field Change
2016-10-14 15:54 f.huber New Issue
2016-10-14 16:03 joergs Note Added: 0002401
2016-10-14 16:03 joergs bareos-15.2: impact => yes
2016-10-14 16:03 joergs bareos-14.2: impact => no
2016-10-14 16:03 joergs bareos-13.2: impact => no
2016-10-14 16:03 joergs Priority high => low
2019-03-18 12:59 arogge Assigned To => arogge
2019-03-18 12:59 arogge Status new => feedback
2019-03-18 12:59 arogge Note Added: 0003295
2019-04-10 16:40 arogge Status feedback => resolved
2019-04-10 16:40 arogge Resolution open => unable to reproduce
2019-04-10 16:40 arogge Note Added: 0003319
2019-04-10 17:44 arogge Status resolved => closed