View Issue Details

IDProjectCategoryView StatusLast Update
0000703bareos-core[All Projects] directorpublic2016-10-10 19:31
ReporterM1Sports20Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
PlatformX86OSArch LinuxOS VersionRolling
Product Version16.2.4rc 
Fixed in Version16.2.4rc 
Summary0000703: Always Increment mode Consolidate job
DescriptionThere is no product version for 16.2.4, so I reported with an older version.

I have several "Always Increment Mode" jobs running each having their own client and pool. The consolidate jobs are also setup as such. I noticed that when a consolidate job runs it seems to consolidate for all pools not just the pools associated with the job. If this is how it is suppose to work it wasn't very clear in the documentation.
Additional InformationConfiguration snapshot:

Job {
  Name = "client1"
  Enabled = yes
  JobDefs = "AlwaysIncrementalMode"
  Full Backup Pool = client1-Full
  Pool = client1-Inc
  Client = client_mach
  Priority = 9
  FileSet = "Linux All - Server"
}

Job {
  Name = "client1Consolidate"
  Enabled = yes
  JobDefs = "Consolidate"
  Pool = client1-Inc
  Client = client_mach
  Priority = 9
  FileSet = "Linux All - Server"
}
Job {
  Name = "Client2Backup"
  Enabled = yes
  JobDefs = "AlwaysIncrementalMode"
  Pool = Client2-Inc
  Full Backup Pool = Client2-Full
  Client = Client2_
  FileSet = "Windows All Drives"
}

Job {
  Name = "Client2Consolidate"
  Enabled = yes
  JobDefs = "Consolidate"
  Pool = Client2-Inc
  Client = Client2
  FileSet = "Windows All Drives"
}

Here is a message from one consolidate job running (I expected these consolidations to be separate jobs, since they are separate pools):
03-Oct 10:30 my-dir JobId 12: Start Consolidate JobId 12, Job=Client1Consolidate.2016-10-03_10.30.00_14
03-Oct 10:30 my-dir JobId 12: Looking at always incremental job Client1
03-Oct 10:30 my-dir JobId 12: Client1: considering jobs older than 05-Jul-2016 10:30:01 for consolidation.
03-Oct 10:30 my-dir JobId 12: Client1: less than two jobs to consolidate found, doing nothing.
03-Oct 10:30 my-dir JobId 12: Looking at always incremental job Client2Backup
03-Oct 10:30 my-dir JobId 12: Client2Backup: considering jobs older than 05-Jul-2016 10:30:01 for consolidation.
03-Oct 10:30 my-dir JobId 12: Client2Backup: less incrementals than required, not consolidating
03-Oct 10:30 my-dir JobId 12: BAREOS 16.2.4 (01Jul16): 03-Oct-2016 10:30:10
  JobId: 12
  Job: Client1Consolidate.2016-10-03_10.30.00_14
  Scheduled time: 03-Oct-2016 10:30:00
  Start time: 03-Oct-2016 10:30:00
  End time: 03-Oct-2016 10:30:10
  Termination: Consolidate OK
TagsNo tags attached.
bareos-master: impactyes
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impactyes
bareos-16.2: action
bareos-15.2: impactno
bareos-15.2: action
bareos-14.2: impactno
bareos-14.2: action
bareos-13.2: impactno
bareos-13.2: action
bareos-12.4: impactno
bareos-12.4: action

Relationships

child of 0000698 closedstephand Release bareos-16.2.4 

Activities

joergs

joergs

2016-10-07 13:57

developer   ~0002378

Yes, it is intended in this way. I'll update the documentation to clarify this.

FYI: Filtering for a consolidate job based on Storage or Pool will not make sense. However, future releases may include a filtering based on Job names (Selection Type = Job, Selection Pattern = .*).
joergs

joergs

2016-10-10 19:30

developer   ~0002379

The information have been published with https://github.com/bareos/bareos-docs/commit/9725c921301eb370ec1d6e4712e5f436a5d4740e

It should be available on http://doc.bareos.org tomorrow.

Issue History

Date Modified Username Field Change
2016-10-03 16:58 M1Sports20 New Issue
2016-10-07 13:50 joergs bareos-master: impact => yes
2016-10-07 13:50 joergs bareos-16.2: impact => yes
2016-10-07 13:50 joergs bareos-15.2: impact => no
2016-10-07 13:50 joergs bareos-14.2: impact => no
2016-10-07 13:50 joergs bareos-13.2: impact => no
2016-10-07 13:50 joergs bareos-12.4: impact => no
2016-10-07 13:50 joergs Product Version 15.2.4 => 16.2.4rc
2016-10-07 13:55 joergs Relationship added child of 0000698
2016-10-07 13:57 joergs Note Added: 0002378
2016-10-07 13:57 joergs Assigned To => joergs
2016-10-07 13:57 joergs Status new => assigned
2016-10-10 19:30 joergs Note Added: 0002379
2016-10-10 19:30 joergs Status assigned => resolved
2016-10-10 19:30 joergs Fixed in Version => 16.2.4rc
2016-10-10 19:30 joergs Resolution open => no change required
2016-10-10 19:31 joergs Status resolved => closed
2016-10-10 19:31 joergs Assigned To joergs =>