View Issue Details

IDProjectCategoryView StatusLast Update
0000683bareos-core[All Projects] storage daemonpublic2019-01-16 15:34
ReporterozzicatAssigned Toarogge 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
PlatformLinuxOSDebianOS Version8
Product Version15.2.2 
Target VersionFixed in Version 
Summary0000683: Bareos-sd stops on one job
DescriptionStorage deamon stops with this error on one job

lkpsx1038-ha-sd (100): dev.c:646-870 open disk: mode=CREATE_READ_WRITE open(Rados Device/fs-lkp-1-full-2241, 0x42, 0640)
lkpsx1038-ha-sd (100): dev.c:662-870 open dev: disk fd=0 opened
lkpsx1038-ha-sd (100): dev.c:580-870 preserve=0x3ec1e6b0 fd=0
lkpsx1038-ha-sd (150): label.c:378-870 Label type=0
lkpsx1038-ha-sd (130): label.c:689-870 Start create_volume_label()
lkpsx1038-ha-sd (100): dev.c:921-870 Clear volhdr vol=

Volume Label:
Id : Bareos 2.0 immortal
VerNo : 20
VolName : fs-lkp-1-full-2241
PrevVolName :
VolFile : 0
LabelType : PRE_LABEL
LabelSize : 0
PoolName : fs-lkp-1-full
MediaType : ceph-bareos-003
PoolType : Backup
HostName : lkpsx1038-ha
Date label written: 09-aug-2016 11:33
lkpsx1038-ha-sd (150): label.c:679-870 Created Vol label rec: FI=PRE_LABEL len=199
lkpsx1038-ha-sd (130): label.c:426-870 Wrote label of 199 bytes to "ceph-bareos-003" (Rados Device)
lkpsx1038-ha-sd (130): label.c:430-870 Call write_block_to_dev()
*** Error in `/usr/sbin/bareos-sd': corrupted double-linked list: 0x00007f213015a1e0 ***

TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

mvwieringen

mvwieringen

2016-08-09 19:09

developer   ~0002333

Given the error is not generated by Bareos its probably some corruption
detected by glibc in the CEPH code. It may be due to the way we do things
but I never seen this in my testing. Your best bet is to see if there are
any CEPH updates. Not sure if a proper core file is generated then a
stack trace may give you a hint.
arogge

arogge

2019-01-16 15:34

developer   ~0003192

I'm closing this issue, as there has not been any new information for a long time and there is nothing we can do right now.
If you can provide additional information so we can reproduce this issue, please feel free to reopen the bug.

Issue History

Date Modified Username Field Change
2016-08-09 16:08 ozzicat New Issue
2016-08-09 19:09 mvwieringen Note Added: 0002333
2016-08-09 19:10 mvwieringen Status new => feedback
2019-01-16 15:34 arogge Note Added: 0003192
2019-01-16 15:34 arogge Status feedback => resolved
2019-01-16 15:34 arogge Resolution open => unable to reproduce
2019-01-16 15:34 arogge Assigned To => arogge