View Issue Details

IDProjectCategoryView StatusLast Update
0000595bareos-core[All Projects] webuipublic2017-06-08 16:27
ReporterRobert SmitAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version14.04
Product Version15.4.0 
Fixed in Version 
Summary0000595: Clients view in Webui doesn't work when there are dots in the client names
DescriptionFor the client names (file daemon) configuration in Bareos we use the FQDN of the server.
For example: "server1.domain.com-fd".
This causes the webui to generate an error when clicking on the "Clients" menu button and then on one of the Client links. Also When going from the Dashboard menu button to the list of successful backups link, the list is presented, but clicking on the Client links result in the same error.
The error I get is:
A 404 error occurred
Page not found.
The requested URL could not be matched by routing.
No Exception available
Steps To ReproduceCreate a backup job in the Director with dot's in the Client's (File Daemon) names.

Logged on in Webui:
Clients -> Client link
Dashboard -> Successful Backups -> Client link.
Additional InformationWhen I change the following I can use dot's in the Clients names:
/module/Client/config/module.config.php

Line 46:

'id' => '[a-zA-Z][a-zA-Z0-9_-]*',

change to

'id' => '[a-zA-Z][a-zA-Z0-9\._-]*',
TagsNo tags attached.
bareos-master: impactyes
bareos-master: actionfixed
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impactyes
bareos-15.2: actionfixed
bareos-14.2: impactno
bareos-14.2: action
bareos-13.2: impactno
bareos-13.2: action
bareos-12.4: impactno
bareos-12.4: action

Relationships

duplicate of 0000646 closed Problems with certain characters in client name 
child of 0000625 closedmaik Release bareos-15.2.3 

Activities

mvwieringen

mvwieringen

2016-01-11 17:41

developer   ~0002089

Yes seems like a simple routing problem. Will ask Frank to
look at this after his vacation but for now we can add this
patch so that people using FQDN will have a working WebUI.

I added it with you as author.
mvwieringen

mvwieringen

2016-01-11 17:43

developer   ~0002090

Fix committed to bareos-webui bareos-15.2 branch with changesetid 6073.

Related Changesets

bareos-webui: bareos-15.2 75332f9e

2016-01-11 17:39:37

Robert Smit


Committer: mvwieringen

Ported: N/A

Details Diff
Fix routing for clients.

Allow also dots in client names for the Client routing.

Fixes 0000595: Clients view in Webui doesn't work when there are dots in
the client names

Signed-off-by: Marco van Wieringen <marco.van.wieringen@bareos.com>
Affected Issues
0000595
mod - module/Client/config/module.config.php Diff File

Issue History

Date Modified Username Field Change
2016-01-11 17:16 Robert Smit New Issue
2016-01-11 17:16 Robert Smit Status new => assigned
2016-01-11 17:16 Robert Smit Assigned To => frank
2016-01-11 17:41 mvwieringen Note Added: 0002089
2016-01-11 17:41 mvwieringen Status assigned => feedback
2016-01-11 17:43 mvwieringen Changeset attached => bareos-webui bareos-15.2 75332f9e
2016-01-11 17:43 mvwieringen Note Added: 0002090
2016-01-11 17:43 mvwieringen Status feedback => resolved
2016-01-11 17:43 mvwieringen Resolution open => fixed
2016-03-11 14:39 maik bareos-15.2: impact => yes
2016-03-11 14:39 maik bareos-15.2: action => fixed
2016-03-11 14:39 maik Relationship added child of 0000625
2016-06-10 17:01 frank Relationship added duplicate of 0000646
2016-07-05 13:24 joergs bareos-master: impact => yes
2016-07-05 13:24 joergs bareos-master: action => fixed
2016-07-05 13:24 joergs bareos-14.2: impact => no
2016-07-05 13:24 joergs bareos-13.2: impact => no
2016-07-05 13:24 joergs bareos-12.4: impact => no
2017-06-08 16:27 frank Status resolved => closed
2017-06-08 16:27 frank Assigned To frank =>