View Issue Details

IDProjectCategoryView StatusLast Update
0000560bareos-core[All Projects] webuipublic2019-01-16 11:44
ReporterhegeAssigned Tofrank 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSCentOSOS Version7
Product Version15.2.1 
Target VersionFixed in Version 
Summary0000560: Restore displays invalid date on Windows directories
DescriptionAny Windows client I browse, directories are displayed with this date:

Sun, 29 Nov 2076 08:54:36 GMT (sometimes a few seconds more)

When actual restore is done, everything has correct dates on filesystem, so it seems only webui is broken.
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

hege

hege

2015-12-01 12:13

reporter   ~0002022

I made a fresh 15.2 test installation and backup. This is not an issue there.

My old upgraded 15.2 installation and old backups show faulty dates, so I have probably some stale data there, what to check?
frank

frank

2016-01-21 13:08

manager   ~0002138

Full path meta data of your directories is not necessarily stored in your backups. It depends on how your filesets looks like and/or the backup level.

That is the reason why Webui shows some wrong or lets say miscalculated dates.

This of course can/should be improved.
arogge

arogge

2019-01-16 11:44

developer   ~0003186

I'm unable to reproduce this issue in the current release. I guess the problem was fixed someday and nobody updated the bug.

Issue History

Date Modified Username Field Change
2015-11-10 20:50 hege New Issue
2015-11-10 20:50 hege Status new => assigned
2015-11-10 20:50 hege Assigned To => frank
2015-12-01 12:13 hege Note Added: 0002022
2015-12-11 15:41 frank Status assigned => acknowledged
2016-01-21 13:08 frank Note Added: 0002138
2016-01-21 13:08 frank Status acknowledged => feedback
2019-01-16 11:44 arogge Note Added: 0003186
2019-01-16 11:44 arogge Status feedback => resolved
2019-01-16 11:44 arogge Resolution open => fixed