View Issue Details

IDProjectCategoryView StatusLast Update
0000054bareos-coreinstaller / packagespublic2015-03-25 19:18
Reporterstephand Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSopenSUSEOS Version12.1
Product Version12.4.1 
Fixed in Version12.4.1 
Summary0000054: make_catalog_backup.pl tries to call /usr/sbin/bareos_dbcheck, must be /usr/sbin/bareos-dbcheck
DescriptionBackupCatalog job fails
Steps To Reproducerun job=BackupCatalog

*messages
05-Feb 18:03 gw-dir JobId 16: shell command: run BeforeJob "/usr/lib/bareos/scripts/make_catalog_backup.pl MyCatalog"
05-Feb 18:03 gw-dir JobId 16: BeforeJob: sh: /usr/sbin/bareos_dbcheck: No such file or directory
05-Feb 18:03 gw-dir JobId 16: BeforeJob: Can't find your catalog (MyCatalog) in director configuration
05-Feb 18:03 gw-dir JobId 16: Error: Runscript: BeforeJob returned non-zero status=1. ERR=Child exited with code 1
Additional Informationtrivial to fix:

--- /usr/lib/bareos/scripts/make_catalog_backup.pl.orig 2013-02-05 18:37:30.308873990 +0100
+++ /usr/lib/bareos/scripts/make_catalog_backup.pl 2013-02-05 18:37:43.928033348 +0100
@@ -38,7 +38,7 @@
 =cut
 
 my $cat = shift or die "Usage: $0 catalogname";
-my $dir_conf='/usr/sbin/bareos_dbcheck -B -c /etc/bareos/bareos-dir.conf';
+my $dir_conf='/usr/sbin/bareos-dbcheck -B -c /etc/bareos/bareos-dir.conf';
 my $wd = "/var/lib/bareos";
 
 sub dump_sqlite3
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

mvwieringen adm

mvwieringen adm

2013-08-13 03:12

administrator   ~0000630

Fix committed to bareos master branch with changesetid 879.
mvwieringen

mvwieringen

2015-03-25 16:51

developer   ~0001404

Fix committed to bareos2015 bareos-13.2 branch with changesetid 4435.
joergs

joergs

2015-03-25 19:18

developer   ~0001563

Due to the reimport of the Github repository to bugs.bareos.org, the status of some tickets have been changed. These tickets will be closed again.
Sorry for the noise.

Related Changesets

bareos: master 6fe7b608

2013-05-04 09:51:49

mvwieringen adm

Ported: N/A

Details Diff
Fix typo.

Fixes 0000054: make_catalog_backup.pl tries to call /usr/sbin/bareos_dbcheck,
must be /usr/sbin/bareos-dbcheck
Affected Issues
0000054
mod - src/cats/make_catalog_backup.pl.in Diff File

bareos2015: bareos-12.4 3970de48

2013-05-04 11:51:49

mvwieringen

Ported: N/A

Details Diff
Fix typo.

Fixes 0000054: make_catalog_backup.pl tries to call /usr/sbin/bareos_dbcheck,
must be /usr/sbin/bareos-dbcheck
Affected Issues
0000054
mod - src/cats/make_catalog_backup.pl.in Diff File

bareos2015: bareos-13.2 169865e4

2013-05-04 11:51:49

mvwieringen

Ported: N/A

Details Diff
Fix typo.

Fixes 0000054: make_catalog_backup.pl tries to call /usr/sbin/bareos_dbcheck,
must be /usr/sbin/bareos-dbcheck
Affected Issues
0000054
mod - src/cats/make_catalog_backup.pl.in Diff File

Issue History

Date Modified Username Field Change
2013-02-05 18:40 stephand New Issue
2013-02-05 18:50 mvwieringen Assigned To => mvwieringen
2013-02-05 18:50 mvwieringen Status new => assigned
2013-02-05 18:53 mvwieringen Changeset attached => bareos master c37b8db5
2013-02-05 18:53 mvwieringen Status assigned => closed
2013-02-05 18:53 mvwieringen Resolution open => fixed
2013-02-05 18:54 mvwieringen Target Version => 12.4.0
2013-02-05 18:54 mvwieringen Fixed in Version => 12.4.0
2013-02-05 18:54 mvwieringen Assigned To mvwieringen =>
2013-03-04 10:39 mvwieringen Product Version => 12.4.1
2013-03-04 10:39 mvwieringen Fixed in Version => 12.4.1
2013-08-13 03:12 mvwieringen adm Changeset attached => bareos master 6fe7b608
2013-08-13 03:12 mvwieringen adm Note Added: 0000630
2013-08-13 03:12 mvwieringen adm Assigned To => mvwieringen adm
2013-08-13 03:12 mvwieringen adm Status closed => resolved
2013-08-13 08:41 mvwieringen adm Assigned To mvwieringen adm =>
2013-08-13 08:41 mvwieringen adm Status resolved => closed
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-12.4 3970de48
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-13.2 169865e4
2015-03-25 16:51 mvwieringen Note Added: 0001404
2015-03-25 16:51 mvwieringen Status closed => resolved
2015-03-25 19:18 joergs Note Added: 0001563
2015-03-25 19:18 joergs Status resolved => closed