View Issue Details

IDProjectCategoryView StatusLast Update
0000536bareos-core[All Projects] directorpublic2015-11-06 17:09
Reporteravantsysadm@avant.caAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionreopened 
PlatformLinuxOSCentOSOS Version6
Product Version15.2.1 
Fixed in Version 
Summary0000536: 15.2-rc1 complains non-stop about TCP_KEEPIDLE
DescriptionBareos 15.2-rc1 accumulates a non-stop stream of warning messages, all identical:

*messag
13-Oct 10:31 amanda1-dir JobId 0: Warning: bsock_tcp.c:293 Cannot set TCP_KEEPIDLE on socket: Invalid argument
13-Oct 10:31 amanda1-dir JobId 0: Warning: bsock_tcp.c:293 Cannot set TCP_KEEPIDLE on socket: Invalid argument
13-Oct 10:31 amanda1-dir JobId 0: Warning: bsock_tcp.c:293 Cannot set TCP_KEEPIDLE on socket: Invalid argument
13-Oct 10:31 amanda1-dir JobId 0: Warning: bsock_tcp.c:293 Cannot set TCP_KEEPIDLE on socket: Invalid argument
13-Oct 10:31 amanda1-dir JobId 0: Warning: bsock_tcp.c:293 Cannot set TCP_KEEPIDLE on socket: Invalid argument
13-Oct 10:31 amanda1-dir JobId 0: Warning: bsock_tcp.c:293 Cannot set TCP_KEEPIDLE on socket: Invalid argument
13-Oct 10:31 amanda1-dir JobId 0: Warning: bsock_tcp.c:293 Cannot set TCP_KEEPIDLE on socket: Invalid argument
13-Oct 10:31 amanda1-dir JobId 0: Warning: bsock_tcp.c:293 Cannot set TCP_KEEPIDLE on socket: Invalid argument
13-Oct 10:31 amanda1-dir JobId 0: Warning: bsock_tcp.c:293 Cannot set TCP_KEEPIDLE on socket: Invalid argument
Steps To ReproduceRun the director.
Additional InformationNot sure what else to say... other than the bug tracker needs to allow me to pick version 15.2-rc1 when entering new bugs.
TagsNo tags attached.
bareos-master: impactyes
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impactyes
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

mvwieringen

mvwieringen

2015-11-06 09:32

developer   ~0001923

Looking at some configs from the zillion other problems you opened it seems
you have some problems understanding the meaning of the heartbeat mechanism.
Either setup the heartbeat right (e.g. if you really need it, its only needed
when you have connections through firewalls that otherwise time out) or set it
to a proper value e.g. every 300 seconds or so. What probably happens now is
that you set a value that is to low 0 (which makes absolutely no sense, did you
mean to disable it ? then don't set it at all as that is default.) the
TCP_KEEPIDLE setting is something that was in Bacula for ages so its been working
for ages already so as long as you set correct values things tend to work fine.

B.T.W. most problems you opened in the bug tracker are not really bugs but
more misinterpretations from the docs so maybe it helps to first post one mail
to the users mailinglist with the issues you ran into.
avantsysadm@avant.ca

avantsysadm@avant.ca

2015-11-06 16:33

reporter   ~0001924

1. From the docs: "The default value is zero, which means no change is made to the socket." Setting it explicitly to zero should not - and does not - generate this error. So that works as expected.

2. I had it set to 1 (one) when I was getting this error, as I was trying to determine if my firewall was part of the problem. As far as I can tell, this error still should not have been generated; I've followed the code path and I can't see any reason I can't set TCP_KEEPIDLE to 1. Unless it's another Capabilities / permissions problem? Yes, that's a silly setting for production, but I was trying to debug.

As soon as the current backup finishes, I'll test to see if there is in fact a lower bound, or whether it's global (which might indicate a permission problem or something like that).
avantsysadm@avant.ca

avantsysadm@avant.ca

2015-11-06 16:58

reporter   ~0001929

Cannot reproduce in nightly build. I'm not going back to crashing build (15.2.1) right now just to test this, so keep it closed - sorry for the noise.

Issue History

Date Modified Username Field Change
2015-10-13 17:36 avantsysadm@avant.ca New Issue
2015-10-30 14:14 joergs bareos-master: impact => yes
2015-10-30 14:14 joergs bareos-15.2: impact => yes
2015-10-30 14:14 joergs Product Version => 15.2.1
2015-11-06 09:32 mvwieringen Note Added: 0001923
2015-11-06 09:32 mvwieringen Status new => closed
2015-11-06 09:32 mvwieringen Resolution open => no change required
2015-11-06 16:33 avantsysadm@avant.ca Note Added: 0001924
2015-11-06 16:33 avantsysadm@avant.ca Status closed => feedback
2015-11-06 16:33 avantsysadm@avant.ca Resolution no change required => reopened
2015-11-06 16:58 avantsysadm@avant.ca Note Added: 0001929
2015-11-06 16:58 avantsysadm@avant.ca Status feedback => new
2015-11-06 17:09 mvwieringen Status new => closed