View Issue Details

IDProjectCategoryView StatusLast Update
0000463bareos-corefile daemonpublic2015-06-01 16:21
ReporterSergeyMorozov Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOSWindowsOS Version2008 R2
Product Version14.2.2 
Summary0000463: Crash when restore compressed files
DescriptionThe problem occurs when restoring compressed files (using NTFS compression). Bareos-fd is always crashing.
Steps To ReproduceBackup files with NTFS-compression, then try to restore it to NTFS volume.
TagsNo tags attached.
bareos-master: impactyes
bareos-master: actionfixed
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impactyes
bareos-14.2: actionfixed
bareos-13.2: impact
bareos-13.2: actionnone
bareos-12.4: impact
bareos-12.4: actionnone

Relationships

child of 0000447 closedjoergs Release bareos-14.2.5 

Activities

SergeyMorozov

SergeyMorozov

2015-04-30 10:24

reporter  

bareos-fd.trace (288,620 bytes)
SergeyMorozov

SergeyMorozov

2015-04-30 10:27

reporter   ~0001702

I tried to use nightly build (winbareos-14.4.0.gitblit.1430154352.eb1fd1c-postvista-64-bit-r18.1.exe) and the problem is there.
SergeyMorozov

SergeyMorozov

2015-04-30 11:37

reporter   ~0001704

Messages from Windows application log:

Log Name: Application
Source: Windows Error Reporting
Date: 30.04.2015 12:25:14
Event ID: 1001
Task Category: None
Level: Information
Keywords: Classic
User: N/A
Computer: dcm.group.legion.ru
Description:
Fault bucket , type 0
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: bareos-fd.exe
P2: 1.0.0.0
P3: 553e7be1
P4: KERNELBASE.dll
P5: 6.1.7601.18015
P6: 50b8479b
P7: c0000005
P8: 000000000001b242
P9:
P10:

Attached files:

These files may be available here:
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_bareos-fd.exe_599dde277f9e41ff1bfe3cf442d9e37496b359_0ebe0383

Analysis symbol:
Rechecking for solution: 0
Report Id: cde19928-ef1a-11e4-a3f3-e21ed523f39c
Report Status: 0
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Windows Error Reporting" />
    <EventID Qualifiers="0">1001</EventID>
    <Level>4</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2015-04-30T09:25:14.000000000Z" />
    <EventRecordID>8925</EventRecordID>
    <Channel>Application</Channel>
    <Computer>dcm.group.legion.ru</Computer>
    <Security />
  </System>
  <EventData>
    <Data>
    </Data>
    <Data>0</Data>
    <Data>APPCRASH</Data>
    <Data>Not available</Data>
    <Data>0</Data>
    <Data>bareos-fd.exe</Data>
    <Data>1.0.0.0</Data>
    <Data>553e7be1</Data>
    <Data>KERNELBASE.dll</Data>
    <Data>6.1.7601.18015</Data>
    <Data>50b8479b</Data>
    <Data>c0000005</Data>
    <Data>000000000001b242</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_bareos-fd.exe_599dde277f9e41ff1bfe3cf442d9e37496b359_0ebe0383</Data>
    <Data>
    </Data>
    <Data>0</Data>
    <Data>cde19928-ef1a-11e4-a3f3-e21ed523f39c</Data>
    <Data>0</Data>
  </EventData>
</Event>

Log Name: Application
Source: Windows Error Reporting
Date: 30.04.2015 12:25:14
Event ID: 1001
Task Category: None
Level: Information
Keywords: Classic
User: N/A
Computer: dcm.group.legion.ru
Description:
Fault bucket , type 0
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: bareos-fd.exe
P2: 1.0.0.0
P3: 553e7be1
P4: KERNELBASE.dll
P5: 6.1.7601.18015
P6: 50b8479b
P7: c0000005
P8: 000000000001b242
P9:
P10:

Attached files:

These files may be available here:
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_bareos-fd.exe_599dde277f9e41ff1bfe3cf442d9e37496b359_0ebe0383

Analysis symbol:
Rechecking for solution: 0
Report Id: cde19928-ef1a-11e4-a3f3-e21ed523f39c
Report Status: 4
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Windows Error Reporting" />
    <EventID Qualifiers="0">1001</EventID>
    <Level>4</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2015-04-30T09:25:14.000000000Z" />
    <EventRecordID>8924</EventRecordID>
    <Channel>Application</Channel>
    <Computer>dcm.group.legion.ru</Computer>
    <Security />
  </System>
  <EventData>
    <Data>
    </Data>
    <Data>0</Data>
    <Data>APPCRASH</Data>
    <Data>Not available</Data>
    <Data>0</Data>
    <Data>bareos-fd.exe</Data>
    <Data>1.0.0.0</Data>
    <Data>553e7be1</Data>
    <Data>KERNELBASE.dll</Data>
    <Data>6.1.7601.18015</Data>
    <Data>50b8479b</Data>
    <Data>c0000005</Data>
    <Data>000000000001b242</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_bareos-fd.exe_599dde277f9e41ff1bfe3cf442d9e37496b359_0ebe0383</Data>
    <Data>
    </Data>
    <Data>0</Data>
    <Data>cde19928-ef1a-11e4-a3f3-e21ed523f39c</Data>
    <Data>4</Data>
  </EventData>
</Event>

Log Name: Application
Source: Application Error
Date: 30.04.2015 12:25:14
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: dcm.group.legion.ru
Description:
Faulting application name: bareos-fd.exe, version: 1.0.0.0, time stamp: 0x553e7be1
Faulting module name: KERNELBASE.dll, version: 6.1.7601.18015, time stamp: 0x50b8479b
Exception code: 0xc0000005
Fault offset: 0x000000000001b242
Faulting process id: 0xba4
Faulting application start time: 0x01d08327504c59a6
Faulting application path: C:\Program Files\Bareos\bareos-fd.exe
Faulting module path: C:\Windows\system32\KERNELBASE.dll
Report Id: cde19928-ef1a-11e4-a3f3-e21ed523f39c
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2015-04-30T09:25:14.000000000Z" />
    <EventRecordID>8923</EventRecordID>
    <Channel>Application</Channel>
    <Computer>dcm.group.legion.ru</Computer>
    <Security />
  </System>
  <EventData>
    <Data>bareos-fd.exe</Data>
    <Data>1.0.0.0</Data>
    <Data>553e7be1</Data>
    <Data>KERNELBASE.dll</Data>
    <Data>6.1.7601.18015</Data>
    <Data>50b8479b</Data>
    <Data>c0000005</Data>
    <Data>000000000001b242</Data>
    <Data>ba4</Data>
    <Data>01d08327504c59a6</Data>
    <Data>C:\Program Files\Bareos\bareos-fd.exe</Data>
    <Data>C:\Windows\system32\KERNELBASE.dll</Data>
    <Data>cde19928-ef1a-11e4-a3f3-e21ed523f39c</Data>
  </EventData>
</Event>
SergeyMorozov

SergeyMorozov

2015-04-30 11:38

reporter  

Report.wer (8,182 bytes)
pstorz

pstorz

2015-05-04 16:50

administrator   ~0001707

I tried to reproduce the error windows 2012 r2 server with today's nightly build and with Bareos 14.2.2.postvista-16.1 and was not able to reproduce:

- Backup from compressed volume and restore to both compressed and uncompressed volume works without problems.

- Tried first single file and then complete bareos source checkout.
I will try to reproduce on 2008r2 also.
SergeyMorozov

SergeyMorozov

2015-05-05 09:34

reporter   ~0001709

I tried the latest nightly (winbareos-15.2.0.gitblit.1430470729.c02e573-postvista-64-bit-r23.1.exe) with no success, bareos-fd still crashing.
Maybe it is important, on the server side (Linux, bareos-sd and bareos-dir) I using version 14.2.4.
pstorz

pstorz

2015-05-05 10:11

administrator   ~0001710

On Windows 2008 it crashes also here in my environment. So it hast to do with the windows version.

Thanks for the feedback.
mvwieringen

mvwieringen

2015-05-07 19:49

developer   ~0001712

Fix committed to bareos master branch with changesetid 5219.
mvwieringen

mvwieringen

2015-05-29 18:06

developer   ~0001758

Fix committed to bareos bareos-14.2 branch with changesetid 5342.

Related Changesets

bareos: master 49f2f397

2015-05-05 14:53:12

pstorz


Committer: mvwieringen

Ported: N/A

Details Diff
Fix restore of compressed files

The compressed file restoration failed before on Windows 2008.

We now use the variable types from the microsoft documentation,
also now have a bytesreturned variable which is mandatory
if lpOverlapped is NULL according to the documentation.

See documentation of FSCTL_SET_COMPRESSION control code at Microsoft:
https://msdn.microsoft.com/en-us/library/windows/desktop/aa364592%28v=vs.85%29.aspx

Fixes 0000463: Crash when restore compressed files
Affected Issues
0000463
mod - src/findlib/attribs.c Diff File

bareos: bareos-14.2 4866847d

2015-05-05 14:53:12

pstorz


Committer: mvwieringen

Ported: N/A

Details Diff
Fix restore of compressed files

The compressed file restoration failed before on Windows 2008.

We now use the variable types from the microsoft documentation,
also now have a bytesreturned variable which is mandatory
if lpOverlapped is NULL according to the documentation.

See documentation of FSCTL_SET_COMPRESSION control code at Microsoft:
https://msdn.microsoft.com/en-us/library/windows/desktop/aa364592%28v=vs.85%29.aspx

Fixes 0000463: Crash when restore compressed files
Affected Issues
0000463
mod - src/findlib/attribs.c Diff File

Issue History

Date Modified Username Field Change
2015-04-30 10:24 SergeyMorozov New Issue
2015-04-30 10:24 SergeyMorozov File Added: bareos-fd.trace
2015-04-30 10:27 SergeyMorozov Note Added: 0001702
2015-04-30 11:37 SergeyMorozov Note Added: 0001704
2015-04-30 11:38 SergeyMorozov File Added: Report.wer
2015-05-04 16:46 pstorz Assigned To => pstorz
2015-05-04 16:46 pstorz Status new => assigned
2015-05-04 16:50 pstorz Note Added: 0001707
2015-05-05 09:34 SergeyMorozov Note Added: 0001709
2015-05-05 10:10 pstorz Priority urgent => normal
2015-05-05 10:11 pstorz Note Added: 0001710
2015-05-07 19:49 mvwieringen Changeset attached => bareos master 49f2f397
2015-05-07 19:49 mvwieringen Note Added: 0001712
2015-05-07 19:49 mvwieringen Status assigned => resolved
2015-05-07 19:49 mvwieringen Resolution open => fixed
2015-05-27 12:39 joergs Relationship added child of 0000447
2015-05-27 12:40 joergs bareos-master: impact => yes
2015-05-27 12:40 joergs bareos-master: action => fixed
2015-05-27 12:40 joergs bareos-14.2: impact => yes
2015-05-27 12:40 joergs bareos-14.2: action => will care
2015-05-27 14:09 pstorz bareos-13.2: action => none
2015-05-27 14:10 pstorz bareos-12.4: action => none
2015-05-27 14:18 pstorz Assigned To pstorz =>
2015-05-29 18:06 mvwieringen Changeset attached => bareos bareos-14.2 4866847d
2015-05-29 18:06 mvwieringen Note Added: 0001758
2015-06-01 16:21 joergs bareos-14.2: action will care => fixed
2015-06-01 16:21 joergs Status resolved => closed