View Issue Details

IDProjectCategoryView StatusLast Update
0000437bareos-core[All Projects] storage daemonpublic2015-03-25 19:19
ReporterjoergsAssigned To 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSanyOS Version3
Product Version14.4.0 
Target VersionFixed in Version 
Summary0000437: when storing on multiple volumes via File backend, a data block of 64k gets lost
DescriptionWhen backup jobs on File backend uses multiple volumes, data (64k block) gets lost.

This is recognized on restore:

12-Mar 18:47 sdtest-fd JobId 32: Error: attribs.c:419 File size of restored file /tmp/bareos-restores/tmp/test/test1500 not correct. Original 1536000, restored 1470464.

This does only happen with File backend. With the Tape (Autochanger) backend (mhvtl), this problem did not occur.
Steps To ReproduceDo a normal Bareos package based installation (I've used SLES11, but the problem have been initially reported on Debian 7).

In the Full Pool set

Maximum Volume Bytes = 1M

set the FileSet to a directory

/tmp/test/

and create a file of the size 1,5M in it.

Run full backup of the file (which will use two volumes) and run a restore job.

The restored file is 65536 Bytes (64kb) smaller than the original one.
Additional InformationThe file size of the volumes is smaller than the file it contains.
Therefore the problem already happens when writing to the volumes.

bextract also reports the error.

Originally, this have been discussed on

http://thread.gmane.org/gmane.comp.sysutils.backup.bareos.user/1255
TagsNo tags attached.
bareos-master: impactyes
bareos-master: actionfixed
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impactyes
bareos-14.2: actionfixed
bareos-13.2: impactno
bareos-13.2: action
bareos-12.4: impactno
bareos-12.4: action

Relationships

child of 0000420 closed Release bareos-14.2.4 

Activities

tigerfoot

tigerfoot

2015-03-12 21:14

developer   ~0001310

To be tested on 13.2 and 14.2 (I've done several time restore without seeing this specific issue)
joergs

joergs

2015-03-12 23:57

administrator   ~0001311

problem do not exist on 13.2.2, but it exists on 14.2.2 and 14.2.3.
joergs

joergs

2015-03-13 17:10

administrator   ~0001312

It seems, the problem has been introduced by

commit f964f4cb223cde3ffd57fe902bf2b1a77bfef00f

Implement auto inflation/deflation in the storage daemon.

At least, my automatic test (using git bisect) tells me this.
mvwieringen

mvwieringen

2015-03-13 17:56

developer   ~0001313

Ok thanks for that. I have a hunch what goes wrong. Seems to align with
the fact it only happens with auto labeling.
stephand

stephand

2015-03-15 16:34

developer   ~0001316

yes, I was only able to reproduce it when new auto labeled volume files were created. Recycled volume files work fine, no restore issue then, but this may only apply for recycled volume files that have been created and auto labeled before upgrade to 14.2
mvwieringen

mvwieringen

2015-03-17 15:53

developer   ~0001321

Fix committed to bareos master branch with changesetid 3558.
mvwieringen

mvwieringen

2015-03-17 17:34

developer   ~0001323

Still waiting for backporting to 14.2.
mvwieringen

mvwieringen

2015-03-25 16:51

developer   ~0001434

Fix committed to bareos2015 bareos-14.2 branch with changesetid 4445.
joergs

joergs

2015-03-25 19:19

administrator   ~0001585

Due to the reimport of the Github repository to bugs.bareos.org, the status of some tickets have been changed. These tickets will be closed again.
Sorry for the noise.

Related Changesets

bareos: master 43bf8601

2015-03-13 18:32:58

mvwieringen

Ported: N/A

Details Diff
Don't trash dcr->rec while doing autolabeling.

Fixes 0000437: When storing on multiple volumes via File backend, a data
block of 64k gets lost
Affected Issues
0000437
mod - src/stored/label.c Diff File

bareos2015: bareos-14.2 263240ea

2015-03-13 18:32:58

mvwieringen

Ported: N/A

Details Diff
Don't trash dcr->rec while doing autolabeling.

Fixes 0000437: When storing on multiple volumes via File backend, a data
block of 64k gets lost
Affected Issues
0000437
mod - src/stored/label.c Diff File

Issue History

Date Modified Username Field Change
2015-03-12 19:56 joergs New Issue
2015-03-12 21:14 tigerfoot Note Added: 0001310
2015-03-12 23:57 joergs bareos-master: impact => yes
2015-03-12 23:57 joergs bareos-master: action => will care
2015-03-12 23:57 joergs bareos-14.2: impact => yes
2015-03-12 23:57 joergs bareos-14.2: action => will care
2015-03-12 23:57 joergs bareos-13.2: impact => no
2015-03-12 23:57 joergs bareos-12.4: impact => no
2015-03-12 23:57 joergs Note Added: 0001311
2015-03-13 17:10 joergs Note Added: 0001312
2015-03-13 17:56 mvwieringen Note Added: 0001313
2015-03-15 16:34 stephand Note Added: 0001316
2015-03-17 15:53 mvwieringen Changeset attached => bareos master 43bf8601
2015-03-17 15:53 mvwieringen Note Added: 0001321
2015-03-17 15:53 mvwieringen Status new => resolved
2015-03-17 15:53 mvwieringen Resolution open => fixed
2015-03-17 17:32 mvwieringen Status resolved => feedback
2015-03-17 17:32 mvwieringen Resolution fixed => reopened
2015-03-17 17:34 mvwieringen Note Added: 0001323
2015-03-22 10:27 joergs Relationship added child of 0000420
2015-03-22 10:28 joergs bareos-master: action will care => fixed
2015-03-25 12:40 joergs bareos-14.2: action will care => fixed
2015-03-25 12:40 joergs Status feedback => resolved
2015-03-25 12:40 joergs Resolution reopened => fixed
2015-03-25 12:40 joergs Assigned To => joergs
2015-03-25 12:40 joergs Assigned To joergs =>
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-14.2 263240ea
2015-03-25 16:51 mvwieringen Note Added: 0001434
2015-03-25 19:19 joergs Note Added: 0001585
2015-03-25 19:19 joergs Status resolved => closed