View Issue Details

IDProjectCategoryView StatusLast Update
0000425bareos-core[All Projects] file daemonpublic2015-03-25 19:19
ReportermvwieringenAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSanyOS Version3
Product Version14.2.3 
Target Version14.2.4Fixed in Version14.2.4 
Summary0000425: Mssqlvdi plugin always restores to file
DescriptionEven when you specify a where of "/" which should indicate restore the
database using the VDI interface the plugin will write it to a file.
Additional InformationSeems the where gets truncated to an empty string when it only contains a "/"
in the filed.
TagsNo tags attached.
bareos-master: impactyes
bareos-master: actionfixed
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impactyes
bareos-14.2: actionwill care
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Relationships

child of 0000420 closed Release bareos-14.2.4 

Activities

mvwieringen

mvwieringen

2015-03-25 16:51

developer   ~0001435

Fix committed to bareos2015 bareos-14.2 branch with changesetid 4447.
joergs

joergs

2015-03-25 19:19

administrator   ~0001586

Due to the reimport of the Github repository to bugs.bareos.org, the status of some tickets have been changed. These tickets will be closed again.
Sorry for the noise.

Related Changesets

bareos: master c0b2f27c

2015-02-17 10:40:01

Marco van Wieringen

Ported: N/A

Details Diff
Fix mssqlvdi plugin to interpret where argument correctly.

Fixes 0000425: Mssqlvdi always restores to file.
Affected Issues
0000425
mod - src/win32/plugins/filed/mssqlvdi-fd.c Diff File

bareos2015: bareos-14.2 baa404b7

2015-02-17 10:40:01

mvwieringen

Ported: N/A

Details Diff
Fix mssqlvdi plugin to interpret where argument correctly.

Fixes 0000425: Mssqlvdi always restores to file.
Affected Issues
0000425
mod - src/win32/plugins/filed/mssqlvdi-fd.c Diff File

Issue History

Date Modified Username Field Change
2015-02-17 11:00 mvwieringen New Issue
2015-02-17 11:02 mvwieringen bareos-master: impact => yes
2015-02-17 11:02 mvwieringen bareos-master: action => will care
2015-02-17 11:02 mvwieringen bareos-14.2: impact => yes
2015-02-17 11:02 mvwieringen bareos-14.2: action => will care
2015-03-22 10:36 joergs Changeset attached => bareos master c0b2f27c
2015-03-22 10:38 joergs Relationship added child of 0000420
2015-03-23 15:12 joergs bareos-master: action will care => fixed
2015-03-23 15:12 joergs Status new => resolved
2015-03-23 15:12 joergs Resolution open => fixed
2015-03-23 15:12 joergs Fixed in Version => 14.2.4
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-14.2 baa404b7
2015-03-25 16:51 mvwieringen Note Added: 0001435
2015-03-25 19:19 joergs Note Added: 0001586
2015-03-25 19:19 joergs Status resolved => closed