View Issue Details

IDProjectCategoryView StatusLast Update
0000422bareos-core[All Projects] file daemonpublic2015-11-06 17:26
ReporterbrunoAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSDebianOS Version7
Product Version14.2.2 
Fixed in Version 
Summary0000422: bpipe plugin: Error closing stream for pseudo file file: 268435664
DescriptionTrying to backup sth using bpipe plugin on a default installation fails with fatal error. This happens on both my installations.
Steps To ReproduceSetup Debian 7 + Bareos + MySQL.
Define following fileset:
FileSet {
  Name = "bareos MySQL Backup"
  Include {
    Options {
      Signature = MD5
    }
    Plugin = "bpipe:file=/MYSQL/dump.sql:reader=mysqldump --user=root --password=PASSWORD --opt --all-databases:writer="
  }
}
Enable plugins on the filedaemon.
Run a job with that fileset.
Additional InformationLog records for job 21
2015-02-03 13:25:42
bareos-dir
No prior Full backup Job record found.


No prior or suitable Full backup found in catalog. Doing FULL backup.
2015-02-03 13:25:44
bareos-dir
Start Backup JobId 21, Job=Backup_bareos_MySQL.2015-02-03_13.25.42_23


Using Device "NL01_BAREOS_B2D" to write.
2015-02-03 13:25:44
bareos-sd
Volume "Full-0005" previously written, moving to end of data.


Ready to append to end of Volume "Full-0005" size=9209616998
2015-02-03 13:25:44
bareos-fd
Fatal error: bpipe plugin: Error closing stream for pseudo file file: 268435664
2015-02-03 13:25:44
bareos-sd
Elapsed time=00:00:01, Transfer rate=197 Bytes/second
2015-02-03 13:25:44
bareos-dir
Error: Bareos bareos-dir 14.2.2 (12Dec14):
  Build OS: x86_64-pc-linux-gnu debian Debian GNU/Linux 7.0 (wheezy)
  JobId: 21
  Job: Backup_bareos_MySQL.2015-02-03_13.25.42_23
  Backup Level: Full (upgraded from Incremental)
  Client: "bareos-fd" 14.2.2 (12Dec14) x86_64-pc-linux-gnu,debian,Debian GNU/Linux 7.0 (wheezy)
  FileSet: "bareos MySQL Backup" 2015-02-03 13:25:42
  Pool: "Full" (From Job FullPool override)
  Catalog: "MyCatalog" (From Client resource)
  Storage: "nl-stgt-01" (From Job resource)
  Scheduled time: 03-Feb-2015 13:25:39
  Start time: 03-Feb-2015 13:25:44
  End time: 03-Feb-2015 13:25:44
  Elapsed time: 0 secs
  Priority: 10
  FD Files Written: 1
  SD Files Written: 0
  FD Bytes Written: 0 (0 B)
  SD Bytes Written: 81 (81 B)
  Rate: 0.0 KB/s
  Software Compression: None
  VSS: no
  Encryption: no
  Accurate: no
  Volume name(s): Full-0005
  Volume Session Id: 20
  Volume Session Time: 1422645177
  Last Volume Bytes: 9,209,616,998 (9.209 GB)
  Non-fatal FD errors: 1
  SD Errors: 0
  FD termination status: Error
  SD termination status: Running
  Termination: *** Backup Error ***
TagsNo tags attached.
bareos-master: impactyes
bareos-master: actionfixed
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impactyes
bareos-14.2: actionfixed
bareos-13.2: impact
bareos-13.2: actionnone
bareos-12.4: impact
bareos-12.4: actionnone

Relationships

related to 0000511 closed bpipe plugin: Error closing stream for pseudo file 
child of 0000420 closed Release bareos-14.2.4 

Activities

mvwieringen

mvwieringen

2015-02-03 15:45

developer   ~0001254

Seems I used the wrong variable in the code e.g. the argument instead of
the argument value so its executing the argument instead of the argument_value.

The quickest workaround is to change the bpipe definition to the "old" format

Only because of the = in the cmdline you should store the command in a
shell script.

e.g.

bpipe:/MYSQL/dump.sql:.../read_script:.../write_script:
bruno

bruno

2015-02-03 15:53

reporter   ~0001255

Indeed, this works!
pstorz

pstorz

2015-02-10 12:53

administrator   ~0001273

Fix committed to bareos master branch with changesetid 2704.
mvwieringen

mvwieringen

2015-03-25 16:51

developer   ~0001437

Fix committed to bareos2015 bareos-14.2 branch with changesetid 4449.
joergs

joergs

2015-03-25 19:19

administrator   ~0001588

Due to the reimport of the Github repository to bugs.bareos.org, the status of some tickets have been changed. These tickets will be closed again.
Sorry for the noise.

Related Changesets

bareos: master 57ce99f2

2015-02-03 15:45:41

mvwieringen


Committer: pstorz

Ported: N/A

Details Diff
Use argument_value not argument in bpipe config parser.

Fixes 0000422: bpipe plugin: Error closing stream for pseudo file file:
Affected Issues
0000422
mod - src/plugins/filed/bpipe-fd.c Diff File

bareos2015: bareos-14.2 c4baf251

2015-02-03 15:45:41

mvwieringen

Ported: N/A

Details Diff
Use argument_value not argument in bpipe config parser.

Fixes 0000422: bpipe plugin: Error closing stream for pseudo file file:
Affected Issues
0000422
mod - src/plugins/filed/bpipe-fd.c Diff File

Issue History

Date Modified Username Field Change
2015-02-03 13:44 bruno New Issue
2015-02-03 15:40 mvwieringen Assigned To => mvwieringen
2015-02-03 15:40 mvwieringen Status new => assigned
2015-02-03 15:45 mvwieringen Note Added: 0001254
2015-02-03 15:48 mvwieringen bareos-14.2: impact => yes
2015-02-03 15:48 mvwieringen bareos-14.2: action => will care
2015-02-03 15:53 bruno Note Added: 0001255
2015-02-10 12:53 pstorz Changeset attached => bareos master 57ce99f2
2015-02-10 12:53 pstorz Note Added: 0001273
2015-02-10 12:53 pstorz Status assigned => resolved
2015-02-10 12:53 pstorz Resolution open => fixed
2015-02-14 17:30 mvwieringen adm Assigned To mvwieringen =>
2015-03-22 10:42 joergs Relationship added child of 0000420
2015-03-22 10:43 joergs bareos-master: impact => yes
2015-03-22 10:43 joergs bareos-master: action => fixed
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-14.2 c4baf251
2015-03-25 16:51 mvwieringen Note Added: 0001437
2015-03-25 19:19 joergs Note Added: 0001588
2015-03-25 19:19 joergs Status resolved => closed
2015-06-12 14:26 joergs bareos-14.2: action will care => fixed
2015-06-12 14:26 joergs bareos-13.2: action => none
2015-06-12 14:26 joergs bareos-12.4: action => none
2015-11-06 17:26 joergs Relationship added related to 0000511