View Issue Details

IDProjectCategoryView StatusLast Update
0000410bareos-core[All Projects] Generalpublic2015-03-25 19:19
Reportersimone.rossiAssigned To 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSCentOSOS Version6
Product Version14.2.2 
Fixed in Version 
Summary0000410: 'START BACKUP 'LEVEL' not provided, defaulting to LEVEL 0' after launching differential backup
DescriptionAfter performing a full backup (done with success), I have tried to execute a differential backup, but the director reported the following message:

LOG_MESSAGE: 'START BACKUP 'LEVEL' not provided, defaulting to LEVEL 0'

how can I fix this problem?
Additional Information####### BAREOS-DIR.CONF #########



Client {
  Name = netapp01
  Address = 10.54.248.22
  Port = 10000
  Catalog = MyCatalog
  File Retention = 90 days
  Job Retention = 6 months
  Protocol = NDMPv4
  Auth Type = clear # Clear == Clear Text, MD5 == Challenge protocol
  Username = "XXX"
  Password = "XXX"
}

Job {
  Name = Backup-Full-netapp01
  Type = Backup
  Level = Full
  Client = netapp01
  FileSet = netapp01-Fileset
  Schedule = FullSaturday
  Storage = NDMPFile-Netapp01
  Pool = netapp01-Pool
  Protocol = NDMP
  Messages = Standard
  Backup Format = smtape
}

Job {
  Name = Backup-Diff-netapp01
  Type = Backup
  Level = Differential
  Client = netapp01
  FileSet = netapp01-Fileset
  Schedule = WeeklyDifferential
  Storage = NDMPFile-Netapp01
  Pool = netapp01-Pool
  Protocol = NDMP
  Messages = Standard
  Backup Format = smtape
}

#Job {
# Name = "Restore_Backup_netapp01"
# Type = Restore
# Client = netapp01
# FileSet = "netapp01-Fileset"
# Storage = NDMPFile-Netapp01
# Pool = netapp01-Pool
# Messages = Standard
# Where = /restore
#}

Schedule {
  Name = "FullSaturday"
  Run = Full 2nd sat at 00:00
  Run = Full 4th sat at 00:00
}

Schedule {
  Name = "WeeklyDifferential"
  Run = Differential mon-fri at 2:00
}

Pool {
  Name = netapp01-Pool
  Pool Type = Backup
  Volume Retention = 14 days
  Recycle = yes
  AutoPrune = yes
  LabelFormat = "netapp01-Backup-"
  Maximum Volume Jobs = 1
  Maximum Volume Bytes = 200G
}
### NetApp01 Paired Storage
Storage {
  Name = Storage-Backup
  Password = "XXXXX"
  Address = 10.54.248.205
  SDPort = 9103
  Device = Storage-Backup
  Media Type = File
  Maximum Concurrent Jobs = 20
}

Storage {
  Name = NDMPFile-Netapp01
  Address = 10.54.248.205 # N.B. Use a fully qualified name here
  Port = 10001
  Protocol = NDMPv4
  Auth Type = Clear
  Username = "XXX"
  Password = "XXX"
  Device = NDMPFile-Netapp01
  Media Type = File
  PairedStorage = Storage-Backup
  Maximum Concurrent Jobs = 20
}
Fileset {
  Name = netapp01-Fileset
  Include {
   Options {
   }
     File = /vol/vol1
  }
  Exclude {
        File = /vol/vol1/.snapshot
        }
}


####### BAREOS-SD.CONF #######

Storage {
  Name = bareos-sd
  Maximum Concurrent Jobs = 20
  NDMP Enable = yes
  NDMP Port = 10001
  SD Port = 9103
}

Director {
  Name = bareos-dir
  Password = "XXXXX"
}
Director {
  Name = bareos-mon
  Password = "XXXXX"
  Monitor = yes
}


Device {
  Name = Storage-Backup
  Media Type = File
  Archive Device = /backup/fasstr
  LabelMedia = yes;
  Random Access = Yes;
  AutomaticMount = yes;
  RemovableMedia = no;
  AlwaysOpen = yes;
  Maximum Concurrent Jobs = 20
  
  
  

}

Ndmp {
  Name = NDMPFile-Netapp01
  Username = "XXX"
  Password = "XXX"
  AuthType = Clear
  Loglevel = 3
}
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Relationships

child of 0000420 closed Release bareos-14.2.4 

Activities

mvwieringen

mvwieringen

2015-01-27 20:58

developer   ~0001227

Last edited: 2015-01-30 11:02

View 2 revisions

We have never tested incrementals and differentials using the SM_TAPE protocol
so for now that is disabled. I have to look what I did for the Oracle ZFS
appliance as I seem to rembember I got it working there and the DUMP protocol
uses it.

It could be as simple as allowing levels for SM_TAPE which is controlled by
the ndmp_backup_format_option[] option table in the NDMP DMA.

In its current form NDMP needs to be tested in each environment as NDMP support
only means data encapsulation as each vendor does NDMP differently. We don't have
many paying customers for NDMP so things are somewhat community driven.

mvwieringen

mvwieringen

2015-01-30 11:06

developer  

0001-Enable-dump-levels-for-SM_TAPE-NDMP-backups.patch (877 bytes)
From 015a325334c64acd3b33237ec84a2e8edf3541f9 Mon Sep 17 00:00:00 2001
From: Marco van Wieringen <marco.van.wieringen@bareos.com>
Date: Fri, 30 Jan 2015 11:05:48 +0100
Subject: [PATCH] Enable dump levels for SM_TAPE NDMP backups.

---
 src/dird/ndmp_dma.c |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/src/dird/ndmp_dma.c b/src/dird/ndmp_dma.c
index d65256e..f97b4ef 100644
--- a/src/dird/ndmp_dma.c
+++ b/src/dird/ndmp_dma.c
@@ -182,7 +182,7 @@ struct ndmp_backup_format_option {
 static ndmp_backup_format_option ndmp_backup_format_options[] = {
    { (char *)"dump", true, true, true, true },
    { (char *)"tar", true, false, true, true },
-   { (char *)"smtape", false, false, false, true },
+   { (char *)"smtape", false, true, false, true },
    { (char *)"zfs", false, true, false, true },
    { NULL, false, false, false }
 };
-- 
1.7.3.2

mvwieringen

mvwieringen

2015-01-30 11:07

developer   ~0001238

You could try the attached patch which enables the use of levels for SM_TAPE.
mvwieringen

mvwieringen

2015-02-10 12:53

developer   ~0001270

Fix committed to bareos master branch with changesetid 2701.
mvwieringen

mvwieringen

2015-03-25 16:51

developer   ~0001436

Fix committed to bareos2015 bareos-14.2 branch with changesetid 4448.
joergs

joergs

2015-03-25 19:19

administrator   ~0001590

Due to the reimport of the Github repository to bugs.bareos.org, the status of some tickets have been changed. These tickets will be closed again.
Sorry for the noise.

Related Changesets

bareos: master 462a02c5

2015-01-27 20:59:11

mvwieringen

Ported: N/A

Details Diff
Enable NDMP level support for SM_TAPE backups.

Fixes 0000410: START BACKUP 'LEVEL' not provided, defaulting to LEVEL 0'
after launching differential backup
Affected Issues
0000410
mod - src/dird/ndmp_dma.c Diff File
mod - src/stored/ndmp_tape.c Diff File

bareos2015: bareos-14.2 db182c69

2015-01-27 20:59:11

mvwieringen

Ported: N/A

Details Diff
Enable NDMP level support for SM_TAPE backups.

Fixes 0000410: START BACKUP 'LEVEL' not provided, defaulting to LEVEL 0'
after launching differential backup
Affected Issues
0000410
mod - src/dird/ndmp_dma.c Diff File
mod - src/stored/ndmp_tape.c Diff File

Issue History

Date Modified Username Field Change
2015-01-27 18:16 simone.rossi New Issue
2015-01-27 20:58 mvwieringen Note Added: 0001227
2015-01-27 20:58 mvwieringen Assigned To => mvwieringen
2015-01-27 20:58 mvwieringen Severity minor => feature
2015-01-27 20:58 mvwieringen Status new => assigned
2015-01-30 11:02 mvwieringen Note Edited: 0001227 View Revisions
2015-01-30 11:06 mvwieringen File Added: 0001-Enable-dump-levels-for-SM_TAPE-NDMP-backups.patch
2015-01-30 11:07 mvwieringen Note Added: 0001238
2015-01-30 11:07 mvwieringen Assigned To mvwieringen =>
2015-01-30 11:07 mvwieringen Status assigned => feedback
2015-02-10 12:53 mvwieringen Changeset attached => bareos master 462a02c5
2015-02-10 12:53 mvwieringen Note Added: 0001270
2015-02-10 12:53 mvwieringen Status feedback => resolved
2015-02-10 12:53 mvwieringen Resolution open => fixed
2015-03-23 14:18 joergs Relationship added child of 0000420
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-14.2 db182c69
2015-03-25 16:51 mvwieringen Note Added: 0001436
2015-03-25 19:19 joergs Note Added: 0001590
2015-03-25 19:19 joergs Status resolved => closed