View Issue Details

IDProjectCategoryView StatusLast Update
0000383bareos-core[All Projects] directorpublic2016-07-08 14:34
ReporterirekpiasAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSCentOSOS Version5.11
Product Version14.2.2 
Fixed in Version14.2.2 
Summary0000383: dir command in bconsole crash bareos-dir
DescriptionHi.

I noticed, that dir command in bconsole crash bareos-dir. But it crash, when i use dir, not ls. I think - it has to do with national charset coding and ... putty ?

Screen shot added and bactrace too.
Steps To ReproduceAlways, when i use dir command in bconsole in this particular restore job.
Additional InformationBareos - the latest for Centos 5
TagsNo tags attached.
bareos-master: impactyes
bareos-master: actionfixed
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impactno
bareos-15.2: actionnone
bareos-14.2: impactyes
bareos-14.2: actionfixed
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Relationships

duplicate of 0000354 closedpstorz bconsole restore / dir on (at least one) directory crashes bareos-dir 
has duplicate 0000398 closed bconsole & bareos-dir segfault on restore dir 

Activities

irekpias

irekpias

2014-12-24 09:41

reporter  

dir-crash-bareos-dir.png (76,463 bytes)
dir-crash-bareos-dir.png (76,463 bytes)
irekpias

irekpias

2014-12-24 09:43

reporter  

posejdon-dir.5003.bactrace (4,908 bytes)
irekpias

irekpias

2014-12-24 09:46

reporter   ~0001154

Created /var/lib/bareos/bareos-dir.core.5003 for doing postmortem debugging
[New Thread 5018]
[New Thread 5218]
[New Thread 5219]
[New Thread 5220]
[New Thread 5222]
[New Thread 5398]
[New Thread 7060]
[New Thread 16654]
[New Thread 5003]
[Thread debugging using libthread_db enabled]

warning: no loadable sections found in added symbol-file system-supplied DSO at 0x7fff2b7fd000
Core was generated by `/usr/sbin/bareos-dir -g bareos -c /etc/bareos/bareos-dir.conf'.
#0 0x000000346580e351 in nanosleep () from /lib64/libpthread.so.0
$1 = 1702063984
$2 = 63612328
$3 = 63612392
/usr/lib/bareos/scripts/btraceback.gdb:4: Error in sourced command file:
No symbol "catalog_db" in current context.
mvwieringen

mvwieringen

2014-12-24 10:59

developer   ~0001155

We need a proper debugger stacktrace to be able to do anything with this.

Please first install bareos-debuginfo and then attach the *traceback* file(s)
that are generated. The bactrace are next to useless for anything else then
finding multithread lockups.
irekpias

irekpias

2014-12-24 11:29

reporter   ~0001156

I installed bareos-debug, where is bareos-debuginfo ?
irekpias

irekpias

2014-12-24 11:31

reporter  

bareos.1694.traceback (6,638 bytes)
mvwieringen

mvwieringen

2014-12-24 12:51

developer   ~0001157

The debuginfo rpm only contains the debugging symbols which get automatically
loaded by gdb when the dir crashes. As you can see in your first note then
it was not installed as it didn't find any symbols.

I would expect on the next crash in the working directory you will find
some traceback files.

For more information on the debugging of a crash there is a full section
in the documentation.
irekpias

irekpias

2014-12-24 12:55

reporter   ~0001158

I attached second file: bareos.1694.traceback [^] (6,638 bytes) 2014-12-24 11:31 in this bug track system.

This isn't enough ?
mvwieringen

mvwieringen

2014-12-24 13:21

developer   ~0001159

Yes that is enough it would help if you next time say what you did I don't
scan the whole history for what changed in the bug report.

Next to that your question seems to indicate you were looking for something.
mvwieringen

mvwieringen

2014-12-24 14:13

developer   ~0001160

Fix committed to bareos master branch with changesetid 2595.
mvwieringen

mvwieringen

2014-12-24 14:21

developer   ~0001163

Fix committed to bareos bareos-14.2 branch with changesetid 2601.
mvwieringen

mvwieringen

2015-03-25 16:51

developer   ~0001450

Fix committed to bareos2015 bareos-14.2 branch with changesetid 4488.
joergs

joergs

2015-03-25 19:19

administrator   ~0001646

Due to the reimport of the Github repository to bugs.bareos.org, the status of some tickets have been changed. These tickets will be closed again.
Sorry for the noise.
mvwieringen

mvwieringen

2016-01-07 19:44

developer   ~0002073

Fix committed to bareos master branch with changesetid 6051.
mvwieringen

mvwieringen

2016-07-08 14:34

developer   ~0002308

Fix committed to bareos bareos-14.2 branch with changesetid 6412.

Related Changesets

bareos: master ae9681c8

2014-12-24 12:21:55

mvwieringen

Ported: N/A

Details Diff
Fix director crash on dir command with long filenames

Fixes 0000383: dir command in bconsole crash bareos-dir
Affected Issues
0000383
mod - src/dird/ua_tree.c Diff File

bareos: bareos-14.2 8befea7d

2014-12-24 12:21:55

mvwieringen

Ported: N/A

Details Diff
Fix director crash on dir command with long filenames

Fixes 0000383: dir command in bconsole crash bareos-dir
Affected Issues
0000383
mod - src/dird/ua_tree.c Diff File

bareos2015: bareos-14.2 09ee5e3b

2014-12-24 13:21:55

mvwieringen

Ported: N/A

Details Diff
Fix director crash on dir command with long filenames

Fixes 0000383: dir command in bconsole crash bareos-dir
Affected Issues
0000383
mod - src/dird/ua_tree.c Diff File

bareos: bareos-14.2 f3d86023

2016-01-04 10:04:27

Jyri Palis


Committer: mvwieringen

Ported: N/A

Details Diff
mssqlvdi: Fix IClientVirtualDeviceSet2::CreateEx call.

Seems we need to call IClientVirtualDeviceSet2::CreateEx with as first
argument the instance name when connecting to the an non default
instance.

Fixes 0000383: mssqldvi problem with connection to mssql not default
instance
Affected Issues
0000383
mod - AUTHORS Diff File
mod - src/win32/plugins/filed/mssqlvdi-fd.c Diff File

Issue History

Date Modified Username Field Change
2014-12-24 09:40 irekpias New Issue
2014-12-24 09:41 irekpias File Added: dir-crash-bareos-dir.png
2014-12-24 09:43 irekpias File Added: posejdon-dir.5003.bactrace
2014-12-24 09:46 irekpias Note Added: 0001154
2014-12-24 10:59 mvwieringen Note Added: 0001155
2014-12-24 10:59 mvwieringen Status new => feedback
2014-12-24 11:29 irekpias Note Added: 0001156
2014-12-24 11:29 irekpias Status feedback => new
2014-12-24 11:31 irekpias File Added: bareos.1694.traceback
2014-12-24 12:51 mvwieringen Note Added: 0001157
2014-12-24 12:51 mvwieringen Status new => feedback
2014-12-24 12:55 irekpias Note Added: 0001158
2014-12-24 12:55 irekpias Status feedback => new
2014-12-24 13:21 mvwieringen Note Added: 0001159
2014-12-24 13:21 mvwieringen Assigned To => mvwieringen
2014-12-24 13:21 mvwieringen Status new => assigned
2014-12-24 14:13 mvwieringen Changeset attached => bareos master ae9681c8
2014-12-24 14:13 mvwieringen Note Added: 0001160
2014-12-24 14:13 mvwieringen Status assigned => resolved
2014-12-24 14:13 mvwieringen Resolution open => fixed
2014-12-24 14:21 mvwieringen Changeset attached => bareos bareos-14.2 8befea7d
2014-12-24 14:21 mvwieringen Note Added: 0001163
2015-01-13 22:54 mvwieringen Relationship added has duplicate 0000398
2015-01-19 12:29 maik Relationship added duplicate of 0000354
2015-01-26 16:00 mvwieringen adm Assigned To mvwieringen =>
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-14.2 09ee5e3b
2015-03-25 16:51 mvwieringen Note Added: 0001450
2015-03-25 19:03 joergs Fixed in Version => 14.2.2
2015-03-25 19:19 joergs Note Added: 0001646
2015-03-25 19:19 joergs Status resolved => closed
2016-01-07 19:44 mvwieringen Changeset attached => bareos master 5389d0d1
2016-01-07 19:44 mvwieringen Note Added: 0002073
2016-01-07 19:44 mvwieringen Status closed => resolved
2016-01-07 19:46 mvwieringen Changeset removed bareos master 5389d0d1 =>
2016-03-11 14:35 maik bareos-15.2: impact => yes
2016-03-11 14:35 maik bareos-15.2: action => fixed
2016-03-11 14:35 maik bareos-14.2: impact => yes
2016-03-11 14:35 maik Relationship added child of 0000625
2016-03-11 14:58 maik Relationship deleted child of 0000625
2016-03-11 14:59 joergs bareos-master: impact => yes
2016-03-11 14:59 joergs bareos-master: action => fixed
2016-03-11 14:59 joergs bareos-15.2: impact yes => no
2016-03-11 14:59 joergs bareos-15.2: action fixed => none
2016-03-11 14:59 joergs bareos-14.2: action => fixed
2016-07-05 11:51 joergs Relationship added child of 0000584
2016-07-05 11:52 joergs Relationship deleted child of 0000584
2016-07-08 14:34 mvwieringen Changeset attached => bareos bareos-14.2 f3d86023
2016-07-08 14:34 mvwieringen Note Added: 0002308