View Issue Details

IDProjectCategoryView StatusLast Update
0000378bareos-core[All Projects] directorpublic2015-03-25 19:19
ReporterirekpiasAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindows 8OSWindowsOS Version8
Product Version 
Fixed in Version 
Summary0000378: Bareos tray monitor - not accurate information from bareos-dir
DescriptionHi.

I use bareos-tray-monitor to monitor directos, storage daemon and some bareos clients.

Info from director isn't accurate. It is lacking information about schedules, number of terminates job.

Here ale copy&paste info about director form bareos-try-monitor:

XXXXX-dir Version: 14.2.2 (12 December 2014) x86_64-redhat-linux-gnu redhat CentOS release 5.10 (Final)
Daemon started 17-gru-14 23:52. Jobs: run=10, running=0 mode=0
 Heap: heap=974,848 smbytes=509,312 max_bytes=601,342 bufs=5,530 max_bufs=5,554
No Scheduled Jobs.
====

Running Jobs:
Console connected at 18-gru-14 07:25
Console connected at 19-gru-14 07:11
Console connected at 19-gru-14 10:30
No Jobs running.
====

Terminated Jobs:
 JobId Level Files Bytes Status Finished Name
====================================================================

====


TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

pstorz

pstorz

2014-12-22 17:13

administrator   ~0001147

JobACLs are now also enforced on the job listings.

Please add

JobACL = *all*

to your monitor restricted console.
irekpias

irekpias

2014-12-22 20:19

reporter   ~0001148

Yes, that did the trick. Many thanks for the help ! Of course, that is not bug. I must more intensive use [bareos-users] list.

Best regards !
pstorz

pstorz

2014-12-23 19:25

administrator   ~0001150

Fix committed to bareos master branch with changesetid 2585.
mvwieringen

mvwieringen

2014-12-24 14:21

developer   ~0001162

Fix committed to bareos bareos-14.2 branch with changesetid 2597.
mvwieringen

mvwieringen

2015-03-25 16:51

developer   ~0001451

Fix committed to bareos2015 bareos-14.2 branch with changesetid 4492.
joergs

joergs

2015-03-25 19:19

administrator   ~0001601

Due to the reimport of the Github repository to bugs.bareos.org, the status of some tickets have been changed. These tickets will be closed again.
Sorry for the noise.

Related Changesets

bareos: master 57641508

2014-12-22 16:11:35

pstorz

Ported: N/A

Details Diff
Add JobACL to monitor console to see jobs

Looks like before the status command did not limit the
view of jobs according to the JobACL.

As the ACLs now have been fixed, we need to allow the
monitor ressource to see all jobs because otherwise
we see nothing.

Fixes 0000378: Bareos tray monitor - not accurate information from
bareos-dir
Affected Issues
0000378
mod - platforms/univention/conffiles/etc/bareos/bareos-dir.conf Diff File
mod - src/defaultconfigs/diskonly/bareos-dir.conf.in Diff File
mod - src/defaultconfigs/legacy/bareos-dir.conf.in Diff File

bareos: bareos-14.2 e9b20cd0

2014-12-22 16:11:35

pstorz


Committer: mvwieringen

Ported: N/A

Details Diff
Add JobACL to monitor console to see jobs

Looks like before the status command did not limit the
view of jobs according to the JobACL.

As the ACLs now have been fixed, we need to allow the
monitor ressource to see all jobs because otherwise
we see nothing.

Fixes 0000378: Bareos tray monitor - not accurate information from
bareos-dir
Affected Issues
0000378
mod - platforms/univention/conffiles/etc/bareos/bareos-dir.conf Diff File
mod - src/defaultconfigs/diskonly/bareos-dir.conf.in Diff File
mod - src/defaultconfigs/legacy/bareos-dir.conf.in Diff File

bareos2015: bareos-14.2 49d2359a

2014-12-22 17:11:35

pstorz


Committer: mvwieringen

Ported: N/A

Details Diff
Add JobACL to monitor console to see jobs

Looks like before the status command did not limit the
view of jobs according to the JobACL.

As the ACLs now have been fixed, we need to allow the
monitor ressource to see all jobs because otherwise
we see nothing.

Fixes 0000378: Bareos tray monitor - not accurate information from
bareos-dir
Affected Issues
0000378
mod - platforms/univention/conffiles/etc/bareos/bareos-dir.conf Diff File
mod - src/defaultconfigs/diskonly/bareos-dir.conf.in Diff File
mod - src/defaultconfigs/legacy/bareos-dir.conf.in Diff File

Issue History

Date Modified Username Field Change
2014-12-19 13:50 irekpias New Issue
2014-12-19 22:09 pstorz Assigned To => pstorz
2014-12-19 22:09 pstorz Status new => assigned
2014-12-22 17:13 pstorz Note Added: 0001147
2014-12-22 20:19 irekpias Note Added: 0001148
2014-12-23 19:25 pstorz Changeset attached => bareos master 57641508
2014-12-23 19:25 pstorz Note Added: 0001150
2014-12-23 19:25 pstorz Status assigned => resolved
2014-12-23 19:25 pstorz Resolution open => fixed
2014-12-23 19:28 mvwieringen adm Status resolved => closed
2014-12-23 19:28 mvwieringen adm Assigned To pstorz =>
2014-12-24 14:21 mvwieringen Changeset attached => bareos bareos-14.2 e9b20cd0
2014-12-24 14:21 mvwieringen Note Added: 0001162
2014-12-24 14:21 mvwieringen Assigned To => mvwieringen
2014-12-24 14:21 mvwieringen Status closed => resolved
2015-01-26 16:01 mvwieringen adm Assigned To mvwieringen =>
2015-01-26 16:14 mvwieringen adm Status resolved => closed
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-14.2 49d2359a
2015-03-25 16:51 mvwieringen Note Added: 0001451
2015-03-25 16:51 mvwieringen Status closed => resolved
2015-03-25 19:19 joergs Note Added: 0001601
2015-03-25 19:19 joergs Status resolved => closed