View Issue Details

IDProjectCategoryView StatusLast Update
0000366bareos-corefile daemonpublic2015-06-01 16:22
Reporteritheiss Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinux Debian 7 OSDebian 7 
Product Version14.2.1 
Summary0000366: Accurate Mode and strippath
DescriptionI have run a job in Accurate Mode (Accurate = yes) and in the coresponding FileSet I have specified Options { strippath = 2 }. The full backup is working as expected. I can verify in the database (table 'path') that two directories were stripped off. Next run is an incremental run and then I get the following kind of errors:

Backup-FD JobId 3: Error: Cannot open /data/test/sample.txt ERR=No such file or directory.

The original path before strippath gets applied was: /mnt/backup/data/test/sample.txt

The two options Accurate = yes and strippath do not seem to work together. I have expected that strippath is applied before the Accurate Mode is checked. Is this a bug or are these options merely exclusive.?
TagsNo tags attached.
bareos-master: impactyes
bareos-master: actionfixed
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impactyes
bareos-14.2: actionfixed
bareos-13.2: impact
bareos-13.2: actionnone
bareos-12.4: impact
bareos-12.4: actionnone

Relationships

child of 0000447 closedjoergs Release bareos-14.2.5 

Activities

mvwieringen

mvwieringen

2014-11-23 15:15

developer   ~0001072

I would be interested in seeing some debug output from the filed at
debug level 100. Looking at the accurate code the only things which
seems obvious is that this might happen when an md4 or sha1 digest is
made for comparing in accurate mode.

It would be the best if you test with a small fileset with only a few
files. You get the debug output by running bareos-fd -f -d 100 > logfile 2>&1
mvwieringen

mvwieringen

2015-04-16 23:04

developer   ~0001692

Fix committed to bareos master branch with changesetid 5187.
mvwieringen

mvwieringen

2015-05-29 18:06

developer   ~0001755

Fix committed to bareos bareos-14.2 branch with changesetid 5331.

Related Changesets

bareos: master ed0bfb45

2015-04-16 23:02:06

mvwieringen

Ported: N/A

Details Diff
Fix accurate mode when using strip path.

Fixes 0000366: Accurate Mode and strippath
Affected Issues
0000366
mod - src/filed/accurate.c Diff File

bareos: bareos-14.2 f0d33f86

2015-04-16 23:02:06

mvwieringen

Ported: N/A

Details Diff
Fix accurate mode when using strip path.

Fixes 0000366: Accurate Mode and strippath
Affected Issues
0000366
mod - src/filed/accurate.c Diff File

Issue History

Date Modified Username Field Change
2014-11-20 21:04 itheiss New Issue
2014-11-23 15:12 mvwieringen Assigned To => mvwieringen
2014-11-23 15:12 mvwieringen Status new => assigned
2014-11-23 15:15 mvwieringen Note Added: 0001072
2014-11-23 15:27 mvwieringen Status assigned => feedback
2015-02-10 14:50 mvwieringen Assigned To mvwieringen =>
2015-04-16 22:50 mvwieringen Status feedback => closed
2015-04-16 22:50 mvwieringen Resolution open => unable to reproduce
2015-04-16 23:04 mvwieringen Changeset attached => bareos master ed0bfb45
2015-04-16 23:04 mvwieringen Note Added: 0001692
2015-04-16 23:04 mvwieringen Status closed => resolved
2015-04-16 23:04 mvwieringen Resolution unable to reproduce => fixed
2015-05-27 12:44 joergs Relationship added child of 0000447
2015-05-27 12:44 joergs bareos-master: impact => yes
2015-05-27 12:44 joergs bareos-master: action => fixed
2015-05-27 12:44 joergs bareos-14.2: impact => yes
2015-05-27 12:44 joergs bareos-14.2: action => will care
2015-05-29 18:06 mvwieringen Changeset attached => bareos bareos-14.2 f0d33f86
2015-05-29 18:06 mvwieringen Note Added: 0001755
2015-06-01 16:22 joergs bareos-14.2: action will care => fixed
2015-06-01 16:22 joergs bareos-13.2: action => none
2015-06-01 16:22 joergs bareos-12.4: action => none
2015-06-01 16:22 joergs Status resolved => closed