View Issue Details

IDProjectCategoryView StatusLast Update
0000341bareos-corestorage daemonpublic2015-03-25 19:19
Reportergusber Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformamd64OSFreeBSDOS Version10.0-RELEASE-p2
Summary0000341: stored compile fails
Descriptionconfigured with:

CFLAGS="-O3 -I/usr/local/include"
CXXFLAGS="-O3 -I/usr/local/include"

./configure --prefix="/usr/local" --exec-prefix="/usr/local" --enable-lockmgr --enable-includes --disable-ipv6 --enable-dynamic-cats-backends --disable-bat --with-mysql --with-lzo="/usr/local" --with-readline --disable-conio --disable-ndmp --disable-scsi-crypto --with-openssl --with-working-dir="/opt/bareos" --with-archivedir="/opt/backup" --with-zlib --with-python

line 812: src/stored/backends/generic_tape_device.c fails to compile.
undefined reference to dev_errno

Steps To Reproduce# Host: x86_64-amd-freebsd10.0 -- freebsd 10.0-RELEASE-p2
CFLAGS="-O3 -I/usr/local/include"
CXXFLAGS="-O3 -I/usr/local/include"

export CFLAGS CXXFLAGS

./configure --prefix="/usr/local" --exec-prefix="/usr/local" --enable-lockmgr --enable-includes --disable-ipv6 --enable-dynamic-cats-backends --disable-bat --with-mysql --with-lzo="/usr/local" --with-readline --disable-conio --disable-ndmp --disable-scsi-crypto --with-openssl --with-working-dir="/opt/bareos" --with-archivedir="/opt/backup" --with-zlib --with-python

make
Additional InformationFixed by changing
line 812: src/stored/backends/generic_tape_device.c:

From:
Dmsg2(200, "Doing MTIOCERRSTAT errno=%d ERR=%s\n", dev_errno, be.bstrerror(dev_errno));

To:
Dmsg2(200, "Doing MTIOCERRSTAT errno=%d ERR=%s\n", dev->dev_errno, be.bstrerror(dev->dev_errno));
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

mvwieringen

mvwieringen

2014-09-24 15:57

developer   ~0000987

Fix committed to bareos bareos-14.2 branch with changesetid 2151.
mvwieringen

mvwieringen

2014-09-24 15:57

developer   ~0000988

Fix committed to bareos master branch with changesetid 2152.
mvwieringen

mvwieringen

2015-03-25 16:51

developer   ~0001462

Fix committed to bareos2015 bareos-14.2 branch with changesetid 4626.
joergs

joergs

2015-03-25 19:19

developer   ~0001612

Due to the reimport of the Github repository to bugs.bareos.org, the status of some tickets have been changed. These tickets will be closed again.
Sorry for the noise.

Related Changesets

bareos: bareos-14.2 438769fa

2014-09-24 13:27:46

mvwieringen

Ported: N/A

Details Diff
Fix typo.

Fixes 0000341: stored compile fails
Affected Issues
0000341
mod - src/stored/backends/generic_tape_device.c Diff File

bareos: master 3653b3aa

2014-09-24 13:27:46

mvwieringen

Ported: N/A

Details Diff
Fix typo.

Fixes 0000341: stored compile fails
Affected Issues
0000341
mod - src/stored/backends/generic_tape_device.c Diff File

bareos2015: bareos-14.2 8c559e33

2014-09-24 15:27:46

mvwieringen

Ported: N/A

Details Diff
Fix typo.

Fixes 0000341: stored compile fails
Affected Issues
0000341
mod - src/stored/backends/generic_tape_device.c Diff File

Issue History

Date Modified Username Field Change
2014-09-24 14:18 gusber New Issue
2014-09-24 15:57 mvwieringen Changeset attached => bareos bareos-14.2 438769fa
2014-09-24 15:57 mvwieringen Note Added: 0000987
2014-09-24 15:57 mvwieringen Assigned To => mvwieringen
2014-09-24 15:57 mvwieringen Status new => resolved
2014-09-24 15:57 mvwieringen Resolution open => fixed
2014-09-24 15:57 mvwieringen Changeset attached => bareos master 3653b3aa
2014-09-24 15:57 mvwieringen Note Added: 0000988
2014-09-29 11:17 mvwieringen adm Assigned To mvwieringen =>
2014-09-29 11:17 mvwieringen adm Status resolved => closed
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-14.2 8c559e33
2015-03-25 16:51 mvwieringen Note Added: 0001462
2015-03-25 16:51 mvwieringen Status closed => resolved
2015-03-25 19:19 joergs Note Added: 0001612
2015-03-25 19:19 joergs Status resolved => closed