View Issue Details

IDProjectCategoryView StatusLast Update
0000312bareos-core[All Projects] Generalpublic2015-03-25 19:18
ReporteradykielAssigned To 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Platformlinux_x86_64OSDebian GNU/LinuxOS Version7
Product Version12.4.6 
Fixed in Version 
Summary0000312: no elapsed time info in restore job
DescriptionRestore job message shows only this information:


17-Jun 12:34 bareos-dir JobId 1893: Bareos bareos-dir 12.4.6 (12Sep13):
  Build OS: x86_64-pc-linux-gnu debian Debian GNU/Linux 7.0 (wheezy)
  JobId: 1893
  Job: RestoreFiles.2014-06-17_12.34.33_19
  Restore Client: vs5
  Start time: 17-Jun-2014 12:34:35
  End time: 17-Jun-2014 12:34:42
  Files Expected: 3,056
  Files Restored: 3,056
  Bytes Restored: 24,126,336
  Rate: 3446.6 KB/s
  FD Errors: 0
  FD termination status: OK
  SD termination status: OK
  Termination: Restore OK


Steps To Reproducedo restore job
Additional InformationIt would be nice to know how much time it took the same way it's calculated in backup job.
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

mvwieringen

mvwieringen

2014-06-17 16:22

developer   ~0000910

Fix committed to bareos master branch with changesetid 1866.
mvwieringen

mvwieringen

2014-06-18 11:17

developer   ~0000913

Fix committed to bareos bareos-13.2 branch with changesetid 1872.
mvwieringen

mvwieringen

2014-06-18 16:30

developer   ~0000915

Fix committed to bareos bareos-12.4 branch with changesetid 1875.
mvwieringen

mvwieringen

2015-03-25 16:51

developer   ~0001345

Fix committed to bareos2015 bareos-14.2 branch with changesetid 4741.
joergs

joergs

2015-03-25 19:18

administrator   ~0001501

Due to the reimport of the Github repository to bugs.bareos.org, the status of some tickets have been changed. These tickets will be closed again.
Sorry for the noise.

Related Changesets

bareos: master 1086c0de

2014-06-17 14:17:08

mvwieringen

Ported: N/A

Details Diff
No elapsed time info in restore job.

Added code sniplet that calculates the elapsed time of a restore Job.
This uses the same code used in the generate_backup_summary() function
now in the generate_restore_summary() function.

Fixes 0000312: no elapsed time info in restore job
Affected Issues
0000312
mod - src/dird/backup.c Diff File
mod - src/dird/restore.c Diff File

bareos: bareos-13.2 b55442d6

2014-06-17 14:17:08

mvwieringen

Ported: N/A

Details Diff
No elapsed time info in restore job.

Added code sniplet that calculates the elapsed time of a restore Job.
This uses the same code used in the generate_backup_summary() function
now in the generate_restore_summary() function.

Fixes 0000312: no elapsed time info in restore job
Affected Issues
0000312
mod - src/dird/backup.c Diff File
mod - src/dird/restore.c Diff File

bareos: bareos-12.4 12dc7333

2014-06-17 14:17:08

mvwieringen

Ported: N/A

Details Diff
No elapsed time info in restore job.

Added code sniplet that calculates the elapsed time of a restore Job.
This uses the same code used in the generate_backup_summary() function
now in the generate_restore_summary() function.

Fixes 0000312: no elapsed time info in restore job
Affected Issues
0000312
mod - src/dird/restore.c Diff File

bareos2015: bareos-12.4 395d698c

2014-06-17 16:17:08

mvwieringen

Ported: N/A

Details Diff
No elapsed time info in restore job.

Added code sniplet that calculates the elapsed time of a restore Job.
This uses the same code used in the generate_backup_summary() function
now in the generate_restore_summary() function.

Fixes 0000312: no elapsed time info in restore job
Affected Issues
0000312
mod - src/dird/restore.c Diff File

bareos2015: bareos-13.2 3c9312d5

2014-06-17 16:17:08

mvwieringen

Ported: N/A

Details Diff
No elapsed time info in restore job.

Added code sniplet that calculates the elapsed time of a restore Job.
This uses the same code used in the generate_backup_summary() function
now in the generate_restore_summary() function.

Fixes 0000312: no elapsed time info in restore job
Affected Issues
0000312
mod - src/dird/backup.c Diff File
mod - src/dird/restore.c Diff File

bareos2015: bareos-14.2 3738dbf5

2014-06-17 16:17:08

mvwieringen

Ported: N/A

Details Diff
No elapsed time info in restore job.

Added code sniplet that calculates the elapsed time of a restore Job.
This uses the same code used in the generate_backup_summary() function
now in the generate_restore_summary() function.

Fixes 0000312: no elapsed time info in restore job
Affected Issues
0000312
mod - src/dird/backup.c Diff File
mod - src/dird/restore.c Diff File

Issue History

Date Modified Username Field Change
2014-06-17 14:30 adykiel New Issue
2014-06-17 16:22 mvwieringen Changeset attached => bareos master 1086c0de
2014-06-17 16:22 mvwieringen Note Added: 0000910
2014-06-17 16:22 mvwieringen Assigned To => mvwieringen
2014-06-17 16:22 mvwieringen Status new => resolved
2014-06-17 16:22 mvwieringen Resolution open => fixed
2014-06-18 11:17 mvwieringen Changeset attached => bareos bareos-13.2 b55442d6
2014-06-18 11:17 mvwieringen Note Added: 0000913
2014-06-18 16:30 mvwieringen Changeset attached => bareos bareos-12.4 12dc7333
2014-06-18 16:30 mvwieringen Note Added: 0000915
2014-10-20 17:02 mvwieringen Status resolved => closed
2014-10-20 17:02 mvwieringen Assigned To mvwieringen =>
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-12.4 395d698c
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-13.2 3c9312d5
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-14.2 3738dbf5
2015-03-25 16:51 mvwieringen Note Added: 0001345
2015-03-25 16:51 mvwieringen Status closed => resolved
2015-03-25 19:18 joergs Note Added: 0001501
2015-03-25 19:18 joergs Status resolved => closed