View Issue Details

IDProjectCategoryView StatusLast Update
0000295bareos-core[All Projects] Generalpublic2015-01-26 16:26
ReporterMaxHeadroomAssigned To 
PrioritynoneSeverityfeatureReproducibilityN/A
Status closedResolutionwon't fix 
Product Version 
Fixed in Version 
Summary0000295: Delta copy of big files
DescriptionBackup big files that only had changed some megabytes (eg. Virtual Client images) take long and need a lot of space on backup media.
A better solution would be a delta copy of the previous backuped file.

Save only the delta from current-(fullbackup+all deltas)
On a 'virtual-full' this should be build only on the bareos server with the full and all delta backups.

Look at http://xdelta.org maybe it helps.

regards max
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

joergs

joergs

2014-05-16 17:15

administrator   ~0000866

Stephan, do I remember correctly, that you've taken a look at this? Did it look promising?
stephand

stephand

2014-05-19 12:42

developer   ~0000872

The problem with xdelta is, as far as I know, that it needs the full old data beside the new (changed) data to compute the delta. That conflicts with the goal to minimize network data transfer. It would be necesary to transfer the full new data via network to where the old data resides enable to compute the delta using xdelta.

It looks like only rdiff (librsync) supports computing the delta using only the much smaller signature of the old data.

On the other hand, the deltas generated by xdelta are a lot smaller than rdiff deltas.

For a more detailed comparison: There's a master thesis about "Binary Differencing for Media Files" from Vladimir Komsiyski at http://dare.uva.nl/document/490827

So when considering minimizing network data transfer more important than minimizing delta size, rdiff (librsync) would be the better choice.
mvwieringen adm

mvwieringen adm

2015-01-26 16:26

administrator   ~0001223

We try to tackle this via either GSOC or some thesis work.

Issue History

Date Modified Username Field Change
2014-05-13 16:43 MaxHeadroom New Issue
2014-05-16 17:14 joergs Assigned To => stephand
2014-05-16 17:14 joergs Status new => assigned
2014-05-16 17:15 joergs Note Added: 0000866
2014-05-19 12:42 stephand Note Added: 0000872
2015-01-26 16:26 mvwieringen adm Note Added: 0001223
2015-01-26 16:26 mvwieringen adm Assigned To stephand =>
2015-01-26 16:26 mvwieringen adm Status assigned => closed
2015-01-26 16:26 mvwieringen adm Resolution open => won't fix