View Issue Details

IDProjectCategoryView StatusLast Update
0000263bareos-core[All Projects] file daemonpublic2015-01-26 16:18
ReporterPGAssigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionnot fixable 
PlatformWindowsOSWindows ServerOS Version2003R2 SP2
Product Version13.2.2 
Fixed in Version 
Summary0000263: Restored tempory files got hardlinked to systemfiles on domain controller - Sysvol contents damaged
DescriptionI did a test-restore of the System-Dir (C:\Windows) from client A to client B - on client B the destination was c:\tmp. (default)

The Restore was repored as "OK".

Then i wanted to delete the Test-Files in C:\tmp - i wondered a little bit about messages like "can not delete - file is open".

After some while i found out that there were missing Group Policies.
After further research i found out that the deletion of c:\tmp\Windows\Sysvol\ deleted also the files in the real C:\windows\Sysvol!

It seems to be a problem with the DFS-Service and Files beeing marked as hardling?

Steps To ReproduceI repeated restores of System-Files to temp-directory.
After deleting the contents of the temp-directory, there was always removed the original content in c:\windows\sysvol\..
Additional InformationBareos 13.2.2 on Server and Clients.
Director Ubuntu Server 12.04
FD-Clients Windows 2003R2 SP2.
BAT-Client Windows XP.
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

mvwieringen

mvwieringen

2014-01-01 11:59

developer   ~0000776

Seems this is a known problem:

http://support.microsoft.com/kb/324175

The junction points are probably restored as part of the Backup API
protocol that is used. To fix this we probably need to filter the
data restored by the backup API to ignore junction/ reparse points
of a certain type.
maik

maik

2015-01-19 12:32

administrator   ~0001197

Windows problem, see link to KB above.

Issue History

Date Modified Username Field Change
2013-12-27 18:06 PG New Issue
2014-01-01 11:59 mvwieringen Note Added: 0000776
2014-01-01 11:59 mvwieringen Priority urgent => normal
2014-01-01 11:59 mvwieringen Status new => confirmed
2015-01-19 12:32 maik Note Added: 0001197
2015-01-19 12:32 maik Status confirmed => closed
2015-01-19 12:32 maik Assigned To => maik
2015-01-19 12:32 maik Resolution open => not fixable
2015-01-26 16:18 mvwieringen adm Assigned To maik =>