View Issue Details

IDProjectCategoryView StatusLast Update
0000241bareos-core[All Projects] documentationpublic2013-10-29 18:36
ReporterchrfleAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSanyOS Version3
Product Version13.2.1 
Fixed in Version 
Summary0000241: Correct default value of "Allow Duplicate Jobs"
DescriptionSince bacula commit f91db64 the
default of "Allow Duplicate Jobs" has been yes instead of no as the
manual states.
Additional InformationPatch on it's way
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

chrfle

chrfle

2013-10-28 18:32

reporter  

0001-Correct-default-value-of-Allow-Duplicate-Jobs.patch (1,555 bytes)
From 1cc094c48a156f03e7b70100e03379c2fb26b388 Mon Sep 17 00:00:00 2001
From: Christer Fletcher <android@fletcher.se>
Date: Sun, 27 Oct 2013 22:09:41 +0100
Subject: [PATCH] Correct default value of "Allow Duplicate Jobs"

Since bacula commit f91db64cb5dd84e91c3b077e19bfb6f803795f1e the
default of "Allow Duplicate Jobs" has been yes instead of no as the
manual states.
---
 manuals/en/main/dirdconf.tex | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/manuals/en/main/dirdconf.tex b/manuals/en/main/dirdconf.tex
index cec4cad..8db78e1 100644
--- a/manuals/en/main/dirdconf.tex
+++ b/manuals/en/main/dirdconf.tex
@@ -1776,7 +1776,7 @@ with the same name starts.  This happens most frequently when the first job
 runs longer than expected because no tapes are available.
 
 If this directive is enabled duplicate jobs will be run.  If
-the directive is set to {\bf no} (default) then only one job of a given name
+the directive is set to {\bf no} then only one job of a given name
 may run at one time, and the action that Bareos takes to ensure only
 one job runs is determined by the other directives (see below).
 
@@ -1785,6 +1785,8 @@ are present and none of the three directives given below permit
 cancelling a job, then the current job (the second one started)
 will be cancelled.
 
+The default is {\bf yes}.
+
 % \item [Allow Higher Duplicates = {\textless}yes{\textbar}no{\textgreater}] \hfill \\
 % \index[general]{Allow Higher Duplicates}
 % This directive was implemented in version 5.0.0, but does not work
-- 
1.8.3.2

chrfle

chrfle

2013-10-28 18:33

reporter   ~0000708

This one cause me a whole lot of confusion until I started debugging it and saw that the default was wrongly documented.
chrfle

chrfle

2013-10-28 18:45

reporter   ~0000709

dird_conf.c:359

   { "allowduplicatejobs", CFG_TYPE_BOOL, ITEM(res_job.AllowDuplicateJobs), 0, CFG_ITEM_DEFAULT, "true" },
mvwieringen

mvwieringen

2013-10-29 18:29

developer   ~0000713

Fix committed to bareos-docs master branch with changesetid 1296.

Related Changesets

bareos-docs: master 92efeed8

2013-10-27 21:09:41

chrfle


Committer: mvwieringen

Ported: N/A

Details Diff
Correct default value of "Allow Duplicate Jobs"

Since bacula commit f91db64cb5dd84e91c3b077e19bfb6f803795f1e the
default of "Allow Duplicate Jobs" has been yes instead of no as the
manual states.

Fixes 0000241: Correct default value of "Allow Duplicate Jobs"

Signed-off-by: Marco van Wieringen <marco.van.wieringen@bareos.com>
Affected Issues
0000241
mod - manuals/en/main/dirdconf.tex Diff File

Issue History

Date Modified Username Field Change
2013-10-28 18:32 chrfle New Issue
2013-10-28 18:32 chrfle File Added: 0001-Correct-default-value-of-Allow-Duplicate-Jobs.patch
2013-10-28 18:33 chrfle Note Added: 0000708
2013-10-28 18:45 chrfle Note Added: 0000709
2013-10-29 18:29 mvwieringen Changeset attached => bareos-docs master 92efeed8
2013-10-29 18:29 mvwieringen Note Added: 0000713
2013-10-29 18:29 mvwieringen Assigned To => mvwieringen
2013-10-29 18:29 mvwieringen Status new => resolved
2013-10-29 18:29 mvwieringen Resolution open => fixed
2013-10-29 18:36 mvwieringen Status resolved => closed
2013-10-29 18:36 mvwieringen Assigned To mvwieringen =>