View Issue Details

IDProjectCategoryView StatusLast Update
0000209bareos-core[All Projects] Generalpublic2015-03-25 19:19
ReportermvwieringenAssigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
PlatformOpenIndianaOSOpenIndianaOS Versionb151a
Product Version12.4.4 
Fixed in Version 
Summary0000209: Implement a store_alist_dir function
DescriptionWe currently have the following functions:

- store_dir() (For storing a string with shell expansion to a dir/file)
- store_str() (For storing a string)
- store_alist_str() (For storing a list of strings)

we are missing a store_alist_dir() which stores a list of shell expanded
dirs/files.
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

mvwieringen

mvwieringen

2013-07-17 19:32

developer   ~0000536

Fix committed to bareos master branch with changesetid 518.
mvwieringen adm

mvwieringen adm

2013-08-13 03:12

administrator   ~0000569

Fix committed to bareos master branch with changesetid 573.
mvwieringen

mvwieringen

2015-03-25 16:51

developer   ~0001489

Fix committed to bareos2015 bareos-14.2 branch with changesetid 5061.
joergs

joergs

2015-03-25 19:19

administrator   ~0001638

Due to the reimport of the Github repository to bugs.bareos.org, the status of some tickets have been changed. These tickets will be closed again.
Sorry for the noise.

Related Changesets

bareos: master fa6a0548

2013-07-17 17:30:24

mvwieringen adm

Ported: N/A

Details Diff
Implement a store_alist_dir function

We currently have the following functions:

- store_dir() (For storing a string with shell expansion to a dir/file)
- store_str() (For storing a string)
- store_alist_str() (For storing a list of strings)

we are missing a store_alist_dir() which stores a list of shell
expanded dirs/files.

Fixes 0000209: Implement a store_alist_dir function
Affected Issues
0000209
mod - src/lib/parse_conf.h Diff File
mod - src/lib/parse_conf.c Diff File
mod - src/filed/filed_conf.c Diff File

bareos2015: bareos-14.2 a4bb4971

2013-07-17 19:30:24

mvwieringen

Ported: N/A

Details Diff
Implement a store_alist_dir function

We currently have the following functions:

- store_dir() (For storing a string with shell expansion to a dir/file)
- store_str() (For storing a string)
- store_alist_str() (For storing a list of strings)

we are missing a store_alist_dir() which stores a list of shell
expanded dirs/files.

Fixes 0000209: Implement a store_alist_dir function
Affected Issues
0000209
mod - src/filed/filed_conf.c Diff File
mod - src/lib/parse_conf.c Diff File
mod - src/lib/parse_conf.h Diff File

Issue History

Date Modified Username Field Change
2013-07-17 19:11 mvwieringen New Issue
2013-07-17 19:11 mvwieringen Status new => assigned
2013-07-17 19:11 mvwieringen Assigned To => mvwieringen
2013-07-17 19:32 mvwieringen Changeset attached => bareos master a127df43
2013-07-17 19:32 mvwieringen Note Added: 0000536
2013-07-17 19:32 mvwieringen Status assigned => resolved
2013-07-17 19:32 mvwieringen Resolution open => fixed
2013-08-13 03:12 mvwieringen adm Changeset attached => bareos master fa6a0548
2013-08-13 03:12 mvwieringen adm Note Added: 0000569
2013-08-13 03:12 mvwieringen adm Assigned To mvwieringen => mvwieringen adm
2013-09-06 13:12 mvwieringen Status resolved => closed
2013-09-06 13:12 mvwieringen Assigned To mvwieringen adm =>
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-14.2 a4bb4971
2015-03-25 16:51 mvwieringen Note Added: 0001489
2015-03-25 16:51 mvwieringen Status closed => resolved
2015-03-25 19:19 joergs Note Added: 0001638
2015-03-25 19:19 joergs Status resolved => closed