View Issue Details

IDProjectCategoryView StatusLast Update
0001481bareos-coreinstaller / packagespublic2022-09-13 11:42
ReporterRyushin Assigned Tobruno-at-bareos  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionwon't fix 
PlatformLinuxOSDebianOS Version10
Product Version21.1.4 
Summary0001481: SysV Init Scripts Missing in Debian
DescriptionI see in the release notes for 21 that SysV init scripts were removed. Debian supports multiple init systems:
https://wiki.debian.org/Init

As such, SysV is not obsolete but still supported under Debian. I have Debian and Devuan servers running SysV. So if Debian packages are provided, SysV init scripts should also be provided in the packages.
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

bruno-at-bareos

bruno-at-bareos

2022-09-13 11:41

developer   ~0004745

The wiki page state clearly that all others init except systemd are in a non production, non supported state.

>>Since jessie, only systemd is fully supported; sysvinit is mostly supported, but Debian packages are not required to provide sysvinit start scripts. Support >>for init systems other than systemd is significantly improved in Bullseye. runit is also packaged, but has not received the same level of testing and >>support as the others, and is not currently supported as PID 1. As of Bullseye, a collection of sysvinit start scripts that have been removed from their >>original packages is provided in the orphan-sysvinit-scripts package.

We deliver a ready to work installation in the packages, it doesn't force any advanced admin to choose another system and use the published source to adapt to it own needs.

You are free to propose a PR in our code repository, that can package those script without interfering with Debian actual packaging rules.
bruno-at-bareos

bruno-at-bareos

2022-09-13 11:42

developer   ~0004746

Only systemd is actually supported by upstream

Issue History

Date Modified Username Field Change
2022-09-09 22:01 Ryushin New Issue
2022-09-13 11:41 bruno-at-bareos Note Added: 0004745
2022-09-13 11:42 bruno-at-bareos Assigned To => bruno-at-bareos
2022-09-13 11:42 bruno-at-bareos Status new => closed
2022-09-13 11:42 bruno-at-bareos Resolution open => won't fix
2022-09-13 11:42 bruno-at-bareos Note Added: 0004746