View Issue Details

IDProjectCategoryView StatusLast Update
0001464bareos-coredirectorpublic2022-07-05 14:53
Reportermeilihao Assigned Tobruno-at-bareos  
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformlinuxOSoracle linuxOS Version7.9
Product Version21.1.3 
Summary0001464: director can't connect filedaemon
Descriptiondirector can't connect filedaemon, got ssl error.
Steps To Reproduceenv:
- filedaemon: v21.0.0 on win10, x64
- direcor: v21.1.2, x64

bconsole run: `status client=xxx`, get error:
```bash
# tail -f /var/log/bareos.log
Network error during CRAM MD5 with 192.168.0.130
Unable to authenticate with File daemon at "192.168.0.130:9102"
```

filedaemon error: `TLS negotiation failed` and `error:1408F119:SSL routines:ssl3_get_record:decryption failed or bad record mac`
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

meilihao

meilihao

2022-05-31 04:12

reporter   ~0004630

Has anyone encountered?
bruno-at-bareos

bruno-at-bareos

2022-07-05 14:53

developer   ~0004656

After restarting both director and client, did you still get any trouble.
I'm not able to reproduce here with Win10 64bits and Centos 8 bareos binaries from download.bareos.org

From where come your director then ?
- direcor: v21.1.2, x64
bruno-at-bareos

bruno-at-bareos

2022-07-05 14:53

developer   ~0004657

Can't be reproduced

Issue History

Date Modified Username Field Change
2022-05-23 10:52 meilihao New Issue
2022-05-31 04:12 meilihao Note Added: 0004630
2022-07-05 14:53 bruno-at-bareos Note Added: 0004656
2022-07-05 14:53 bruno-at-bareos Assigned To => bruno-at-bareos
2022-07-05 14:53 bruno-at-bareos Status new => resolved
2022-07-05 14:53 bruno-at-bareos Resolution open => unable to reproduce
2022-07-05 14:53 bruno-at-bareos Note Added: 0004657