View Issue Details

IDProjectCategoryView StatusLast Update
0001396bareos-core[All Projects] bconsolepublic2021-11-24 14:43
Reporternelson.gonzalez6Assigned Tobruno-at-bareos 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformLinuxOSCentOSOS Version7
Product Version19.2.11 
Fixed in Version 
Summary0001396: HOW TO REMOVE FRON DB ALL ERROR, CANCELED, FAILED JOBS
DescriptionI HAVE NOTICED THAT WHEN LISTING IN bconsole, pools with media ids notice that have jobs from 3 to 4 years ago, all the clients that are already not in used or eliminated that are still on the db catalog list. how can i remove these jobs that are volstatus Error, experired, canceled.

need sugestions.

Thanks.


-----------------------------

| MediaId | VolumeName | VolStatus | Enabled | VolBytes | VolFiles | VolRetention | Recycle | Slot | InChanger | MediaType | L astWritten | Storage |
+---------+----------------------+-----------+---------+------------+----------+--------------+---------+------+-----------+-------------+-- -------------------+---------+
| 698 | Differentialvpn-0698 | Error | 1 | 35,437,993 | 0 | 864,000 | 1 | 0 | 0 | GlusterFile | 2 021-07-23 04:42:41 | Gluster |
| 900 | Differentialvpn-0900 | Error | 1 | 3,246,132 | 0 | 864,000 | 1 | 0 | 0 | GlusterFile | 2 021-08-29 14:56:06 | Gluster |
| 1,000 | Differentialvpn-1000 | Append | 1 | 226,375 | 0 | 864,000 | 1 | 0 | 0 | GlusterFile | 2 021-10-31 06:11:56 | Gluster |
+---------+----------------------+-----------+---------+------------+----------+-
TagsNo tags attached.
bareos-master: impactno
bareos-master: actionnone
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

bruno-at-bareos

bruno-at-bareos

2021-11-02 13:21

developer   ~0004313

Did you already test dbcheck this tool normally is the right one to cleanup orphan stored in DB.
nelson.gonzalez6

nelson.gonzalez6

2021-11-08 13:01

reporter   ~0004320

Hi yes, i have cleaned dbcheck -fv and it took long time due to lots of orphanes but when listing volumes in bconsole it still has the errors.
bruno-at-bareos

bruno-at-bareos

2021-11-10 10:01

developer   ~0004325

So in that case, the best things to do is to remove them manually: with the delete volume command into bconsole.
You will normally also have to remove manually the volume file from the filesystem.

This is due to the fact that volume in Error state are locked and then not pruned as we can't touch them anymore.
bruno-at-bareos

bruno-at-bareos

2021-11-16 15:42

developer   ~0004341

Beside removing manually those records, in bconsole or by scripting the delete volume line, you have to remember to delete the corresponding file if it still exist in your storage place.
bruno-at-bareos

bruno-at-bareos

2021-11-24 14:42

developer   ~0004357

Final note before closing. The manual process is required.
bruno-at-bareos

bruno-at-bareos

2021-11-24 14:43

developer   ~0004358

A manual process is needed as described to remove volumes in errors.

Issue History

Date Modified Username Field Change
2021-10-31 21:36 nelson.gonzalez6 New Issue
2021-11-02 13:21 bruno-at-bareos Note Added: 0004313
2021-11-08 13:01 nelson.gonzalez6 Note Added: 0004320
2021-11-10 10:01 bruno-at-bareos Note Added: 0004325
2021-11-16 15:40 bruno-at-bareos Severity major => minor
2021-11-16 15:42 bruno-at-bareos Note Added: 0004341
2021-11-24 14:42 bruno-at-bareos Note Added: 0004357
2021-11-24 14:42 bruno-at-bareos Assigned To => bruno-at-bareos
2021-11-24 14:42 bruno-at-bareos Status new => assigned
2021-11-24 14:43 bruno-at-bareos Status assigned => resolved
2021-11-24 14:43 bruno-at-bareos Resolution open => no change required
2021-11-24 14:43 bruno-at-bareos bareos-master: impact => no
2021-11-24 14:43 bruno-at-bareos bareos-master: action => none
2021-11-24 14:43 bruno-at-bareos Note Added: 0004358