View Issue Details

IDProjectCategoryView StatusLast Update
0001342bareos-core[All Projects] webuipublic2021-06-28 17:27
ReporterbluecmdAssigned Tofrank 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSDebianOS Version10
Product Version20.0.1 
Fixed in Version 
Summary0001342: Invalid login on webui causes apache2 error log to fill disk
DescriptionHi,

I am setting up Bareos 20.0.1 from using Bacula.
I followed the instructions to set it up on my Debian 11 testing system by using Debian 10 packages.

When I have configured the webui to talk to my director and I login with the right credentials, things work fine.
When I try to login with the *wrong* credentials however the PHP process seems to go haywire and output an unending loop of the following:

[Fri Apr 23 22:58:18.627635 2021] [php7:notice] [pid 50019] [client 2a07:redacted:51371] PHP Notice: fwrite(): send of 26 bytes failed with errno=104 Connection reset by peer in /usr/share/bareos-webui/vendor/Bareos/library/Bareos/BSock/BareosBSock.php on line 219, referer: https://debian.redacted/bareos-webui/
[Fri Apr 23 22:58:18.627740 2021] [php7:notice] [pid 50019] [client 2a07:redacted:51371] PHP Notice: fwrite(): send of 26 bytes failed with errno=32 Broken pipe in /usr/share/bareos-webui/vendor/Bareos/library/Bareos/BSock/BareosBSock.php on line 219, referer: https://debian.redacted/bareos-webui/
[Fri Apr 23 22:58:18.627768 2021] [php7:notice] [pid 50019] [client 2a07:redacted:51371] PHP Notice: fwrite(): send of 26 bytes failed with errno=32 Broken pipe in /usr/share/bareos-webui/vendor/Bareos/library/Bareos/BSock/BareosBSock.php on line 219, referer: https://debian.redacted/bareos-webui/
[this line repeats indefinitely]

Within seconds I have many hundred of megabytes in the log.
Steps To Reproduce1. Install 20.0.1 on Debian testing with webui
2. Login using wrong credentials
TagsNo tags attached.
bareos-master: impactyes
bareos-master: actionfixed
bareos-19.2: impactyes
bareos-19.2: actionfixed
bareos-18.2: impactyes
bareos-18.2: actionfixed
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Relationships

related to 0001324 resolvedfrank Infinite loop when trying to log with invalid account 

Activities

bluecmd

bluecmd

2021-04-23 23:16

reporter   ~0004116

Looking closer on existing bugs, this seems to be the same as https://bugs.bareos.org/view.php?id=1324

Issue History

Date Modified Username Field Change
2021-04-23 23:07 bluecmd New Issue
2021-04-23 23:16 bluecmd Note Added: 0004116
2021-04-29 11:00 frank Assigned To => frank
2021-04-29 11:00 frank Status new => assigned
2021-06-16 17:20 frank Relationship added related to 0001324
2021-06-28 17:27 frank Status assigned => resolved
2021-06-28 17:27 frank Resolution open => fixed
2021-06-28 17:27 frank bareos-master: impact => yes
2021-06-28 17:27 frank bareos-master: action => fixed
2021-06-28 17:27 frank bareos-19.2: impact => yes
2021-06-28 17:27 frank bareos-19.2: action => fixed
2021-06-28 17:27 frank bareos-18.2: impact => yes
2021-06-28 17:27 frank bareos-18.2: action => fixed