View Issue Details

IDProjectCategoryView StatusLast Update
0001234bareos-core[All Projects] directorpublic2020-06-22 19:50
ReporterbrowcioAssigned Topstorz 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version18.04
Product Version19.2.7 
Fixed in Version 
Summary0001234: Log spammed with "0 jobs that will be pruned" after upgrade
DescriptionHello,

earlier this week I upgraded our bareos instance from 19.2.6 to 19.2.7. Since then every job run causes flood of:
Volume "vol_12419" has Volume Retention of 7776000 sec. and has 0 jobs that will be pruned
Volume "vol_12420" has Volume Retention of 7776000 sec. and has 0 jobs that will be pruned
Volume "vol_12421" has Volume Retention of 7776000 sec. and has 0 jobs that will be pruned
Volume "vol_12423" has Volume Retention of 7776000 sec. and has 0 jobs that will be pruned
messages for every volume in database. Also i observe much higher database load. I suspect that this may be caused by changes in pruning code mentioned in release notes.
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

pstorz

pstorz

2020-04-28 15:22

administrator   ~0003969

Fix committed to bareos bareos-19.2 branch with changesetid 13261.

Related Changesets

bareos: master 1b062873

2020-04-27 10:41:21

pstorz

Ported: N/A

Details Diff
ua_prune.cc: skip volume prune information if no job is pruned

Fixes 0001234: Log spammed with "0 jobs that will be pruned" after upgrade
Affected Issues
0001234
mod - core/src/dird/ua_prune.cc Diff File

bareos: bareos-19.2 81d54085

2020-04-27 10:41:21

pstorz

Ported: N/A

Details Diff
ua_prune.cc: skip volume prune information if no job is pruned

Fixes 0001234: Log spammed with "0 jobs that will be pruned" after upgrade
Affected Issues
0001234
mod - core/src/dird/ua_prune.cc Diff File

Issue History

Date Modified Username Field Change
2020-04-24 18:27 browcio New Issue
2020-04-28 15:22 pstorz Changeset attached => bareos master 1b062873
2020-04-28 15:22 pstorz Changeset attached => bareos bareos-19.2 81d54085
2020-04-28 15:22 pstorz Note Added: 0003969
2020-04-28 15:22 pstorz Assigned To => pstorz
2020-04-28 15:22 pstorz Status new => resolved
2020-04-28 15:22 pstorz Resolution open => fixed