View Issue Details

IDProjectCategoryView StatusLast Update
0001201bareos-core[All Projects] directorpublic2020-02-20 14:01
ReporterIntAssigned Toarogge 
PrioritynormalSeveritymajorReproducibilitysometimes
Status closedResolutionduplicate 
PlatformLinuxOSCentOSOS Version7
Product Version19.2.6 
Fixed in Version 
Summary0001201: Fallback to unencrypted communication with older bareos client 14.2.1 sometimes fails
DescriptionFallback to unencrypted communication with older bareos client 14.2.1 sometimes works and sometimes fails.
Details see log output in Additional Information.

The link to help
http://doc.bareos.org/master/html/bareos-manual-main-reference.html#AuthorizationErrors
given in the log does not work (invalid URL)
The correct URL would be https://docs.bareos.org/Appendix/Troubleshooting.html?#authorization-errors

but I don't think the troubleshooting hints given there apply here.
Additional InformationFailed job:
----------------------------------------------------------------
2020-02-20 02:29:23 raspberry1-fd JobId 13580: Fatal error: Failed to authenticate Storage daemon.
2020-02-20 02:29:23 bareos-dir JobId 13580: Fatal error: Bad response to Storage command: wanted 2000 OK storage
, got 2902 Bad storage

2020-02-20 02:29:23 bareos-dir JobId 13580: Error: Bareos bareos-dir 19.2.6 (11Feb20):
Build OS: Linux-3.10.0-1062.9.1.el7.x86_64 redhat CentOS Linux release 7.7.1908 (Core)
JobId: 13580
Job: backup-raspberry1-fd.2020-02-19_23.55.00_16
Backup Level: Incremental, since=2020-02-19 02:50:15
Client: "raspberry1-fd" 14.2.1 (12Sep14) arm-unknown-linux-gnueabihf,debian,8.0
FileSet: "RaspbianData" 2019-03-25 22:00:00
Pool: "Backup" (From Job resource)
Catalog: "MyCatalog" (From Client resource)
Storage: "Tape" (From Job resource)
Scheduled time: 19-Feb-2020 23:55:00
Start time: 20-Feb-2020 02:29:11
End time: 20-Feb-2020 02:29:23
Elapsed time: 12 secs
Priority: 10
FD Files Written: 0
SD Files Written: 0
FD Bytes Written: 0 (0 B)
SD Bytes Written: 0 (0 B)
Rate: 0.0 KB/s
Software Compression: None
VSS: no
Encryption: no
Accurate: yes
Volume name(s):
Volume Session Id: 88
Volume Session Time: 1581695744
Last Volume Bytes: 0 (0 B)
Non-fatal FD errors: 2
SD Errors: 0
FD termination status: Fatal Error
SD termination status: Waiting on FD
Termination: *** Backup Error ***

2020-02-20 02:29:17 raspberry1-fd JobId 13580: Fatal error: Authorization key rejected by Storage daemon.
Please see http://doc.bareos.org/master/html/bareos-manual-main-reference.html#AuthorizationErrors for help.
2020-02-20 02:29:11 bareos-dir JobId 13580: Start Backup JobId 13580, Job=backup-raspberry1-fd.2020-02-19_23.55.00_16
2020-02-20 02:29:11 bareos-dir JobId 13580: Connected Storage daemon at bareos.local.lan:9103, encryption: PSK-AES256-CBC-SHA
2020-02-20 02:29:11 bareos-dir JobId 13580: Using Device "tapedrive-0" to write.
2020-02-20 02:29:11 bareos-dir JobId 13580: Connected Client: raspberry1-fd at 192.168.1.26:9102, encryption: None
2020-02-20 02:29:11 bareos-dir JobId 13580: Handshake: Cleartext
2020-02-20 02:29:11 bareos-dir JobId 13580: Encryption: None


Successful job on same client:
----------------------------------------------------------------
2020-02-19 02:51:21 bareos-sd JobId 13557: Elapsed time=00:01:06, Transfer rate=10.68 M Bytes/second
2020-02-19 02:51:21 bareos-sd JobId 13557: Sending spooled attrs to the Director. Despooling 1,652 bytes ...
2020-02-19 02:51:21 bareos-dir JobId 13557: Insert of attributes batch table with 6 entries start
2020-02-19 02:51:21 bareos-dir JobId 13557: Insert of attributes batch table done
2020-02-19 02:51:21 bareos-dir JobId 13557: Bareos bareos-dir 19.2.6 (11Feb20):
Build OS: Linux-3.10.0-1062.9.1.el7.x86_64 redhat CentOS Linux release 7.7.1908 (Core)
JobId: 13557
Job: backup-raspberry1-fd.2020-02-18_23.55.00_59
Backup Level: Incremental, since=2020-02-18 02:39:08
Client: "raspberry1-fd" 14.2.1 (12Sep14) arm-unknown-linux-gnueabihf,debian,8.0
FileSet: "RaspbianData" 2019-03-25 22:00:00
Pool: "Backup" (From Job resource)
Catalog: "MyCatalog" (From Client resource)
Storage: "Tape" (From Job resource)
Scheduled time: 18-Feb-2020 23:55:00
Start time: 19-Feb-2020 02:50:15
End time: 19-Feb-2020 02:51:21
Elapsed time: 1 min 6 secs
Priority: 10
FD Files Written: 6
SD Files Written: 6
FD Bytes Written: 705,092,857 (705.0 MB)
SD Bytes Written: 705,093,449 (705.0 MB)
Rate: 10683.2 KB/s
Software Compression: None
VSS: no
Encryption: no
Accurate: yes
Volume name(s): NIX459L6
Volume Session Id: 65
Volume Session Time: 1581695744
Last Volume Bytes: 206,314,478,592 (206.3 GB)
Non-fatal FD errors: 1
SD Errors: 0
FD termination status: OK
SD termination status: OK
Termination: Backup OK -- with warnings

2020-02-19 02:51:17 bareos-sd JobId 13557: Despooling elapsed time = 00:00:02, Transfer rate = 352.6 M Bytes/second
2020-02-19 02:51:17 bareos-sd JobId 13557: Releasing device "tapedrive-0" (/dev/tape/by-id/scsi-35005076312128141-nst).
2020-02-19 02:51:15 bareos-sd JobId 13557: Committing spooled data to Volume "NIX459L6". Despooling 705,255,505 bytes ...
2020-02-19 02:50:20 raspberry1-fd JobId 13557: Error: /home/pi/Python/FS-RS485-Sys.log: mtime changed during backup.
2020-02-19 02:50:15 bareos-dir JobId 13557: TLS negotiation failed (while probing client protocol)
2020-02-19 02:50:15 bareos-dir JobId 13557: Connected Client: raspberry1-fd at 192.168.1.26:9102, encryption: None
2020-02-19 02:50:15 bareos-dir JobId 13557: Handshake: Cleartext
2020-02-19 02:50:15 bareos-dir JobId 13557: Encryption: None
2020-02-19 02:50:15 bareos-dir JobId 13557: Sending Accurate information.
2020-02-19 02:50:15 bareos-sd JobId 13557: Spooling data ...
2020-02-19 02:50:10 bareos-dir JobId 13557: Start Backup JobId 13557, Job=backup-raspberry1-fd.2020-02-18_23.55.00_59
2020-02-19 02:50:10 bareos-dir JobId 13557: Connected Storage daemon at bareos.local.lan:9103, encryption: PSK-AES256-CBC-SHA
2020-02-19 02:50:10 bareos-dir JobId 13557: Using Device "tapedrive-0" to write.
2020-02-19 02:50:10 bareos-dir JobId 13557: Probing client protocol... (result will be saved until config reload)
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Relationships

duplicate of 0001192 resolvedarogge Authorization key rejected by Storage daemon since upgrading director and storage daemons 

Activities

jkk

jkk

2020-02-20 11:12

reporter   ~0003845

This looks like a duplicate of https://bugs.bareos.org/view.php?id=1192
Int

Int

2020-02-20 12:59

reporter   ~0003846

you are right, this really looks like a duplicate
arogge

arogge

2020-02-20 14:00

developer   ~0003847

Closed as duplicate of 0001192

Issue History

Date Modified Username Field Change
2020-02-20 11:01 Int New Issue
2020-02-20 11:12 jkk Note Added: 0003845
2020-02-20 12:59 Int Note Added: 0003846
2020-02-20 14:00 arogge Relationship added duplicate of 0001192
2020-02-20 14:00 arogge Assigned To => arogge
2020-02-20 14:00 arogge Status new => resolved
2020-02-20 14:00 arogge Resolution open => duplicate
2020-02-20 14:00 arogge Note Added: 0003847
2020-02-20 14:01 arogge Status resolved => closed